Process keeps writing to the log

Bug #1277058 reported by Alberto Milone on 2014-02-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fglrx-pxpress (Ubuntu)
Undecided
Unassigned
Precise
Critical
Alberto Milone

Bug Description

SRU request:

Please accept fglrx-pxpress 0.6~hybrid0.0.2 in precise-proposed.

[Rationale]
Because of a regression in 0.6~hybrid0.0.1, the amd-config upstart job gets stuck, and, as a result, /var/log/upstart/amd-config.log keeps growing indefinitely

[Impact]
fglrx-pxpress is installed by jockey only on systems with hybrid graphics. This issue can make a system very slow and can also cause it to run out of space.

[Test case]
1) Remove the old log:
sudo rm /var/log/upstart/amd-config.*

2) Install fglrx-pxpress 0.6~hybrid0.0.2 on a hybrid system

3) Boot the system

4) see if /var/log/upstart/amd-config.log is created (it shouldn't be)

5) check that /var/log/amd-xconfig.log exists

6) make sure that the upstart is not running any more by typing:
sudo initctl status amd-config

The correct output is "amd-config stop/waiting".

Changed in fglrx-pxpress (Ubuntu):
status: New → Invalid
Changed in fglrx-pxpress (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Alberto Milone (albertomilone)
description: updated
Changed in fglrx-pxpress (Ubuntu Precise):
status: Triaged → In Progress

Hello Alberto, or anyone else affected,

Accepted fglrx-pxpress into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/fglrx-pxpress/0.6~hybrid0.0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fglrx-pxpress (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

# amd-xconfig
# from line 148

is_laptop () {
    # We only support laptops by default,
    # you can override this check by creating
    # the /etc/force-pxpress file
    if [ -f "$force_pxpress" ]; then
        echo "yes "
    else
        if [ -n "`ls -A /sys/class/power_supply/`" ] && \
           [ -d "/proc/acpi/button/lid" ]; then
            echo "yes"
        else
            echo "no"
        fi
    fi
}

We found that somehow the string "yes" from echo command starts a yes process. There must be an interpolation of the output of this function ( is_laptop ). Editing the file and changing "yes " to something else (not a command) seems to fix the problem.
Thanks for hearing our comments !

Nahuel Sciaratta
Alejandro Panza

description: updated
Alberto Milone (albertomilone) wrote :

The fix in precise-proposed works correctly on my laptop:

:~$ ls /var/log/upstart/ | grep amd

:~$ sudo initctl status amd-config
amd-config stop/waiting

:~$ cat /var/log/amd-xconfig.log
hybrid intel+amd: no need to do anything

:~$ apt-cache policy fglrx-pxpress
fglrx-pxpress:
  Installed: 0.6~hybrid0.0.2
  Candidate: 0.6~hybrid0.0.2
  Version table:
 *** 0.6~hybrid0.0.2 0
        400 http://archive.ubuntu.com/ubuntu/ precise-proposed/universe amd64 Packages
        100 /var/lib/dpkg/status
     0.6~hybrid0.0.1 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise-updates/universe amd64 Packages

Alberto Milone (albertomilone) wrote :

it works on my multi-gpu desktop system too:

:~$ ls /var/log/upstart/ | grep amd

:~$ sudo initctl status amd-config
amd-config stop/waiting

:~$ cat /var/log/amd-xconfig.log
multi gpu system with amd(s) detected

:~$ apt-cache policy fglrx-pxpress
fglrx-pxpress:
  Installed: 0.6~hybrid0.0.2
  Candidate: 0.6~hybrid0.0.2
  Version table:
 *** 0.6~hybrid0.0.2 0
        400 http://archive.ubuntu.com/ubuntu/ precise-proposed/universe amd64 Packages
        100 /var/lib/dpkg/status
     0.6~hybrid0.0.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/universe amd64 Packages

description: updated
tags: added: verification-done
removed: verification-needed

My Laptop was affected by a filesystem full caused from this bug

I installed the fix and it works fine on my laptop

I am using Ubuntu 12.04 on my Lenovo ThinkPad
I installed : fglrx-pxpress_0.6~hybrid0.0.2_amd64.deb

ThinkPad:~$ ls /var/log/upstart/amd-config.log
ls: cannot access /var/log/upstart/amd-config.log: No such file or directory

The huge file that causing filesystem full is not more presents

:~$ sudo initctl status amd-config
amd-config stop/waiting

ThinkPad:~$ cat /var/log/amd-xconfig.log
hybrid intel+amd: no need to do anything

I just can't undestand this, because I have internal and external VGA on my laptop

ThinkPad:~$ apt-cache policy fglrx-pxpress
fglrx-pxpress:
  Installed: 0.6~hybrid0.0.2
  Candidate: 0.6~hybrid0.0.2
  Version table:
 *** 0.6~hybrid0.0.2 0
        100 /var/lib/dpkg/status
     0.6~hybrid0.0.1 0
        500 http://mirror.isoc.org.il/pub/ubuntu/ precise-updates/universe amd64 Packages

the fix is ok

Thanks all

Alberto Milone (albertomilone) wrote :

@Giovanni: that works as expected. The "hybrid intel+amd: no need to do anything" only means that it's all set.

Colin Watson (cjwatson) wrote :

Waiving the usual seven-day waiting period, since this is a pretty simple fix, it's a critical problem, and 12.04.4 is on its way any minute which would otherwise cause lots of people to run into this bug.

The verification of the Stable Release Update for fglrx-pxpress has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-pxpress - 0.6~hybrid0.0.2

---------------
fglrx-pxpress (0.6~hybrid0.0.2) precise-proposed; urgency=low

  * debian/amd-config.conf:
    - Convert to a task job, as this is just a short
      lived job.
  * amd-xconfig{.in}:
    - Fix laptop detection. This was causing the job to
      get stuck in an endless loop (LP: #1277058).
 -- Alberto Milone <email address hidden> Thu, 06 Feb 2014 14:09:34 +0100

Changed in fglrx-pxpress (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers