Dual-Monitor not working with fglrx in 12.04

Bug #966352 reported by joni on 2012-03-27
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

A few weeks ago I upgraded to 12.04 because I wanted to test it. I did the update "in 2 parts" because my computer crashed the first time. A few days ago i updated a few packages with apt-get (about 20 packages I think).

Suddenly my dual-monitor setup did not work any longer (same bug as written below), I decided to reinstall Ubuntu to get a clean OS.

Installing fglrx-updates with jockey didn't work so i installed it through the terminal.

Then i set up up my screens in amdcccle (multi-desktop). That way it worked perfectly in 11.10.
Now the only thing i got is a white primary screen and a "working" secondary screen. If my mouse enters the left screen, the cursor changes to an "X". I can right click on the blank screen and the menu opens, but i can not have any windows on the screen. I can change which monitor works either my left or my right screen by editing xorg.conf.

If I activate Xinerama in amdcccl both screens work, but i only get Unity2D automatically at login and everything feels really slow. In 11.10 both screens worked without Xinerama (i had Xinerama turned off because i have the top-bar of unity on both screen, which i don't like)

My graphics card is an AMD Sapphire 6850.

Edit: I can't remember exactly and i can't test it right now but I think with open source drivers it worked.

joni (joni93) wrote :
tags: added: fglrx multi-monitor
joni (joni93) on 2012-03-27
description: updated
David Greenway (dave9151982) wrote :

I gave gt250 and I have two monitors on it, one hooked through dvi the other through vga on the same card.. I only get video through the dvi. Windows gives me video on both. Any solution?

3.2.0-20-generic #33-Ubuntu SMP Tue Mar 27 16:42:26 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
joni (joni93) wrote :

I don't think your problem has to do with fglrx because you have a nvidia card, and fglrx is only for amd/ati.
Anyway good to hear someone else has a problem
with dual monitor.

I really need dual monitor and fglrx, hope this gets fixed soon.

Jim Rorie (jfrorie) wrote :

This is going to sound weird, but I experienced something very similar. In my case, it wasn't a white screen rather a very large window covering the entire monitor. It could not get it to go away as it wasn't showing up anywhere I could kill it. I used the force quit application and killed the window and my desktop works fine.

Joost Van Durme (joostvandurme) wrote :

I can configure dual head setup fine in amdcccle with the shipped fglrx driver, but settings are not saved at next reboot.
Bummer, no?

joni (joni93) wrote :

I don't know why, but yesterday i tried it again. Removed fglrx installed mesa again, removed mesa and installed fglrx again, and tried to set up my dual head setup again in amdcccle and IT WORKED.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments