fglrx (not installed): fglrx kernel module failed to build [KCL_fpu_begin: Error: 'TS_USEDFPU' undeclared (first use in this function)]

Bug #947871 reported by yddium on 2012-03-06
238
This bug affects 39 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
High
Unassigned

Bug Description

no such file

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: fglrx (not installed)
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
.tmp.unity.support.test.0:

.tmp.unity.support.test.1:

ApportVersion: 1.94-0ubuntu1
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CurrentDmesg:
 [ 65.089828] iwlwifi 0000:08:00.0: Tx aggregation enabled on ra = 14:e6:e4:87:69:e0 tid = 0
 [ 358.679924] iwlwifi 0000:08:00.0: Tx aggregation enabled on ra = 14:e6:e4:87:69:e0 tid = 6
DKMSKernelVersion: 3.2.0-18-generic-pae
Date: Tue Mar 6 18:00:44 2012
DistUpgraded: Log time: 2012-03-06 14:01:59.210554
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-sutton-20110422-3
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21e2]
InstallationMedia: Ubuntu 10.10 "Maverick" - Build i386 LIVE Binary 20110422-19:07
MachineType: LENOVO 1141A59
PackageVersion: (not installed)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic-pae root=UUID=72d25fd0-39bf-4eaa-885c-69113da556d8 ro acpi_osi="!Windows 2009" quiet splash vt.handoff=7
SourcePackage: fglrx-installer
Title: fglrx (not installed): fglrx kernel module failed to build
UpgradeStatus: Upgraded to precise on 2012-03-06 (0 days ago)
dmi.bios.date: 09/09/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8HET38WW(1.20)
dmi.board.asset.tag: Not Available
dmi.board.name: 1141A59
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8HET38WW(1.20):bd09/09/2011:svnLENOVO:pn1141A59:pvrThinkPadE420:rvnLENOVO:rn1141A59:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 1141A59
dmi.product.version: ThinkPad E420
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.libdrm2: libdrm2 2.4.31+git20120302.be30d350-0ubuntu0sarvatt~oneiric
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1+git20120301+8.0.a3080987-0ubuntu0sarvatt~oneiric
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1+git20120301+8.0.a3080987-0ubuntu0sarvatt~oneiric
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99+git20120302.878454ae-0ubuntu0sarvatt~oneiric
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.18.0+git20120302.aaed9e97-0ubuntu0sarvatt~oneiric
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20120113.b0d7f4dd-0ubuntu0sarvatt~oneiric

yddium (yddium) wrote :
tags: removed: need-duplicate-check
summary: fglrx (not installed): fglrx kernel module failed to build
+ [KCL_fpu_begin: Error: 'TS_USEDFPU' undeclared (first use in this
+ function)]
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

I notice a couple of warnings that look interesting (although the source code make.sh looks like valid bash to me)...

make.sh: 390: [: 1: unexpected operator
make.sh: 396: [: 1: unexpected operator

I don't think those are the source of the failure though. Unfortunately the rest of the error log is in Chinese so I can't diagnose the problem.

make[1]: 正在进入目录 `/usr/src/linux-headers-3.2.0-18-generic-pae'
  CC [M] /var/lib/dkms/fglrx/8.930/build/2.6.x/firegl_public.o
In file included from /var/lib/dkms/fglrx/8.930/build/2.6.x/firegl_public.c:192:0:
/var/lib/dkms/fglrx/8.930/build/2.6.x/kcl_debug.h:202:5: 警告: “_DEBUG”未定义 [-Wundef]
/var/lib/dkms/fglrx/8.930/build/2.6.x/firegl_public.c: 在函数‘KCL_fpu_begin’中:
/var/lib/dkms/fglrx/8.930/build/2.6.x/firegl_public.c:5802:28: 错误: ‘TS_USEDFPU’未声明(在此函数内第一次使用)
/var/lib/dkms/fglrx/8.930/build/2.6.x/firegl_public.c:5802:28: 附注: 每个未声明的标识符在其出现的函数内只报告一次
/var/lib/dkms/fglrx/8.930/build/2.6.x/firegl_public.c: 在文件作用域:
/var/lib/dkms/fglrx/8.930/build/2.6.x/kcl_debug.h:162:16: 警告: ‘module_log_map’定义后未使用 [-Wunused-variable]
/var/lib/dkms/fglrx/8.930/build/2.6.x/kcl_debug.h:175:19: 警告: ‘module_type_map’定义后未使用 [-Wunused-variable]

Bryce Harrington (bryce) wrote :

Fixed in 8.960 with patch fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch

Changed in fglrx-installer (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released

seems I am getting the same problem of make not playing nice

[code]
DKMS make.log for fglrx-8.951 for kernel 3.0.0-19-generic (i686)
Sun Apr 22 13:41:24 NZST 2012
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.0.0-19-generic/build SUBDIRS=/var/lib/dkms/fglrx/8.951/build/2.6.x modules
make[1]: Entering directory `/usr/src/linux-headers-3.0.0-19-generic'
  CC [M] /var/lib/dkms/fglrx/8.951/build/2.6.x/firegl_public.o
/var/lib/dkms/fglrx/8.951/build/2.6.x/firegl_public.c: In function ‘KCL_fpu_begin’:
/var/lib/dkms/fglrx/8.951/build/2.6.x/firegl_public.c:5804:28: error: ‘TS_USEDFPU’ undeclared (first use in this function)
/var/lib/dkms/fglrx/8.951/build/2.6.x/firegl_public.c:5804:28: note: each undeclared identifier is reported only once for each function it appears in
make[2]: *** [/var/lib/dkms/fglrx/8.951/build/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/var/lib/dkms/fglrx/8.951/build/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.0.0-19-generic'
make: *** [kmod_build] Error 2
build failed with return value 2
[/code]

justsoso8 (justsoso8) wrote :

I have the same problem with latest ubuntu update

DKMS make.log for fglrx-8.961 for kernel 3.2.0-24-generic-pae (i686)
Sat Apr 28 15:58:49 CST 2012
AMD kernel module generator version 2.1
make.sh: 390: [: 1: unexpected operator
make.sh: 396: [: 1: unexpected operator
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.2.0-24-generic-pae/build SUBDIRS=/var/lib/dkms/fglrx/8.961/build/2.6.x modules
make[1]: Entering directory `/usr/src/linux-headers-3.2.0-24-generic-pae'
  CC [M] /var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.o
/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.c: In function ‘KCL_fpu_begin’:
/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.c:5812:28: error: ‘TS_USEDFPU’ undeclared (first use in this function)
/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.c:5812:28: note: each undeclared identifier is reported only once for each function it appears in
make[2]: *** [/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/var/lib/dkms/fglrx/8.961/build/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.2.0-24-generic-pae'
make: *** [kmod_build] Error 2
build failed with return value 2

To post a comment you must log in.