After ATI driver 12.1 upgrade, can't re-login to Unity after log out was performed [fglrx]

Bug #922905 reported by bioShark on 2012-01-27
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)

Bug Description

I am using:

Description: Ubuntu 11.10
Release: 11.10

kernel issue.


Yesterday I have upgraded my ATI proprietary driver to 12.1. After some small issues it installed correctly, I have confirmation in Catalyst that the driver is at version 12.1.

Today I have noticed that after each log out, when I try to log back in, the screen freezes on my wallpaper. The mouse is working fine. CTRL-ALT-Backspace resets the Xserver, and prompts me back to the log in page. If I try a login, same thing happens. If I reboot from the login screen, I can log in into Unity 3D without any issue.

The issues happen only if I try to log-out and then back in. If I log in on Ubuntu 2D, it works fine.

Sample of output from /var/log/syslog:

gnome-session[3017]: Gdk-WARNING: gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.#012
 kernel: [ 1124.496537] [fglrx] IRQ 49 Disabled


- I have reported this problem in an askUbuntu question:
- Found similar question where filing a bug has been suggested:

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7.1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,imgjpeg,compiztoolbox,move,imgpng,gnomecompat,vpswitch,resize,grid,place,wall,regex,unitymtgrabhandles,wobbly,session,animation,expo,fade,scale,workarounds,ezoom,unityshell]
CompositorRunning: compiz
Date: Sat Jan 28 00:36:36 2012
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
 fglrx, 8.930, 3.0.0-12-generic, x86_64: installed
 fglrx, 8.930, 3.0.0-15-generic, x86_64: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
 ATI Technologies Inc RV770 [Radeon HD 4870] [1002:9440] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited Device [174b:0502]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
 xorg:fglrx_updates - ATI/AMD proprietary FGLRX graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: System manufacturer Rampage Formula
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=a1bf84d6-68a5-4550-8cfc-800316d4df25 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install) 04/03/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0308
dmi.board.asset.tag: To Be Filled By O.E.M. Rampage Formula
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0308:bd04/03/2008:svnSystemmanufacturer:pnRampageFormula:pvrSystemVersion:rvnASUSTeKComputerINC.:rnRampageFormula:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion: Rampage Formula
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

bioShark (bioshark) wrote :
Jorge Castro (jorge) on 2012-01-28
Changed in xorg (Ubuntu):
status: New → Confirmed
bioShark (bioshark) wrote :

I have reverted to the drivers 11.12 and then to 11.10 (currently using it) and the behavior is the same. The problem is that I don't remember if I had this problem before initially upgrading to 12.1 driver, or not. I would guess not, so, something is wrong here. It's not a show stopper for me, because I don't need to log-out / log-in, but still it's an error.

Bryce Harrington (bryce) on 2012-02-08
tags: added: kubuntu
bugbot (bugbot) on 2012-02-23
affects: xorg (Ubuntu) → fglrx-installer (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers