KDE taskbar (the bottom panel) doesn't respond occasionally

Bug #887933 reported by Ales on 2011-11-09
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned
kwin (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrade from Kubuntu 11.04 to 11.10 the bottom panel started to freeze every now and then. It stops working for about 1 or 2 minutes. During this time I can't switch windows (but ALT+TAB works), can't switch workspaces (but CTRL+F1 - F4 works), I'm unable to start the launcher (but ALT+F2 works) or the calendar or anything else. The whole bottom panel is out of order for some time. After a while it works again and I can see that all previous clicks are quickly processed.

The problem repeats several times a day but I haven't found any regularity or a reason why it happens.

I upgraded KDE to 4.7.3 from ppa:kubuntu-ppa/ppa, but it didn't help.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
NonfreeKernelModules: wl fglrx
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,gnomecompat,mousepoll,imgpng,resize,snap,grid,place,vpswitch,wall,regex,unitymtgrabhandles,animation,session,expo,workarounds,ezoom,fade,scale,unityshell]
CompositorRunning: kwin
Date: Wed Nov 9 09:27:26 2011
DistUpgraded: Log time: 2011-10-14 12:55:21.497371
DistroCodename: oneiric
DistroVariant: kubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-11-generic-pae, i686: installed
 bcmwl, 5.100.82.38+bdcom, 3.0.0-12-generic, i686: installed
 bcmwl, 5.100.82.38+bdcom, 3.0.0-12-generic-pae, i686: installed
 fglrx, 8.881, 3.0.0-12-generic-pae, i686: installed
EcryptfsInUse: Yes
ExtraDebuggingInterest: No
GraphicsCard:
 ATI Technologies Inc Manhattan [Mobility Radeon HD 5400 Series] [1002:68e0] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:142d]
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Release i386 (20110427)
JockeyStatus:
 xorg:fglrx_updates - Uzavřený grafický ovladač FGLRX od ATI/AMD (aktualizace po vydání) (Uzavřená, Zakázáno, Nepoužívá se)
 kmod:wl - Bezdrátový ovladač Broadcom STA (Uzavřená, Povoleno, Používáno) [auto-install]
 xorg:fglrx - Uzavřený grafický ovladač FGLRX od ATI/AMD (Uzavřená, Povoleno, Používáno)
MachineType: Hewlett-Packard HP ProBook 4525s
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic-pae root=UUID=534d86aa-1a8f-44c7-96b5-830c8d2fa944 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (25 days ago)
dmi.bios.date: 02/14/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CPK Ver. F.09
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 142D
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 51.18
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CPKVer.F.09:bd02/14/2011:svnHewlett-Packard:pnHPProBook4525s:pvr:rvnHewlett-Packard:rn142D:rvrKBCVersion51.18:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP ProBook 4525s
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
version.fglrx-installer: fglrx-installer N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Ales (w-ales) wrote :
affects: ubuntu → xorg (Ubuntu)
bugbot (bugbot) on 2011-11-10
affects: xorg (Ubuntu) → fglrx-installer (Ubuntu)
Jacek_G (wafelj) wrote :

Same situation on 3 laptops i use KUBUNTU 11.10 on all:
dell inspiron 1520 nvidia card
dell inspiron q17r intel (optimus-nvidia) card
hp g72 intel (switcheroo ati) card
Happens only when desktop effects are ON.
So i dont think that problem is connected to video card,

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Peter Snow (peter-x8o) wrote :

Affects me using:

3.2.0-39-generic-pae #62-Ubuntu SMP Wed Feb 27 22:25:11 UTC 2013 i686 i686 i386 GNU/Linux

Unfortunately, can't confirm whether it will recover, since it's still like it currently after about 15 minutes. Might need to reboot or maybe restarting KDM might fix it.

GreyGeek (greygeek77) wrote :

My panel becomes unresponsive several times an hour and this problem has been with me for several months. Any app that I have open and focused on continues to work fine. Apps that are open but not the focus can be swithed to using Alt-Tab. If I close the app that has focus the image in the taskbar stays. The panel can become responsive again in a minute or two, but sometimes it stays unresponsive.

The keyboard is always responsive. If I use Ctrl+Esc and open ksysmonitor I can rightclick on the Plasma-desktop line and send it the signal "INT". That ALWAYS reactivates the panel and desktop. Since I first noticed the problem in late July or August, the plasma desktop has crashed on my only once. Sending the "INT" always gets the panel going again.

No log shows any indication of any problem with these panel freezes and thaws.

Using Kubuntu 12.04.2
xserver-xorg-video-intel (i915)
Running KDE 4.11.2 from PPA, but previous versions of KDE had the problem.
3.8.0-32-generic #47~precise1-Ubuntu SMP Wed Oct 2 16:19:35 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
but I've used the 3.2, 3.4 and 3.6 kernels. All had the same problem.

GreyGeek (greygeek77) wrote :

Since I made my post above I have switched from Kubuntu 12.04.3 with KDE 4.11.2, which had the problem, to KWheezy 1.3 with KDE 4.8.4, to use a distro based directly off of Debian. Kwheezy, too, exhibits this problem. The "INT" trick works on it as well. KWheezy 1.3 uses the 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux kernel.

Neither stopping the apper daemon or removing NetworkManager from the system tray resolved the problem.

The problem is only a pain when I want to switch from one app to another, but Ctrl-Esc - INT makes it less painful.

GreyGeek (greygeek77) wrote :

BTW, I should add that I am NOT using the fglrx installer. Never have. My video driver for my Intel graphic chip is i915.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers