FGLRX package does not disable radeon modesetting and prevents X from starting.

Bug #827120 reported by Ryan Farmer on 2011-08-16
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

AMD's proprietary Catalyst driver "FGLRX" uses the X server to set the video mode. This behavior is incompatible with the open source radeon kernel module with attempts to set the video mode using the kernel.

If a user installs Catalyst/FGLRX and kernel mode setting is not disabled for Radeon with radeon.modeset=0 on the kernel line in GRUB, then eventually the entire system will stop booting at the point where X should be loading, and the monitor will suspend itself since nothing is sending it a video signal. At this time, the system also stops responding to the keyboard so ctrl-alt-del or other key combinations to restart the system have no effect.

Since *buntu defaults to no GRUB countdown, it is very difficult to catch it in order to change the kernel boot line to allow it to boot up to where the user can change GRUB's settings. However, the user should not ever reach this point because the FGLRX package should set radeon.modeset=0 for them.

This does not appear to be happening as of now in *buntu Oneiric.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: fglrx 2:8.872-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Tue Aug 16 01:15:26 2011
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: fglrx-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Ryan Farmer (ryanfarmer-t) wrote :
bugbot (bugbot) on 2011-08-16
tags: added: kubuntu
Paul Hoell (hoellp) wrote :

I can confirm this behavior on a new install of Kubuntu Oneiric from today, i have to manually disable modesetting so the system can boot at all.

Ubuntu seems to have this sorted, but Kubuntu still lacks this fix.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed

Same here with Kubuntu Oneiric Beta 1. Adding "radeon.modeset=0" to grub solves the problem for me.

Ryan Farmer (ryanfarmer-t) wrote :

This has been fixed for a while. Closing.

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers