Can't use dual screen 1680x1050 side-by-side with fglrx while open source radeon works

Bug #822548 reported by Olivier Mengué on 2011-08-08
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)

Bug Description

Using gnome-display-properties, I can't setup a configuration to enable my dual 1680x1050 screens setup in a side-by-side landcape configuration: gnome-display-properties says that the virtual size is not adapted to the real size (3360x1050 is bigger that maximum 1680x1050) (this is not the exact message as I can not copy it and I'm using Ubuntu in french).

However this setup works well (at least when it doesn't lock up at startup, due to bugs) with the open source radeon driver.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: fglrx 2:8.840-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic
Uname: Linux 2.6.38-10-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Mon Aug 8 09:22:28 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: fglrx, 8.840, 2.6.38-10-generic, x86_64: installed
EcryptfsInUse: Yes
 ATI Technologies Inc RV620 LE [Radeon HD 3450] [1002:95c5] (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0342]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
JockeyStatus: xorg:fglrx - Pilote graphique FGLRX propriétaire pour ATI/AMD (Propriétaire, Activé, En cours d'utilisation)
MachineType: Dell Inc. OptiPlex 380
 PATH=(custom, user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=68623e2f-0116-42d1-af2e-e6280e81625a ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: fglrx-installer
UpgradeStatus: No upgrade log present (probably fresh install) 02/24/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05 01TKCC
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 15
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd02/24/2011:svnDellInc.:pnOptiPlex380:pvr:rvnDellInc.:rn01TKCC:rvrA01:cvnDellInc.:ct15:cvr: OptiPlex 380
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Also evident in Ubuntu 11.10 with both Radeon HD 4850 and Radeon HD 5840

Olivier Mengué (dolmen) wrote :
Olivier Mengué (dolmen) wrote :

Here is the xrandr output:

    $ xrandr --output DFP1 --right-of DFP2
    xrandr: screen cannot be larger than 1680x1680 (desired size 3360x1050)

Bryce Harrington (bryce) wrote :

Hey dolmen,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in fglrx-installer (Ubuntu):
status: New → Incomplete
description: updated
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Expired
Olivier Mengué (dolmen) wrote :

I'm reopening the bug because Alex Liam confirmed that the bug is still on 11.10.

Changed in fglrx-installer (Ubuntu):
status: Expired → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers