Ubuntu

Hybrid Graphics with Intel+fglrx is not supported

Reported by Guillaume Modard on 2011-07-20
268
This bug affects 51 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Medium
Chris Halse Rogers
Oneiric
Undecided
Unassigned
Precise
Medium
Chris Halse Rogers
fglrx-installer-updates (Ubuntu)
Undecided
markackerman8@gmail.com
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

I upgrade to Ubuntu 11.10 because of this bug that has not been solved in Ubuntu 11.04 (this bug do not affect Ubuntu 11.10) :
https://bugs.launchpad.net/bugs/727620

I tried to install ATI proprietary driver in 11.10, restart computer... and Unity 2D start, but no Unity 3D. Finally only free graphic driver works correctly to gets 3D and desktop fx.

This bug also affect Ubuntu 11.04 .

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: fglrx (not installed)
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unitydialog,unityshell]
CompositorRunning: compiz
Date: Wed Jul 20 23:49:26 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: bcmwl, 5.100.82.38+bdcom, 3.0.0-5-generic, x86_64: installed
GdmLog:

GdmLog1:

GdmLog2:

GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:163c]
 ATI Technologies Inc Robson CE [AMD Radeon HD 6300 Series] [1002:68e4] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:163c]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110719)
MachineType: Hewlett-Packard HP Pavilion dv6 Notebook PC
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-5-generic root=UUID=d3d8d1a1-6b53-4523-a971-38a6ae7f7858 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: fglrx-installer
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/21/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.23
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 163C
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 65.35
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.23:bd10/21/2010:svnHewlett-Packard:pnHPPaviliondv6NotebookPC:pvr0589120000242B10010020100:rvnHewlett-Packard:rn163C:rvr65.35:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6 Notebook PC
dmi.product.version: 0589120000242B10010020100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.5.0-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11~1-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11~1-0ubuntu4
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0-3ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Bryce Harrington (bryce) wrote :

 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:163c]
 ATI Technologies Inc Robson CE [AMD Radeon HD 6300 Series] [1002:68e4] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:163c]

Is your laptop a hybrid graphics system?

Changed in fglrx-installer (Ubuntu):
status: New → Incomplete

I've investigate a little bit more this bug.

Actually, I haven't installed ATI proprietary driver. So I use only free drivers.

Here is the result of some command :

guillaume@guillaume-notebook:~$ glxinfo | grep enderer
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile

According to glxinfo, render is done by the Intel integrated card.

guillaume@guillaume-notebook:~$ grep /drivers/ /var/log/Xorg.0.log
[ 24.493] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 24.519] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 24.540] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 24.543] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so

Here, no radeon or radeonHD driver is loaded.

guillaume@guillaume-notebook:~$ lspci -v | grep -A 12 VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Device 163c
 Flags: bus master, fast devsel, latency 0, IRQ 43
 Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
 Memory at b0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at 5050 [size=8]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915

00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
 Subsystem: Hewlett-Packard Company Device 163c
--
01:00.0 VGA compatible controller: ATI Technologies Inc Robson CE [AMD Radeon HD 6300 Series] (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Device 163c
 Flags: bus master, fast devsel, latency 0, IRQ 45
 Memory at a0000000 (64-bit, prefetchable) [size=256M]
 Memory at c4400000 (64-bit, non-prefetchable) [size=128K]
 I/O ports at 4000 [size=256]
 Expansion ROM at c4440000 [disabled] [size=128K]
 Capabilities: <access denied>
 Kernel driver in use: radeon
 Kernel modules: radeon

01:00.1 Audio device: ATI Technologies Inc Manhattan HDMI Audio [Mobility Radeon HD 5000 Series]
 Subsystem: Hewlett-Packard Company Device 163c
guillaume@guillaume-notebook:~$

Finally, lspci show the ATI graphic card and says : "Kernel driver in use: radeon"

What does it mean ? Does the ATI card is used or not ?

When I install proprietary driver, Catalyst says something like "no graphic card"...

I'm not sure this bug has really been solved : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/727620 and https://bugzilla.kernel.org/show_bug.cgi?id=30052

I'm not a specialist... is it a Kernel bug ? or Xorg bug ? ....

Note : since the last update, I'm not able to install ATI proprio driver because of this bug :
https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/720343

slomobile (slogmobile) wrote :

I can confirm this bug on a Dell Vostro 3550 i5 processor thus integrated graphics and discrete ATI. This is supposedly an Ubuntu Certified machine but have been unable to locate any version that actually works on it. Currently trying 11.10 all updates current as of August 4th 2011.
System info says graphics unknown
Catalyst says no driver installed
apt-get install fglrx says fglrx is already the newest version.
glxinfo causes segmentation fault
Additional drivers says ATI/AMD proprietary FGLRX graphics driver is activated and in use.

slomobile (slogmobile) wrote :

slo@slomobile3:~$ aticonfig
aticonfig: No supported adapters detected
slo@slomobile3:~$ sudo lspci -v > lspciOutput.txt
-file attached-

If any logs or other information would be helpful just ask me for it.
In your request for further info please include the command line you would like typed.

slomobile (slogmobile) wrote :
Changed in fglrx-installer (Ubuntu):
importance: Undecided → High
Bryce Harrington (bryce) wrote :

slomobile, one issue per bug report please, you should post your crash as a separate bug report.

Bryce Harrington (bryce) wrote :

Hybrid graphics is not supported in Ubuntu at this time.

There are some (unsupported) ways to manually set up hybrid graphics systems or using experimental upstream utilities... see the forums or askubuntu for tech support on how to do this.

summary: - fglrx do not works : HP notbook dv6 - AMD Radeon HD 6300 Series
+ Hybrid Graphics with Intel+fglrx is not supported
Changed in fglrx-installer (Ubuntu):
importance: High → Wishlist
status: Incomplete → Confirmed
status: Confirmed → Triaged
Bartosz Zasieczny (siekacz) wrote :

I don't understand why this bug is marked as triaged. Triaging means that we know what is the cause of some bug. Currently we don't. And it's not only supporting hybrid graphics, but at least running correctly the fglrx correctly. Explanation, that "we don't support blah-blah-blah...", is no explanation.

insan3 (jurgen-insan3) wrote :

I have this exact same issue on a desktop PC with a Intergrated HD3300 card (no dual graphic card or switchable graphics) so the issue is with the AMD driver I guess?

TS (dreammaster-max) wrote :

I have this issue on core i5 with mobility radeon hd 5000 series and intel integrated graphics. I get the powerxpress error, which I don't see listed here, but is listed on https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/852355 which is marked as a duplicate of this bug.
This page https://bbs.archlinux.org/viewtopic.php?pid=937766#p937766 and this page https://bbs.archlinux.org/viewtopic.php?id=119291 list possible solutions and workarounds that seem to indicate the archlinux community has experienced and fixed this issue. Perhaps someone more able could apply this to Ubuntu?

Rob A (docsmooth) wrote :

ATI Radeon HD3650 / Intel i915 combo on a Lenovo Thinkpad T500. Kubuntu 10.04, 10.10, 11.04 all worked with this hardware and both the free fglrx and the proprietary fglrx.

When I upgraded to 11.10, I did a wipe/reinstall combo of /root (kept only /home). Now proprietary and free fglrx both do not work, but "radeon" module does. i915 still works.

Rebooting into previous 2.6.38 kernel does not help.

Bryce Harrington (bryce) on 2011-11-04
Changed in fglrx-installer (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
Bryce Harrington (bryce) wrote :

Hey guillaumemodard,

Hi, thanks for reporting this issue during the development period of
Ubuntu.

I notice there's not been further comments to the bug report since the
release came out, would you mind updating us on the status of it in the
release?

Are you still able to reproduce the issue? If not, do you think the bug
report can be closed, or do you think we should continue tracking it?

Changed in fglrx-installer (Ubuntu):
status: Triaged → Incomplete
Chris Halse Rogers (raof) wrote :

It should be possible to do intel+fglrx, although I don't believe that it's currently well exposed in our tools.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Triaged
importance: Wishlist → Medium
Miloš Jakovljević (milos-sd) wrote :

I installed FGLRX drivers, and after that Xserver is not starting. Here is he Xorg.0.log: http://pastebin.com/hsnCw47g

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.911-0ubuntu1

---------------
fglrx-installer (2:8.911-0ubuntu1) precise; urgency=low

  * New upstream release (11-11).
  * debian/fglrx.install.in, debian/fglrx.dirs.in,
    debian/fglrx.links.in ,debian/fglrx.postinst.in,
    debian/rules:
    - Install OpenCL libraries.
    - Make sure to use the multiarch path to the Mesa libraries.
      This (partially) solves an issue with PXpress which couldn't
      find the Mesa libraries (LP: #813809).
 -- Alberto Milone <email address hidden> Fri, 25 Nov 2011 15:11:02 +0100

Changed in fglrx-installer (Ubuntu Precise):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu Oneiric):
status: New → Confirmed

Hello Guillaume, or anyone else affected,

Accepted fglrx-installer-updates into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Changed in fglrx-installer-updates (Ubuntu Oneiric):
status: New → Fix Committed
Changed in fglrx-installer-updates (Ubuntu Precise):
status: New → Fix Released
Chris Halse Rogers (raof) wrote :

Alberto: Do you intend to fix this in fglrx-installer in Oneiric as well? If so, we can keep that bug task open. If not, please close it ☺.

Bartosz Zasieczny (siekacz) wrote :

On Radeon 6630M (dell vostro 3450) Xserver still segfaults when ran. Problems with linking seem to be solved. If you want more information, just tell me what to paste here.

Miloš Jakovljević (milos-sd) wrote :

Still a problem with Radeon 6490M and Intel SandyBridge Mobile (GT2). Xorg.0.log is the same as I posted at comment #17
http://pastebin.com/hsnCw47g

Ochir (oabushinov) wrote :

After installing from proposed problem still exists. Boot stops at "Checking battery state...".
I have Radeon HD Mobility 5450 + Intel integrated graphics on my laptop.

Alberto Milone (albertomilone) wrote :

@Chris: a fix from upstream will still be required. I only fixed a packaging issue

Changed in fglrx-installer (Ubuntu Precise):
status: Fix Released → Triaged
Changed in fglrx-installer-updates (Ubuntu Precise):
status: Fix Released → Triaged
TS (dreammaster-max) wrote :

Can someone please assist me in testing the fix? I'm not sure how to get the correct repositories enabled, pull the correct packages without running into conflicts, what steps to follow to test video and what log files to check, etc.

I mentioned previously that https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/852355 is marked as a duplicate of this bug. That seems to be incorrect and I'm going to see about removing the duplicate status.

Matej Moško (gnaag) wrote :

I have exactly the same problem. I fear TS that fix above is not really a fix. According to my research the problem si in the driver itself. The only workaround is to use opensource driver or to disable amd graphics and then use open source driver for intel graphics. Either way it is not expected behaviour. The laptop I bought was intended for games. Now it is nothing more than office machine.

There are some rumors 11.12 catalyst should cope with the problem, but it is not verified. If I am wrong, please correct me. Thanks.

Miloš Jakovljević (milos-sd) wrote :

Does anyone know if this bug is fixed in fglrx 11.12 version?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:8.911-0ubuntu0.1

---------------
fglrx-installer-updates (2:8.911-0ubuntu0.1) oneiric-proposed; urgency=low

  * New upstream release (11-11) (LP: #894802).
  * debian/fglrx-updates.install.in,
    debian/fglrx-updates.dirs.in,
    debian/fglrx-updates.links.in,
    debian/fglrx-updates.postinst.in, debian/rules:
    - Install OpenCL libraries.
    - Make sure to use the multiarch path to the Mesa libraries.
      This (partially) solves an issue with PXpress which
      couldn't find the Mesa libraries (LP: #813809).
 -- Alberto Milone <email address hidden> Fri, 25 Nov 2011 16:38:06 +0100

Changed in fglrx-installer-updates (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Chris Halse Rogers (raof) wrote :

It appears that the Precise fglrx works; or, rather, no longer crashes on startup. Now it just says that PXpress is not supported on my A+I muxed system. Which seems odd, because as far as I'm aware this laptop doesn't *have* a mux.

Miloš Jakovljević (milos-sd) wrote :

I have something else to add to this bug report. I noticed something new in syslog:

[drm:intel_dms_platform_mux_info] *ERROR* MUX INFO call failed

Xorg.0.log is the same as before: http://pastebin.com/hsnCw47g

Difernce from last time I tried is 3.2-rc7 kernel and ati 11.12 driver version.

The bug is tracked here: https://bugzilla.redhat.com/show_bug.cgi?id=709115

SicilyBoy (caffe90) wrote :

Chris, i am in the same situation.
Have you found any solutions?

Chris Halse Rogers (raof) wrote :

I don't think my problem has any solutions except for waiting for AMD to release a fglrx that supports this laptop. FGLRX looks like it's working fine, it just claims to not support my hardware.

@luca-casagrande

I tried it with an Envy 14 1st gen. Intel Ironlake/HD5650. It failed like 11.11. Some people reported success with an Envy 14 2nd gen (Sandy Bridge/HD6670) though.

I tried it with an HP dv6-6185ex. It failed with PXpress is not supported on my A+I muxed system

carlosv (carlosved) wrote :

According to the Linux Hybrid Graphics blog, the Catalyst 12.1 fully supports Hybrid (Switchable) graphics ATI/Intel. Check http://linux-hybrid-graphics.blogspot.com/. And according to this guy: http://ubuntucomputing.blogspot.com/2012/01/amd-catalyst-121-driver-on-hp-pavilion.html , it works on HP dv6. I will give it a shot next week. And report a feedback.

carlosv (carlosved) wrote :

Hi, I just tried the Catalyst 12.1 in my HP touchsmart tm2 Intel/ATI. It did not even let start the lightdm. I had to uninstall. Maybe next Catalyst.

Miloš Jakovljević (milos-sd) wrote :

I tried 12.1 version on HP ProBook 4530s and it works. At least AMD card works with full direct rendering. When I switch to Intel from amd CCC, I don't have direct rendering for some reason. But, AMD card works and that is almost good enough for me. :D

carlosv (carlosved) wrote :

Hi, again. Just to add that according to the forum: http://ubuntuforums.org/showthread.php?t=1930450 it is working for some the hybrid ATI/Intel with the fglrx. Seems that on the next Ubuntu 12.04 it is a great chance that this may work.

@Milos_SD
On this foroum: http://phoronix.com/forums/showthread.php?69880-real-fglrx-12-3-released/page3 on the comment #25, seems a possible solution for the Intel direct rendering. Seems to be a problem with the path to the folder for the Intel driver is incorrect by default. Seems to modify the path solves the problem.

I eagerly looking forward to the new Ubuntu and try the new fglrx.

Alexandru Bucur (melipse) wrote :

Quantal + latest updates + Ati 12.11 beta drivers. on Lenovo G770 (intel hd 3000 + radeon 6770)

I had to follow this http://ubuntuforums.org/showpost.php?p=12324761&postcount=503 to make the intel drive behave nicely.

Nick Andrik (andrikos) wrote :

For your information and people coming to this bug report, you can take a look on the workaround of this bug:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1068404

It's practically what Alexander posted above.

benste (benste) wrote :
benste (benste) wrote :

so the main issue is the INTEL driver

Changed in fglrx-installer-updates (Ubuntu):
status: Triaged → Confirmed
assignee: nobody → markackerman8@gmail.com (markackerman8)
Nick Andrik (andrikos) wrote :

For anyone wanting to work on this issue, you might want to take a look on these bugs:

https://bugs.launchpad.net/ubuntu/+bug/1068404
This was about the initial X-server crash and it was an incompatibility of the fglrx driver with the intel one.
The solution is to install fglrx > 13.1+ which should prevent that error form happening.
You can follow the full discussion on the bug, or take a summary in the attached novell bug:
 https://bugzilla.novell.com/show_bug.cgi?id=780672

After fixing the above bug, there is another of periodic crashes (but not segmentation faults) which is described here:
https://bugs.launchpad.net/fglrx/+bug/1088220
It seems to be provoked by an invalid key in the amdpcsdb database, a workaround is included in the bug description (and the atached ati bug).

Good luck!

PS: I can no longer help on these bugs unfortunately as I do not access to an fglrx/intel system any more :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.