fglrx 2:8.840-0ubuntu4 fails to build against 2.6.39 kernels, due to missing linux/smp_lock.h

Bug #776895 reported by George Drak on 2011-05-04
346
This bug affects 50 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
High
Alberto Milone
Oneiric
High
Alberto Milone

Bug Description

Update to oneric from natty. fglrx don't work.

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: fglrx 2:8.840-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.39-0.5-generic 2.6.39-rc5
Uname: Linux 2.6.39-0-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Wed May 4 10:45:49 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
ErrorMessage: fglrx kernel module failed to build
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
PackageVersion: 2:8.840-0ubuntu4
SourcePackage: fglrx-installer
Title: package fglrx 2:8.840-0ubuntu4 failed to install/upgrade: fglrx kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

George Drak (sonicgd) wrote :
George Drak (sonicgd) wrote :

In make.log:

fatal error: linux/smp_lock.h: No such file or directory

It's because you're using a very recent kernel. Quick workaround: http://idratherhack.blogspot.com/2011/04/nvidia-drivers-fail-without-smplockh.html

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
George Drak (sonicgd) wrote :

No, it doesn't help. Now it says "SPIN_LOCK_UNLOCKED undeclared" and after i use this workaround (http://qemu-forum.ipi.fi/viewtopic.php?f=16&t=1409) it says "implicit declaration of function ‘lock_kernel’"

Bryce Harrington (bryce) wrote :

Oh goodness, don't do that.

The nvidia driver is only released to work with a specific kernel version, 2.6.38. Installing it with 2.6.39 is going to be a path of woe until they post an updated driver to support .39.

The best workaround for now is to downgrade to the natty 2.6.38 kernel (and kernel header files) if you wish to use nvidia.

We'll update nvidia when we get a new build.

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Won't Fix
Bryce Harrington (bryce) wrote :

And by 'nvidia' I mean 'fglrx' of course. :-P

summary: - package fglrx 2:8.840-0ubuntu4 failed to install/upgrade: fglrx kernel
- module failed to build
+ fglrx 2:8.840-0ubuntu4 fails to build against 2.6.39 kernels, due to
+ missing linux/smp_lock.h
Bryce Harrington (bryce) wrote :

Actually, others are probably going to run into this problem, so let's leave this bug open so we can link dupes to it.

@Alberto, is there a way we can work around this locally until a .39 supporting -fglrx is available?

Changed in fglrx-installer (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: Won't Fix → Triaged
Robert Hooker (sarvatt) wrote :

I've uploaded a fglrx 8.850 (11.5) release patched to work with 2.6.39 kernels to oneiric and natty that can be used until it is fixed in the archive to:

https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

It is version 2:8.850-0ubuntu1~xup2 (or higher) and will take a bit to build and be published. Please let me know if it works, I only compile tested it.

Finn10111 (finn-christiansen) wrote :

Hey Robert,

thank you for releasing a patched version! With that version of fglrx compiling works fine and i got kernel 2.6.39 working under natty.

DavidJB (davidjb) wrote :

I can confirm that the fglrx version in Ubuntu-X PPA works for me under 2.6.39-0 with natty - thanks for that!

Timo Witte (spacefish) wrote :

installs fine under oneiric, no build problems!

Building for architecture x86_64
Building initial module for 2.6.39-3-generic
Done.

fglrx.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/2.6.39-3-generic/updates/dkms/

depmod......

DKMS: install Completed.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 774668, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Brian Murray (brian-murray) wrote :

Sorry about that this one should be the master bug since it has had the most work done to it.

Alberto Milone (albertomilone) wrote :

I've patched 8.850 to make it build with Linux 3.0, therefore you shouldn't have this issue any more in Oneiric.

Changed in fglrx-installer (Ubuntu Oneiric):
status: Triaged → Fix Released

it seems to crash gdm when doing full screen games like the mana world. and sometimes when the screen is captured by sudo or gksu or gksudo.

David Klasinc (bigwhale) wrote :

Version 8.861 fails to install on current Oneiric daily build. Here's the relevant error:

Setting up fglrx (2:8.861-0ubuntu2) ...
update-alternatives: renaming x86_64-linux-gnu_xorg_extra_modules slave link from /usr/lib/x86_64-linux-gnu/xorg/extra-modules to /usr/lib/xorg/extra-modules.
update-alternatives: using /usr/lib/fglrx/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
update-alternatives: error: unable to make /usr/lib/dri/fglrx_dri.so.dpkg-tmp a symlink to /etc/alternatives/x86_64-linux-gnu_fglrx_dri: No such file or directory
dpkg: error processing fglrx (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of fglrx-amdcccle:
 fglrx-amdcccle depends on fglrx; however:
  Package fglrx is not configured yet.
dpkg: error processing fglrx-amdcccle (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 fglrx
 fglrx-amdcccle

I tried installing 8.850 version, but it fails because of lib-mesa-glx:

 libgl1-mesa-glx (7.10.3-0ubuntu4) breaks fglrx (<= 2:8.850-0ubuntu1) and is installed.

To post a comment you must log in.