amdcccle crashed with SIGSEGV in QWidget::ungrabGesture()

Bug #753312 reported by bob lourie on 2011-04-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Appears very similar to Bug #747246. Upgrade to sys 15 minutes earlier, restarted after activating FGLRX, submitted auto bug report re nautilus going down, then window pooped up advising of this crash. I ran through the screensavers before beginning to report and motion is slower than I would expect. If required please forward to amd driver maintainers
cheers
bob

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: fglrx-amdcccle 2:8.840-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Thu Apr 7 20:52:19 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: fglrx, 8.840, 2.6.38-8-generic, x86_64: installed
ExecutablePath: /usr/lib/fglrx/bin/amdcccle
GraphicsCard:
 ATI Technologies Inc RS880 [Radeon HD 4200] [1002:9710] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. M4A785TD Motherboard [1043:83a2]
JockeyStatus: xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: System manufacturer System Product Name
ProcCmdline: amdcccle
ProcEnviron:
 LANGUAGE=en_NZ:en
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=6b7a52ac-f416-448f-bfc2-6a7fbfc672d3 ro quiet splash vt.handoff=7
Renderer: Unknown
SegvAnalysis:
 Segfault happened at: 0x7fb2ef91068b: cmp 0x8(%r10),%ecx
 PC (0x7fb2ef91068b) ok
 source "0x8(%r10)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: fglrx-installer
StacktraceTop:
 ?? () from /usr/lib/libQtGui.so.4
 ?? () from /usr/lib/libQtGui.so.4
 QWidget::ungrabGesture(Qt::GestureType) () from /usr/lib/libQtGui.so.4
 QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
 QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
Title: amdcccle crashed with SIGSEGV in QWidget::ungrabGesture()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin audio cdrom dialout fax fuse lpadmin netdev plugdev sambashare tape video
XsessionErrors:
 (<unknown>:1465): libindicator-WARNING **: Shortcut Group does not have key 'TargetEnvironment' falling back to deprecated use of 'OnlyShowIn' and 'NotShowIn'.
 (nautilus:1626): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (nautilus:1626): GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion `format != NULL' failed
dmi.bios.date: 12/22/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0512
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4A785TD-V EVO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0512:bd12/22/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4A785TD-VEVO:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4+bzr20110406-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs 20090808ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

bob lourie (lourie) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #747246, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers