unity rendering broken with fglrx (black masks)

Bug #748137 reported by Jean-Baptiste Lallement on 2011-04-02
210
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
fglrx-installer (Ubuntu)
High
Unassigned
Natty
High
Unassigned
unity (Ubuntu)
High
Canonical Desktop Experience Team
Natty
High
Canonical Desktop Experience Team

Bug Description

With latest unity and fglrx many areas of the screen are black (see attached screenshot)
The black window in the middle of the screen is an xterm

Graphics Card:
01:00.0 VGA compatible controller: ATI Technologies Inc Juniper [Radeon HD 5700 Series]

$ apt-cache policy fglrx unity
unity:
  Installed: 3.8.2-0ubuntu1
  Candidate: 3.8.2-0ubuntu1
  Version table:
 *** 3.8.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status
fglrx:
  Installed: 2:8.840-0ubuntu1
  Candidate: 2:8.840-0ubuntu1
  Version table:
 *** 2:8.840-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ natty/restricted amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: fglrx 2:8.840-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Sat Apr 2 11:51:47 2011
DistroCodename: natty
DistroVariant: ubuntu
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: fglrx-installer
UpgradeStatus: No upgrade log present (probably fresh install)
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu1

Related branches

Jean-Baptiste Lallement (jibel) wrote :
John Dandison (jdandison) wrote :

I upgraded from 10.10 - 11.04. The GNOME desktop (Ubuntu Classic) works fine; the Unity one does not. It appears that anything drawn on the screen will end up masked in black, like the screenshot. My versions of fglrx & unity are identical to those above.

Jean-Baptiste Lallement (jibel) wrote :

John, thanks for confirming.

What's your graphics card ? Could you please open a terminal and paste the output of:
lspci|grep VGA

Thanks in advance.

description: updated
Changed in fglrx-installer (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu Natty):
importance: Undecided → High
status: New → Confirmed
summary: - unity rendering broken with fglrx
+ unity rendering broken with fglrx (black masks)

ok this is the same bug I report this morning:

https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/748123

my vga is an AMD Radeon HD 4250

Changed in unity (Ubuntu Natty):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Benjamin Schmid (benbuntu) wrote :

Same problem here on a Thinkpad Edge 11: After upgrading to 11.04 with an active fglrx driver Ubuntu boots into a non-working unity workspace.

As experienced user I was able to blindly logout (autologin) and change session type to Gnome classic. This may be an problematic issue for users relying on a graphical interface.

01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200]

Saad Inam (thatguy-akabob) wrote :

I have the exact same problem. I upgraded from 10.10 to 11.04 and there are patches of black everywhere. I am using an ATI HD 5450.

Joseph Parsons (freezewarp) wrote :

I wouldn't normally opine into something like this, but on the off-chance that it could be a possible cause:

Graphics Card: 01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200]
Computer: Compaq Presario CQ62
OS: Ubuntu 11.04 Beta 1 x86_64

I installed the FGLRX driver earlier today, and found it generally has issues with more or less everything OpenGL, proceeded to remove it, looked a bit into modprobe.d, and commented/removed two lines (one or both of which I may have added myself when I first installed 10.10):
/etc/modprobe.d/blacklist.conf: "blacklist fglrx"
/etc/modprobe.d/blacklist-framebuffer.conf: "blacklist radeonfb"

I likewise modified xorg.conf to use fglrx, though this may have been unnecessary:
Section "Screen"
        Identifier "Default Screen"
        DefaultDepth 24
EndSection

Section "Module"
        Load "glx"
EndSection

Section "Device"
        Identifier "Default Device"
        Driver "fglrx"
EndSection

At any rate, its just a possible cause; I had also prior to the installation of FGLRX had xorg-edgers installed (apt purged it before doing any of this, though), and the machine itself was an upgrade over 10.10. Likewise, I have yet to be able to run Unity for whatever reason [well, actually, the 11.04 upgrade screwed up the /usr/bin/xsessions directory for some reason; prefer KDE anyway].

dart (dart-v85) wrote :

You need to install latest compiz from daily build that have a fix for it. After installing latest compiz from daily build PPA (this version will land in natty soon) you will not get this issue anymore. However the entire unity interface is extremely laggy which was not the case with unity with open source drivers.

Saad Inam (thatguy-akabob) wrote :

@dart please explain more, I don't quiet understand what I should do to fix this issue. I reinstalled compiz and now on the ubuntu screen, it doesn't go black but there no longer is the top bar, aswell as the launcher on the side. can you tell me step by step what you did?

dart (dart-v85) wrote :

Add the daily build PPA from here: https://launchpad.net/~unity/+archive/daily. Fully update your system. Log into unity session. If nothing comes on screen, try logging out again. You will eventually see unity interface. Also be prepared to run the command: compiz --replace for crashes.

But take a note that your eyes will bleed because unity will be extremely laggy. I don't know what is causing it. So I purged the PPA and now I am happy with classic desktop.

Once this fglrx patch lands in next compiz release in natty, I will file a separate bug for laggy unity.

To clarify the sequence of events: X had a change, which required a
change in the binary driver from ATI. That's landed now, and so compiz
(which is the framework underpinning Unity) needs a change to use it,
the change is in a PPA but not yet landed in the main archive. Dart is
saying that, with the updated compiz and fglrx, Unity runs, but slowly.
We will look at that as soon as compiz is landed.

Mark

dart (dart-v85) wrote :

Thanks for clearing it up. Can't we have a minor compiz release asap, may be only with fglrx patch so that we can have more time for testing?

Mark Shuttleworth (sabdfl) wrote :

You can get it from the daily PPA, aiui, and it will land in the archive
early this week.

axel (simon-simonfoley) wrote :

I followed the instructions and updating from the unity daily PPA resolved the issues with corrupted black windows on my HD 6870 with proprietary fglrx. Wow unity is a shock! Pleasantly surprised! :-)

 I will now try it on my older Laptop with an RS690M Radeon X1200 integrated chipset.

@ axel:

do you observe any slowness in unity, as dart mentioned before?

Frà

akatdim (akatdim) wrote :

I updating unity from PPA too and had slowness only when I move window. Launcher and another applications\animations works fine.
HD2600(mobility)

Arnaud Soyez (weboide) wrote :

Not sure if this is related... but I'm getting the same type of issue with Flash animations inside Firefox.

Grant B (lymera1n) wrote :

I experienced the above bug and applied the PPA patch, and all is good. Although it is slow, it is atleast useable now.

Saad Inam (thatguy-akabob) wrote :

@dart .Thanks, I updated and did exactly like you mentioned. Unfortunately Unity still does not display. I tried the command compiz --replace, but it still produced no result.

Saad Inam (thatguy-akabob) wrote :

I restarted the computer as well as reinstalling Compiz. ran the command once again.

Desktop:~$ compiz --replace
libcompizconfig: dlopen: /usr/lib/compizconfig/backends/libgconf.so: cannot open shared object file: No such file or directory

Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend : ini
Integration : true
Profile : unity
Adding plugins
Initializing core options...done
Initializing bailer options...done
Initializing detection options...done
Initializing composite options...done
Initializing opengl options...done
Initializing decor options...done
Initializing place options...done
Initializing gnomecompat options...done
Initializing grid options...done
Initializing move options...done
Initializing resize options...done
Initializing wobbly options...done
Initializing fade options...done
Initializing scale options...done
Couldn't find a perfect decorator match; trying all decorators
Found no decorator to start

Saad Inam (thatguy-akabob) wrote :

even when it finds the unity decorator. it doesn't load.

Jay Taoko (jaytaoko) wrote :

You need to get the Unity and Compiz from the daily PPA. Also, there is a fix in the fglrx driver, but it has not been loaded into Jockey yet. However you can get the fglrx driver from the Ubuntu archive.

Here is some information you need: https://wiki.ubuntu.com/DesktopExperienceTeam/UnityWithFglrxBeta

As for the lags you may you observe, there are some issues with vsync and the fglrx driver. We are working on them. In the mean time, deactivate Compiz vsync control in the control panel for the OpenGL plugin. Also deactivate vsync in the fglrx control panel. See if you get some improvements.

Saad Inam (thatguy-akabob) wrote :

okay, I've gotten it working with reinstalling unity and then following the steps provided by dart and Jay. It works. Although I don't notice a great amount of lag. just confirming that the black patches are removed with the daily build. Thanks Dart and Jay.

axel (simon-simonfoley) wrote :

Sorry I was working late and I have just got back home. Francesco Miglietta asked me if I was experiencing slowness.
I have two machines.
1 x Laptop AMD L110 1.2GHz, 2GB Ram with ATI X1200 R690 Integrated Graphics ... that is upgrading now and is the target audience of Unity. I'll let you know in 1 hr about the performance.

1 x OpenCL Dev Workstation Sandy Bridge 3.4 GHz Quad,16 GB Ram ATI HD 6870 .. This has been upgraded to Unity and daily PPA + Ubuntu's version of the ATI fglrx proprietary driver.

The black window rendering has now been resolved. As for performance, its fine but then it should be on this system. However I can not test it properly because I keep having to reboot into fail-safe windows graphics mode. This is because there is an issue with the window title bars not being rendered at all in Unity so you can not move the windows around. The Text Tool Bar (File, Menu etc ) Appear in the Unity Top Panel so you can exit the app and reboot, but you can not minimise or maximise App windows.

I do not think this is a Unity issue because even in Compiz Cube, the Top Gnome Panel does not even appear, when you rotate the cube ... it appears that the rotation is not a cube, but a flat 2d desktop that rotates around a central axis. Strange.

laptop almost upgraded will update soon on performance.

axel (simon-simonfoley) wrote :

Right .... I have upgraded my laptop to 11.4 & Unity.
I was unable to use the fglrx driver as I do not believe that the R690M X1200 is supported any more (Thanks ATI).

To get Unity working I used a I manual xorg.conf and used the radeon driver as I did in 10.10. Previously I had to use radeon.modeset=0 as a kernel argument in grub to avoid screen corruption. This time in 11.4 I had to remove the boot arg to get Unity to initialize.

It works ... and I must say, yes it appears sluggish. The latency appears to be the time from clicking on the icon in the Ubuntu side bar to the window for the app appearing on the desktop. There is also a lot of screen corruption around the fonts that is triggered when I launch the 64bit Firefox (makes the system completely unusable & needs a reboot). I do not get the issue when I launch 32 bit firefox.

Strangely enough the same issues I have using the Desktop with the HD 6870 occur on the laptop, such as missing gnome top panel in Compiz Cube. Also in Unity there are missing windows title bars.

Sounds like these are all Compiz errors?

Keep up the good work with Unity guys, when it works it has lots of promise to get the newbies on board!

I have a ATI X1900 and HD 3450 lying around, let me know if you want me to do some more specific testing.

Thx
Axel

dart (dart-v85) wrote :

The screen curruption that you are talking about, I am getting that in
firefox 4 32bit version too, specially while playing flash video and with
add-on/toolbar icons (both in unity as well as classic mode).
This corruption does not happen with chromium. Also I was experiencing the
sluggishness exactly the way you explained. At time titlebars in unity gets
missing and I have to do compiz --replace which fixes the issue.

Sam Spilsbury (smspillaz) wrote :
Download full text (3.7 KiB)

On Tue, Apr 5, 2011 at 5:23 AM, axel <email address hidden> wrote:
> Sorry I was working late and I have just got back home.  Francesco Miglietta asked me if I was experiencing slowness.
> I have two machines.
> 1 x Laptop AMD L110 1.2GHz, 2GB Ram  with ATI X1200 R690 Integrated Graphics ... that is upgrading now and is the target audience of Unity. I'll let you know in 1 hr about the performance.
>
> 1 x OpenCL Dev Workstation Sandy Bridge 3.4 GHz Quad,16 GB Ram  ATI HD
> 6870 .. This has been upgraded to Unity and daily PPA + Ubuntu's version
> of the ATI fglrx proprietary driver.
>
> The black window rendering has now been resolved.

If windows are appearing to become black (eg, they open and are black)
then AMD needs to be alerted of this since it means that the driver
has run out of video memory to put pixmaps into.

Copytexturing might be an option to look into here, however that is
probably going to be for O and not N at this stage.

> As for performance,
> its fine but then it should be on this system. However I can not test it
> properly because I keep having to reboot into fail-safe windows graphics
> mode. This is because there is an issue with the window title bars not
> being rendered at all in Unity so you can not move the windows around.
> The Text Tool Bar (File, Menu etc ) Appear in the Unity Top Panel so you
> can exit the app and reboot, but you can not minimise or maximise App
> windows.
>
> I do not think this is a Unity issue because even in Compiz Cube, the
> Top Gnome Panel does not even appear, when you rotate the cube ... it
> appears that the rotation is not a cube, but a flat 2d desktop that
> rotates around a central axis. Strange.

That's because you've got 2x2 workspaces. Cube only works for
horizontal workspaces, so you've got a 2 sided polygon in that case.

>
> laptop almost upgraded will update soon on performance.
>
> --
> You received this bug notification because you are a member of Canonical
> Desktop Experience Team, which is a bug assignee.
> https://bugs.launchpad.net/bugs/748137
>
> Title:
>  unity rendering broken with fglrx (black masks)
>
> Status in “fglrx-installer” package in Ubuntu:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Confirmed
> Status in “fglrx-installer” source package in Natty:
>  Confirmed
> Status in “unity” source package in Natty:
>  Confirmed
>
> Bug description:
>  With latest unity and fglrx many areas of the screen are black (see attached screenshot)
>  The black window in the middle of the screen is an xterm
>
>  Graphics Card:
>  01:00.0 VGA compatible controller: ATI Technologies Inc Juniper [Radeon HD 5700 Series]
>
>  $ apt-cache policy fglrx unity
>  unity:
>    Installed: 3.8.2-0ubuntu1
>    Candidate: 3.8.2-0ubuntu1
>    Version table:
>   *** 3.8.2-0ubuntu1 0
>          500 http://archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
>          100 /var/lib/dpkg/status
>  fglrx:
>    Installed: 2:8.840-0ubuntu1
>    Candidate: 2:8.840-0ubuntu1
>    Version table:
>   *** 2:8.840-0ubuntu1 0
>          500 http://archive.ubuntu.com/ubuntu/ natty/restricted amd64 Packages
>          100 /var/lib/dpkg/status
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu...

Read more...

Didier Roche (didrocks) on 2011-04-05
Changed in unity:
status: New → Confirmed
Mauricio Pretto (pretto) wrote :

Same problem here
---
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon HD 2400 XT
---

Eibriel (gabriel-inv) wrote :

I've updated from PPA as 'dart' says and Unity works now :)
Using: VGA compatible controller: ATI Technologies Inc Radeon HD 3300 Graphics

Ading a Tab on Firefox, or closing a menu is a bit slow.

Thanks!

Eibriel (gabriel-inv) wrote :

Deactivating VSync on Compiz Manager results on smooth animations.

axel (simon-simonfoley) wrote :

Right, for those who have been having an issue after an upgrade to Ubuntu 11.04 from 10.10 and are having missing Title Bars on all their windows .....been driving me mad for days .....

sudo mv /home/<my home folder>/.gconf .gconf.old

log out and log back in and hey presto ,,,, window title bars back !

I am diff'ing the files to find the root cause ! I will post back ... will probably have to log this as a separate bug !

The latest updates fixed this problem.
The laggy movements are fixed by disabling sync to vblanck in ccsm/opengl

Changed in fglrx-installer (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in unity (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
darundal (darundal) wrote :

I still get laggy window movement after disabling vsync in both CCSM and Catalyst Control Center.

Grant B (lymera1n) wrote :

How do I disable vsync in CCSM and Catalysy Control Center? Thanks!

Stefan (sbossb) wrote :

To disable vsync in open CompizConfig Settings Manager (CCSM) go to the main CCSM menu and select OpenGL under the general category and uncheck Sync to VBlank.

Amitai Bar (amitaibar) wrote :

On Maverick I used to be able to use the vsync so it is clearly a
regression.

On Sat, Apr 9, 2011 at 11:42 PM, Stefan <email address hidden> wrote:

> To disable vsync in open CompizConfig Settings Manager (CCSM) go to the
> main CCSM menu and select OpenGL under the general category and uncheck
> Sync to VBlank.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (747501).
> https://bugs.launchpad.net/bugs/748137
>
> Title:
> unity rendering broken with fglrx (black masks)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/748137/+subscribe
>

i still cant login to unity .... only success login to Ubuntu Desktop Classic

fenris@workstation:~$ apt-cache policy unity unity-common fglrx compiz
compiz:
  Installed: 1:0.9.4+bzr20110415-0ubuntu2
  Candidate: 1:0.9.4+bzr20110415-0ubuntu2
  Version table:
 *** 1:0.9.4+bzr20110415-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
     1:0.9.4+bzr20110415-0ubuntu1+r2754+201104151838 0
        500 http://ppa.launchpad.net/unity/daily/ubuntu/ natty/main i386 Packages
unity:
  Installed: 3.8.10-0ubuntu1
  Candidate: 3.8.10-0ubuntu1
  Version table:
 *** 3.8.10-0ubuntu1 0
        100 /var/lib/dpkg/status
     3.8.8-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
     3.6.8-0ubuntu3+r1046+201103301422 0
        500 http://ppa.launchpad.net/unity/daily/ubuntu/ natty/main i386 Packages
fglrx:
  Installed: 2:8.840-0ubuntu2
  Candidate: 2:8.840-0ubuntu2
  Version table:
 *** 2:8.840-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/restricted i386 Packages
        100 /var/lib/dpkg/status
unity-common:
  Installed: 3.8.10-0ubuntu1
  Candidate: 3.8.10-0ubuntu1
  Version table:
 *** 3.8.10-0ubuntu1 0
        100 /var/lib/dpkg/status
     3.8.8-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
     3.6.8-0ubuntu3+r1046+201103301422 0
        500 http://ppa.launchpad.net/unity/daily/ubuntu/ natty/main i386 Packages
fenris@workstation:~$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV505 [Radeon X1550 64-bit]

axel (simon-simonfoley) wrote :

Yes,
      does not surprise me, basically I suspect it comes down to the fact that your ATI chip set is not functional enough with the Xorg radeon driver to run Unity .....Also like my R690M you will not be supported by the ATI fglrx driver (anything older than R600 is not supported in current releases). My R690M should work but has a driver bug and now defaults back to classic Gnome. Previously it ran Unity but became unusable because of the bug and the screen corruption it caused. I suspect a ppa daily release of Unity \ Compiz triggered this change in behavior so I can not even get the screen corruption.

I have not found any work around / manual config of xorg.conf to get unity working. If I do I will post and let you know.
In the past I used a kernel parameter radeon.modeset=0 in my grub.conf and managed to get compiz cube working with the radeon driver and a manual xorg.conf. You could try that.

I have yet to see anything that Unity does that does seems radically any more demanding than running Compiz Cube!
Its worth persevering as Unity has some really great features. I am even managing to run it as my desktop default on a 24In Monitor! :-)

hi axel,
thanks for ya explanation ... btw , if i uninstall the fglrx package ... the Unity work out of the box with resolution 1024x768 .... i would like to adjust the resolution to 1360x768 .......

axel (simon-simonfoley) wrote :

apologies,
                 I keep getting my .gconf corrupted which prevents unity from loading. You are correct ... I deleted my profiles .gconf folder and logged back in and Unity is now loading as it used to do using the Radeon driver.

I still get graphics corruption (not the fkgrx black window issue posted here) which is the Radeon bug with my specific chip-set.
I belive this bug is associated with the shared graphics memory on my netbook. To avoid this I have to boot with radeon.modeset=0, which disables unity anyway!

You should not have my driver bug so you should work with the basic radeon driver and your hardware.... enjoy :-)

Boudhayan Gupta (baloneygeek) wrote :

Just a heads-up: If I disable Sync to VBlank in CCSM, and keep Tear Free Desktop enabled in AMDCCCLE, I get normal performance, as well as no tearing (because AMD is handling it at the driver level). I guess the whole issue was because vblanking was being done twice (once at the Compiz level and another at the FGLRX level), and this was putting a huge load on the GPU with performance regression.

My card is a ATI Mobility Radeon HD4330

Amitai Bar (amitaibar) wrote :

Didn't work for me.
I have radeon mobility 5470.
I the known confuration and it worked only when tear free was disabled plus
vsync.

On Sun, Apr 24, 2011 at 9:02 PM, Boudhayan Gupta
<email address hidden>wrote:

> Just a heads-up: If I disable Sync to VBlank in CCSM, and keep Tear Free
> Desktop enabled in AMDCCCLE, I get normal performance, as well as no
> tearing (because AMD is handling it at the driver level). I guess the
> whole issue was because vblanking was being done twice (once at the
> Compiz level and another at the FGLRX level), and this was putting a
> huge load on the GPU with performance regression.
>
> My card is a ATI Mobility Radeon HD4330
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (747501).
> https://bugs.launchpad.net/bugs/748137
>
> Title:
> unity rendering broken with fglrx (black masks)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/748137/+subscribe
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers