Ubuntu

package fglrx 2:8.831-0ubuntu1 failed to install/upgrade: fglrx kernel module failed to build

Reported by Anton on 2011-03-30
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to install Ati Catalyst 11.3 (fglrx 8.831) in an up-to-date natty
Hybrid graphics i5-450 / Ati Radeon HD 5450.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: fglrx 2:8.831-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic-pae 2.6.38
Uname: Linux 2.6.38-7-generic-pae i686
Architecture: i386
Date: Wed Mar 30 19:11:03 2011
DistUpgraded: Log time: 2011-03-21 14:28:27.545521
DistroCodename: natty
DistroVariant: ubuntu
ErrorMessage: fglrx kernel module failed to build
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110318)
PackageVersion: N/A
SourcePackage: fglrx-installer
Title: package fglrx 2:8.831-0ubuntu1 failed to install/upgrade: fglrx kernel module failed to build
UpgradeStatus: Upgraded to natty on 2011-03-24 (6 days ago)
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Anton (avelo) wrote :
Anton (avelo) wrote :

dkms compilation problems solved by applying patch provided by Miguel Colon in:
http://osdir.com/ml/attachments/txtq2PBdGtr8X.txt

But still no luck with starting X with fglrx.
aticonfig --px-dgpu or aticonfig --px-dgpu seemed to try the switch but throws errors

(II) fglrx(0): === [xdl_xs110_atiddxPreInit] === begin
(II) fglrx(0): PowerXpress: Discrete GPU is selected.
libGL symbol link files sanity check failed
(EE) fglrx(0): PowerXpress: Fail to switch libGL link files.
(WW) fglrx(0): PreInit PowerXpress failed!

Also tested with 8.840 from natty rep, with the same errors

X always crashes with a Segmentation Fault like this:
Backtrace:
[ 618.316] 0: X (xorg_backtrace+0x3b) [0x80eaa7b]
[ 618.316] 1: X (0x8048000+0x5fa88) [0x80a7a88]
[ 618.316] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb78a240c]
[ 618.316] 3: X (xf86DeleteScreen+0x6c) [0x80c01dc]
[ 618.316] 4: X (InitOutput+0x89f) [0x80b7d3f]
[ 618.316] 5: X (0x8048000+0x1a645) [0x8062645]
[ 618.316] 6: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xe7) [0xb75bfe37]
[ 618.316] 7: X (0x8048000+0x1a3e1) [0x80623e1]
[ 618.316] Segmentation fault at address 0xc
[ 618.316]
Caught signal 11 (Segmentation fault). Server aborting

Robert Roth (evfool) on 2011-04-01
Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Sorry, versions of fglrx prior to 8.40 lack support for the 2.6.38 kernel (and xserver 1.10) shipped in natty.

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers