Ubuntu

[MASTER] fglrx failed to install/upgrade due to being incompatible with 2.6.38 kernel (error: unknown field ‘ioctl’ specified in initializer)

Reported by Ron Bakker on 2011-01-28
924
This bug affects 110 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Critical
Alberto Milone

Bug Description

[Problem]
The -fglrx driver needs updated to work against the 2.6.38 kernel, as the current version is incompatible. It also needs updated to work with xserver 1.10, which was added to Ubuntu on 1-31.

[Workaround]
For now, the only work around is to uninstall -fglrx and use the open source -ati driver, which supports 2D on all AMD cards, and 3D on nearly all of them. AMD will be providing an update to their driver eventually, which hopefully should make it in time for the natty release.

[Original Report]
This problem I have with kernel 37-12 and 38-1.
But with 37-12 startup is possible with a buggy system.
With kernel 38-1 gnome will not startup.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: fglrx 2:8.801-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Fri Jan 28 22:00:14 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: fglrx, 8.801, 2.6.37-12-generic, x86_64: installed
ErrorMessage: fglrx kernel module failed to build
GdmLog1:

GraphicsCard: Subsystem: Acer Incorporated [ALI] Device [1025:0177]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101231)
MachineType: Acer Aspire 5535
PackageVersion: 2:8.801-0ubuntu2
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=b1897262-e69a-425a-a767-97e3c7f8507c ro quiet splash vt.handoff=7
SourcePackage: fglrx-installer
Title: package fglrx 2:8.801-0ubuntu2 failed to install/upgrade: fglrx kernel module failed to build
dmi.bios.date: 11/04/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.04
dmi.board.name: Aspire 5535
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.04:bd11/04/2008:svnAcer:pnAspire5535:pvr0100:rvnAcer:rnAspire5535:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 5535
dmi.product.version: 0100
dmi.sys.vendor: Acer
version.fglrx-installer: fglrx-installer N/A
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu8
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu1

Ron Bakker (r0n) wrote :
Bryce Harrington (bryce) on 2011-01-28
summary: - package fglrx 2:8.801-0ubuntu2 failed to install/upgrade: fglrx kernel
- module failed to build
+ fglrx failed to install/upgrade due to being incompatible with 2.6.38
+ kernel

Thanks for the bug report; you're the first to report this, but we knew it would eventually happen. Whenever the kernel (or xserver) receives a major update, the binary drivers need to be updated (or at least rebuilt) to support it.

In previous releases we've received an update from AMD shortly before final freeze, although I do not know an ETA for natty.

description: updated
emperor (emperor2000) wrote :

Don't think it's related but the day this got released my Natty stopped working. Tried everything, all kernels, fallback settings for x, reconfiguring my xserver to use radeon instead, removing fglrx (I could start without x) and so on. Nothing worked - back to 10.10 for now.

HuK (n-uzunov) wrote :

Resolved!
I`ve installed driver from ATI and it works!

Bryce Harrington (bryce) on 2011-02-02
Changed in fglrx-installer (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
description: updated
Bryce Harrington (bryce) on 2011-02-18
summary: - fglrx failed to install/upgrade due to being incompatible with 2.6.38
- kernel
+ [MASTER] fglrx failed to install/upgrade due to being incompatible with
+ 2.6.38 kernel

Bryce, maybe you should re-title to incompatible with xserver 1.10 as that is where the real incompatibility lies. Catalyst 11.2 works on 2.6.38 kernels.

Ryan Ritterson (rrpublic) wrote :

With the current fglrx package version available in the repos, DKMS fails to build the module due to kernel changes removing the big kernel lock. So, as filed and as stands, the title is correct. I don't believe 11.2 is available pre-packaged in the natty repos yet.

Daniel Letzeisen (dtl131) wrote :

Oh, I see. I was basing my comment off Cat 11.2. Thanks for clarification.

Felix Kuehling (felix-kuehling) wrote :

Catalyst 11.2 may have worked with earlier 2.6.38 RCs, but broke with later RCs and the final versions due to the renaming of acquire/release_console_sem to console_lock/unlock. That said, the kernel compatibility is fixed by a small patch. The Xserver is the bigger problem.

hallboy3 (hallboy3) wrote :

to Dave Lentz
I installed the drivers from AMD. During the installation was an error with dkms.
Version from the repository gives the following error in the file Xorg.0.log:

[ 222.354] (EE) Failed to load module "fglrx" (module does not exist, 0)

[ 223.931] (EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
[dri] This chipset requires a kernel module version of 1.17.0,
[dri] but the kernel reports a version of 2.8.0.[dri] If using legacy modesetting, upgrade your kernel.
[dri] If using kernel modesetting, make sure your module is
[dri] loaded prior to starting X, and that this driver was built
[dri] with support for KMS.
[dri] Disabling DRI.

So, this kernel RC has same issue.

Pieter (diepes) wrote :

Setting up linux-headers-2.6.38-020638rc8 (2.6.38-020638rc8.201103081151) ...
Setting up linux-headers-2.6.38-020638rc8-generic (2.6.38-020638rc8.201103081151) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 2.6.38-020638rc8-generic /boot/vmlinuz-2.6.38-020638rc8-generic
 * dkms: running auto installation service for kernel 2.6.38-020638rc8-generic
 * vboxhost (4.0.4)... [ OK ]
 * fglrx (8.801)... [fail]
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common 2.6.38-020638rc8-generic /boot/vmlinuz-2.6.38-020638rc8-generic

hallboy3 (hallboy3) wrote :

Linux 2.6.38 released with fix:
      drm/radeon: add pageflip hooks for fusion
      drm/radeon: fix page flipping hangs on r300/r400
      drm/radeon: fix problem with changing active VRAM size. (v2)

I hope that this release fixed the problem.

Bryce Harrington (bryce) on 2011-03-19
Changed in fglrx-installer (Ubuntu):
status: Triaged → In Progress
Bruno Clermont (b.clermont) wrote :

package version 2.6.38-7.36
do not fix this problem

$ cat /var/lib/dkms/fglrx/8.801/build/make.log
DKMS make.log for fglrx-8.801 for kernel 2.6.38-7-generic (x86_64)
Sat Mar 19 13:49:16 EDT 2011
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
make -C /lib/modules/2.6.38-7-generic/build SUBDIRS=/var/lib/dkms/fglrx/8.801/build/2.6.x modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.38-7-generic'
  CC [M] /var/lib/dkms/fglrx/8.801/build/2.6.x/firegl_public.o
/var/lib/dkms/fglrx/8.801/build/2.6.x/firegl_public.c:410: error: unknown field ‘ioctl’ specified in initializer
/var/lib/dkms/fglrx/8.801/build/2.6.x/firegl_public.c:410: warning: initialization from incompatible pointer type
/var/lib/dkms/fglrx/8.801/build/2.6.x/firegl_public.c: In function ‘fglrx_pci_suspend’:
/var/lib/dkms/fglrx/8.801/build/2.6.x/firegl_public.c:843: error: implicit declaration of function ‘acquire_console_sem’
/var/lib/dkms/fglrx/8.801/build/2.6.x/firegl_public.c:865: error: implicit declaration of function ‘release_console_sem’
/var/lib/dkms/fglrx/8.801/build/2.6.x/firegl_public.c: In function ‘KAS_Mutex_Initialize’:
/var/lib/dkms/fglrx/8.801/build/2.6.x/firegl_public.c:5110: error: implicit declaration of function ‘init_MUTEX’
make[2]: *** [/var/lib/dkms/fglrx/8.801/build/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/var/lib/dkms/fglrx/8.801/build/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.38-7-generic'
make: *** [kmod_build] Error 2
build failed with return value 2

I downloaded the 8.821 version from ATI/AMD. No luck so far.

Pieter (diepes) wrote :

Just tried the latest 2.6.38 non rc kernel from
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.38-natty/

Setting up linux-headers-2.6.38-020638-generic (2.6.38-020638.201103151303) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 2.6.38-020638-generic /boot/vmlinuz-2.6.38-020638-generic
 * dkms: running auto installation service for kernel 2.6.38-020638-generic
 * vboxhost (4.0.4)... [ OK ]
 * fglrx (8.801)... [fail]
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common 2.6.38-020638-generic /boot/vmlinuz-2.6.38-020638-generic
pieters@pieters-laptop:~/Downloads$

Daniel Letzeisen (dtl131) wrote :

@hallboy: the kernel changes you list refer to the open-source driver. A new version of Catalyst is needed (and will be released next week).

Jacob Mansfield (cyberjacob) wrote :

yay for fix =D

HuK (n-uzunov) wrote :

This helped me:

Patching Catalyst 10-12 Source

(This section to be removed once Catalyst supports Xserver 1.10) Catalyst 10-12 needs patched for compliance with kernel version 2.6.37 before you can install it.
$ cd ~/; mkdir catalyst10.12; cd catalyst10.12/
$ wget http://www2.ati.com/drivers/linux/ati-driver-installer-10-12-x86.x86_64.run
$ chmod +x ati-driver-installer-10-12-x86.x86_64.run
$ ./ati-driver-installer-10-12-x86.x86_64.run --extract driver
$ cd driver
$ wget http://ubuntuone.com/p/WVN/firegl_public.c
$ wget http://ubuntuone.com/p/WVU/Makefile
$ mv firegl_public.c common/lib/modules/fglrx/build_mod/
$ mv Makefile common/lib/modules/fglrx/build_mod/2.6.x/
$ sudo ./ati-installer.sh 8.801 --buildpkg Ubuntu/natty
$ cd ..
$ sudo dpkg -i fglrx*.deb

[edit] Catalyst and Unity

At this time, Catalyst doesn't work with the new Ubuntu desktop (Unity). You can still use the classic GNOME desktop (or another desktop environment).

Daniel Letzeisen (dtl131) wrote :

@HuK: That will only work with an older kernel than the default one in Natty. If you run an older kernel, you can use Catalyst 11.2 without patching.

Saad Inam (thatguy-akabob) wrote :

I really want to Run it. so far i had to downgrade to 10.10 because 11.04 did not display with my HD 5450. Can anyone confirm it running with that new update that was supposedly to be released this week?

EricDHH (ericdhh) wrote :

confirmed on amd64

Most ugly is the broken failsafe graphics at this problem, you only have a working console to fix something. Here with a juniper 5750 the failsafe graphis is restarting in an endless loop.

Changed in fglrx-installer (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
John Winterton (jwinterton) wrote :

Good luck to all. I am currently running with the low-graphics mode, and will continue with other tests.

xserver 1.10 issues still present with Catalyst 11.3 (fglrx 8.831.2) - more's the pity.

hallboy3 (hallboy3) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.840-0ubuntu1

---------------
fglrx-installer (2:8.840-0ubuntu1) natty; urgency=low

  * New upstream release 8.84.6 (LP: #709505).
  * debian/control:
    - Bump build-dep on xserver-xorg-dev to >= 2:1.10.0.
  * debian/dkms.conf.in:
    - Do not use add-compatibility-with-2.6.36-kernels.patch and
      fglrx-2.6.37.patch use-cflags_module-together-with-modflags.patch
      any more.
  * fglrx.install.in:
    - Look for libglx.so and libGL.so in their new location.
    - Make sure to install only libGL.so*.
  * debian/fglrx.postinst:
    - Add missing slave link to amdupdaterandrconfig.
  * debian/rules:
    - Switch back to automatic ABI dependency generation.
    - Avoid accidentally copying the whole fglrx directory.
    - Rename fglrx-libGL.so and fglrx-libglx.so.
 -- Alberto Milone <email address hidden> Tue, 29 Mar 2011 20:16:39 +0200

Changed in fglrx-installer (Ubuntu):
status: In Progress → Fix Released
dart (dart-v85) wrote :

so we will be able to install catalyst driver 11.3 in natty after this fix?

Alberto Milone (albertomilone) wrote :

Yes, but the driver will be available in Jockey only after Natty's Beta 1 is released

Download full text (3.3 KiB)

Hi !
But the binary from AMD its okay with current version of Kernel ? Thanks :)

2011/3/30 Alberto Milone <email address hidden>

> Yes, but the driver will be available in Jockey only after Natty's Beta
> 1 is released
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/709505
>
> Title:
> [MASTER] fglrx failed to install/upgrade due to being incompatible
> with 2.6.38 kernel
>
> Status in “fglrx-installer” package in Ubuntu:
> Fix Released
>
> Bug description:
> [Problem]
> The -fglrx driver needs updated to work against the 2.6.38 kernel, as the
> current version is incompatible. It also needs updated to work with xserver
> 1.10, which was added to Ubuntu on 1-31.
>
> [Workaround]
> For now, the only work around is to uninstall -fglrx and use the open
> source -ati driver, which supports 2D on all AMD cards, and 3D on nearly all
> of them. AMD will be providing an update to their driver eventually, which
> hopefully should make it in time for the natty release.
>
> [Original Report]
> This problem I have with kernel 37-12 and 38-1.
> But with 37-12 startup is possible with a buggy system.
> With kernel 38-1 gnome will not startup.
>
> ProblemType: Package
> DistroRelease: Ubuntu 11.04
> Package: fglrx 2:8.801-0ubuntu2
> ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
> Uname: Linux 2.6.37-12-generic x86_64
> NonfreeKernelModules: fglrx
> Architecture: amd64
> Date: Fri Jan 28 22:00:14 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> DkmsStatus: fglrx, 8.801, 2.6.37-12-generic, x86_64: installed
> ErrorMessage: fglrx kernel module failed to build
> GdmLog1:
>
> GraphicsCard: Subsystem: Acer Incorporated [ALI] Device [1025:0177]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101231)
> MachineType: Acer Aspire 5535
> PackageVersion: 2:8.801-0ubuntu2
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic
> root=UUID=b1897262-e69a-425a-a767-97e3c7f8507c ro quiet splash vt.handoff=7
> SourcePackage: fglrx-installer
> Title: package fglrx 2:8.801-0ubuntu2 failed to install/upgrade: fglrx
> kernel module failed to build
> dmi.bios.date: 11/04/2008
> dmi.bios.vendor: Phoenix Technologies LTD
> dmi.bios.version: V1.04
> dmi.board.name: Aspire 5535
> dmi.board.vendor: Acer
> dmi.board.version: Rev
> dmi.chassis.type: 10
> dmi.chassis.vendor: Acer
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnPhoenixTechnologiesLTD:bvrV1.04:bd11/04/2008:svnAcer:pnAspire5535:pvr0100:rvnAcer:rnAspire5535:rvrRev:cvnAcer:ct10:cvrN/A:
> dmi.product.name: Aspire 5535
> dmi.product.version: 0100
> dmi.sys.vendor: Acer
> version.fglrx-installer: fglrx-installer N/A
> version.libdrm2: libdrm2 2.4.23-1ubuntu3
> version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
> version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu8
> version.xserver-xorg-video-ati: xserver-xorg-video-ati
> 1:6.13.2+git20110124.fadee040-0ubuntu1
> version.xserver-xorg-video-intel: xserver-xorg-video-intel
> 2:2.14.0-1ubuntu2
> version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau
> 1:0...

Read more...

dart (dart-v85) wrote :

@Alberto oh I get it, nvm :D

EricDHH (ericdhh) wrote :

ii fglrx 2:8.840-0ubunt Video driver for the ATI graphics accelerato
ii fglrx-amdcccle 2:8.840-0ubunt Catalyst Control Center for the ATI graphics
ii fglrx-dev 2:8.840-0ubunt Video driver for the ATI graphics accelerato

Compiled well, installed well, kernelmodule is loaded
fglrx 2739144 0

but....
root@agamemnon:/# /usr/lib/fglrx/bin/aticonfig --initial -f
Unable to open /etc/ati/control, please reinstall the driver.
/usr/lib/fglrx/bin/aticonfig: No supported adapters detected

Thats the unfixed bug Bug #706086 , that id reported few weeks ago. Tryin to workaround again.

EricDHH (ericdhh) wrote :
Download full text (6.2 KiB)

Final result, got the ubuntu logo with running dots, then the screen goes to suspend. Aticonfig has placed a new xorg.conf, the systems can boot to failsafe mode with lower graphics. Don't know what xorg mean with missing fglrx, it is not the kernel module

root@agamemnon:/usr/src# lsmod | grep fglrx
fglrx 2739144 0

X.Org X Server 1.10.0
Release Date: 2011-2-25
[ 17.949] X Protocol Version 11, Revision 0
[ 17.949] Build Operating System: Linux 2.6.24-28-server x86_64 Ubuntu
[ 17.949] Current Operating System: Linux agamemnon 2.6.38-7-generic #39-Ubuntu SMP Fri Mar 25 21:24:57 UTC 2011 x86_64
[ 17.949] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=0c41120b-fd56-46a4-aabb-609f95b9abad ro vga=795 splash elevator=noop vt.handoff=7
[ 17.949] Build Date: 25 March 2011 01:46:34AM
[ 17.949] xorg-server 2:1.10.0-0ubuntu2 (For technical support please see http://www.ubuntu.com/support)
[ 17.949] Current version of pixman: 0.20.2
[ 17.949] Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
[ 17.949] Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 17.949] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 30 19:21:49 2011
[ 17.949] (==) Using config file: "/etc/X11/xorg.conf"
[ 17.949] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 17.950] (==) ServerLayout "aticonfig Layout"
[ 17.950] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[ 17.950] (**) | |-->Monitor "aticonfig-Monitor[0]-0"
[ 17.950] (**) | |-->Device "aticonfig-Device[0]-0"
[ 17.950] (==) Automatically adding devices
[ 17.950] (==) Automatically enabling devices
[ 17.950] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 17.950] Entry deleted from font path.
[ 17.950] (==) FontPath set to:
 /usr/share/fonts/X11/misc,
 /usr/share/fonts/X11/100dpi/:unscaled,
 /usr/share/fonts/X11/75dpi/:unscaled,
 /usr/share/fonts/X11/Type1,
 /usr/share/fonts/X11/100dpi,
 /usr/share/fonts/X11/75dpi,
 /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
 built-ins
[ 17.950] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 17.950] (II) The server relies on udev to provide the list of input devices.
 If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 17.950] (II) Loader magic: 0x7e0280
[ 17.950] (II) Module ABI versions:
[ 17.950] X.Org ANSI C Emulation: 0.4
[ 17.950] X.Org Video Driver: 10.0
[ 17.950] X.Org XInput driver : 12.3
[ 17.950] X.Org Server Extension : 5.0
[ 17.951] (--) PCI:*(0:1:0:0) 1002:68be:1458:21e9 rev 0, Mem @ 0xd0000000/268435456, 0xfdec0000/131072, I/O @ 0x0000ee00/256, BIOS @ 0x????????/131072
[ 17.951] (II) Open ACPI successful (/var/run/acpid.socket)
[ 17.951] (II) "extmod" will be loaded by default.
[ 17.951] (II) "dbe" will be loaded by default.
[ 17.951] (II) "glx" will be loaded by default.
[ 17.951] (II) "record" will be loaded by default.
[ 17.951] (...

Read more...

Alberto Milone (albertomilone) wrote :

@stoja
Yes, it's compatible with Natty's kernel

@EricDHH
You didn't enable the fglrx driver

Please type the following commands:

sudo update-alternatives --config gl_conf (and select the line with fglrx)
sudo update-initramfs -u

and finally reboot.

Download full text (3.4 KiB)

@Alberto Milone Thanks for your nice job :)

2011/3/31 Alberto Milone <email address hidden>

> @stoja
> Yes, it's compatible with Natty's kernel
>
> @EricDHH
> You didn't enable the fglrx driver
>
> Please type the following commands:
>
> sudo update-alternatives --config gl_conf (and select the line with fglrx)
> sudo update-initramfs -u
>
> and finally reboot.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/709505
>
> Title:
> [MASTER] fglrx failed to install/upgrade due to being incompatible
> with 2.6.38 kernel
>
> Status in “fglrx-installer” package in Ubuntu:
> Fix Released
>
> Bug description:
> [Problem]
> The -fglrx driver needs updated to work against the 2.6.38 kernel, as the
> current version is incompatible. It also needs updated to work with xserver
> 1.10, which was added to Ubuntu on 1-31.
>
> [Workaround]
> For now, the only work around is to uninstall -fglrx and use the open
> source -ati driver, which supports 2D on all AMD cards, and 3D on nearly all
> of them. AMD will be providing an update to their driver eventually, which
> hopefully should make it in time for the natty release.
>
> [Original Report]
> This problem I have with kernel 37-12 and 38-1.
> But with 37-12 startup is possible with a buggy system.
> With kernel 38-1 gnome will not startup.
>
> ProblemType: Package
> DistroRelease: Ubuntu 11.04
> Package: fglrx 2:8.801-0ubuntu2
> ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
> Uname: Linux 2.6.37-12-generic x86_64
> NonfreeKernelModules: fglrx
> Architecture: amd64
> Date: Fri Jan 28 22:00:14 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> DkmsStatus: fglrx, 8.801, 2.6.37-12-generic, x86_64: installed
> ErrorMessage: fglrx kernel module failed to build
> GdmLog1:
>
> GraphicsCard: Subsystem: Acer Incorporated [ALI] Device [1025:0177]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101231)
> MachineType: Acer Aspire 5535
> PackageVersion: 2:8.801-0ubuntu2
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic
> root=UUID=b1897262-e69a-425a-a767-97e3c7f8507c ro quiet splash vt.handoff=7
> SourcePackage: fglrx-installer
> Title: package fglrx 2:8.801-0ubuntu2 failed to install/upgrade: fglrx
> kernel module failed to build
> dmi.bios.date: 11/04/2008
> dmi.bios.vendor: Phoenix Technologies LTD
> dmi.bios.version: V1.04
> dmi.board.name: Aspire 5535
> dmi.board.vendor: Acer
> dmi.board.version: Rev
> dmi.chassis.type: 10
> dmi.chassis.vendor: Acer
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnPhoenixTechnologiesLTD:bvrV1.04:bd11/04/2008:svnAcer:pnAspire5535:pvr0100:rvnAcer:rnAspire5535:rvrRev:cvnAcer:ct10:cvrN/A:
> dmi.product.name: Aspire 5535
> dmi.product.version: 0100
> dmi.sys.vendor: Acer
> version.fglrx-installer: fglrx-installer N/A
> version.libdrm2: libdrm2 2.4.23-1ubuntu3
> version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
> version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu8
> version.xserver-xorg-video-ati: xserver-xorg-video-ati
> 1:6.13.2+git20110124.fadee040-0ubuntu1
> versi...

Read more...

Step by step to perfection, the blackscreen won't disappear. The gl_conf was on nvidia, switched that around. Now some libs seems to be missing. From which package can i get them?

root@agamemnon:/# ldconfig -v | grep libatiuki
/sbin/ldconfig.real: Pfad »/lib/x86_64-linux-gnu« mehrfach angegeben
/sbin/ldconfig.real: Pfad »/usr/lib/x86_64-linux-gnu« mehrfach angegeben
 libatiuki.so.1 -> libatiuki.so.1.0
 libatiuki.so.1 -> libatiuki.so.1.0
/sbin/ldconfig.real: Es ist nicht möglich, den Status (stat()) der Datei /usr/lib/libjackserver.so zu lesen: Datei oder Verzeichnis nicht gefunden
/sbin/ldconfig.real: Es ist nicht möglich, den Status (stat()) der Datei /usr/lib/libfglrx_dm.so zu lesen: Datei oder Verzeichnis nicht gefunden
/sbin/ldconfig.real: Es ist nicht möglich, den Status (stat()) der Datei /usr/lib/libfglrx_tvout.so zu lesen: Datei oder Verzeichnis nicht gefunden
/sbin/ldconfig.real: Es ist nicht möglich, den Status (stat()) der Datei /usr/lib/libfglrx_pp.so zu lesen: Datei oder Verzeichnis nicht gefunden

Juan Pedro Paredes (juampe) wrote :

aticonfig --initial
No protocol specified
Found fglrx primary device section
Fail to link to fglrx-libglx.so, please check whether driver is installed correctly

Download full text (3.5 KiB)

Im too ! :(
ivan@ivan-N61Jq:~$ sudo aticonfig --initial
Uninitialised file found, configuring.
Fail to link to fglrx-libglx.so, please check whether driver is installed
correctly
Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.original-0
ivan@ivan-N61Jq:~$

2011/3/31 Juan Pedro Paredes <email address hidden>

> aticonfig --initial
> No protocol specified
> Found fglrx primary device section
> Fail to link to fglrx-libglx.so, please check whether driver is installed
> correctly
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/709505
>
> Title:
> [MASTER] fglrx failed to install/upgrade due to being incompatible
> with 2.6.38 kernel
>
> Status in “fglrx-installer” package in Ubuntu:
> Fix Released
>
> Bug description:
> [Problem]
> The -fglrx driver needs updated to work against the 2.6.38 kernel, as the
> current version is incompatible. It also needs updated to work with xserver
> 1.10, which was added to Ubuntu on 1-31.
>
> [Workaround]
> For now, the only work around is to uninstall -fglrx and use the open
> source -ati driver, which supports 2D on all AMD cards, and 3D on nearly all
> of them. AMD will be providing an update to their driver eventually, which
> hopefully should make it in time for the natty release.
>
> [Original Report]
> This problem I have with kernel 37-12 and 38-1.
> But with 37-12 startup is possible with a buggy system.
> With kernel 38-1 gnome will not startup.
>
> ProblemType: Package
> DistroRelease: Ubuntu 11.04
> Package: fglrx 2:8.801-0ubuntu2
> ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
> Uname: Linux 2.6.37-12-generic x86_64
> NonfreeKernelModules: fglrx
> Architecture: amd64
> Date: Fri Jan 28 22:00:14 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> DkmsStatus: fglrx, 8.801, 2.6.37-12-generic, x86_64: installed
> ErrorMessage: fglrx kernel module failed to build
> GdmLog1:
>
> GraphicsCard: Subsystem: Acer Incorporated [ALI] Device [1025:0177]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101231)
> MachineType: Acer Aspire 5535
> PackageVersion: 2:8.801-0ubuntu2
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic
> root=UUID=b1897262-e69a-425a-a767-97e3c7f8507c ro quiet splash vt.handoff=7
> SourcePackage: fglrx-installer
> Title: package fglrx 2:8.801-0ubuntu2 failed to install/upgrade: fglrx
> kernel module failed to build
> dmi.bios.date: 11/04/2008
> dmi.bios.vendor: Phoenix Technologies LTD
> dmi.bios.version: V1.04
> dmi.board.name: Aspire 5535
> dmi.board.vendor: Acer
> dmi.board.version: Rev
> dmi.chassis.type: 10
> dmi.chassis.vendor: Acer
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnPhoenixTechnologiesLTD:bvrV1.04:bd11/04/2008:svnAcer:pnAspire5535:pvr0100:rvnAcer:rnAspire5535:rvrRev:cvnAcer:ct10:cvrN/A:
> dmi.product.name: Aspire 5535
> dmi.product.version: 0100
> dmi.sys.vendor: Acer
> version.fglrx-installer: fglrx-installer N/A
> version.libdrm2: libdrm2 2.4.23-1ubuntu3
> version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
> version.xserver-xorg: xserver-xorg 1:...

Read more...

This start to be offtopic with the bug title, because now fglrx installs
with the 2.6.38 kernel,
so it's possible that Alberto prefers to close it and open a new one.

Latest tries I've been done with fglrx 8.840 in a up-to-date natty with
intel/Ati hybrid:

#aticonfig --px-dgpu
PowerXpress: Discrete GPU is selected (High-Performance mode), please
restart Xserver for changes to take effect!
PowerXpress: Fail to switch GLX link file, please check whether driver
install correctly
#aticonfig --px-igpu
PowerXpress: Integrated GPU is selected (Power-Saving mode), please
restart Xserver for changes to take effect!
PowerXpress: Fail to switch GLX link file, please check whether driver
install correctly

I've seen that when trying to change cards aticonfig expects
/usr/lib/xorg/modules/extensions/libglx.so to be a link
By changing it to a link, and trying again, you discover the names of
the linked files in each mode, and they are (supposed to be):

/usr/lib/xorg/modules/extensions/FGL.renamed.libglx.so for the original
libglx.so mesa file with --px-igpu and
/usr/lib/xorg/modules/extensions/fglrx/fglrx-libglx.so for the fglrx
libglx.so with --px-dgpu
and copying/linking these files you can avoid the Fail in aticonfig.

But X keeps complaining with:
Discrete --px-dgpu:
[ 6452.269] (II) fglrx(0): === [xdl_xs110_atiddxPreInit] === begin
[ 6452.269] (II) fglrx(0): PowerXpress: Discrete GPU is selected.
[ 6452.269] libGL symbol link files sanity check failed
[ 6452.269] (EE) fglrx(0): PowerXpress: Fail to switch libGL link files.
[ 6452.269] (WW) fglrx(0): PreInit PowerXpress failed!
Backtrace:
[ 6452.269] 0: X (xorg_backtrace+0x3b) [0x80b783b]
[ 6452.269] 1: X (0x8048000+0x5d3f8) [0x80a53f8]
[ 6452.269] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb783a40c]
[ 6452.269] 3: X (xf86DeleteScreen+0x6c) [0x80d4d1c]
[ 6452.269] 4: X (InitOutput+0x89f) [0x80b9c0f]
[ 6452.269] 5: X (0x8048000+0x1a645) [0x8062645]
[ 6452.269] 6: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xe7)
[0xb7550e37]
[ 6452.270] 7: X (0x8048000+0x1a3e1) [0x80623e1]
[ 6452.270] Segmentation fault at address 0x25

Integrated --px-igpu:
[ 6487.059] (II) fglrx(0): === [xdl_xs110_atiddxPreInit] === begin
[ 6487.059] (II) fglrx(0): PowerXpress: Integrated GPU is selected.
[ 6487.059] libGL symbol link files sanity check failed
[ 6487.059] (EE) fglrx(0): PowerXpress: Fail to switch libGL link files.
[ 6487.059] (WW) fglrx(0): PreInit PowerXpress failed!(II)
UnloadModule: "fglrx"
[ 6487.059] (II) Unloading fglrx
[ 6487.059] (II) UnloadModule: "fglrxdrm"
[ 6487.059] (II) Unloading fglrxdrm
[ 6487.059] (EE) Screen(s) found, but none have a usable configuration.

Attached full Xorg.logs

@Anton
The driver doesn't support PowerXpress yet, so those commands are expected to fail. Also by changing links to libraries you risk breaking your system.

@EricDHH
Try typing "sudo ldconfig"

Also, please attach the output of the following commads:
1) ldconfig -p | grep libati
2) update-alternatives --display gl_conf

@all
There's no need to run "aticonfig --initial" as fglrx now works even without xorg.conf.

Christopher (soft-kristal) wrote :

I run a partition for test releases only. The main purpose is so when I do a distribution upgrade on my working partition there won't be any major hiccups.

If I upgrade my test partition again to Natty, will this be fixed? I don't want to go back to the drawing board again with a live Gparted.

Hello Alberto,

Finally Worked!

Yes I'know I can broke the system, but it's a natty partition for
testing, not my main install for work. Anyway, many thanks for the advice.

I've also straced X start-up, because of the Xorg errors:

libGL symbol link files sanity check failed
(EE) fglrx(0): PowerXpress: Fail to switch libGL link files.

I've found that fglrx misses links for libGL in /usr/lib/
so I've created the following:
libGL.so -> /usr/lib/fglrx/libGL.so
libGL.so.1 -> /usr/lib/fglrx/libGL.so.1
libGL.so.1.2 -> /usr/lib/fglrx/libGL.so.1.2

Apart from the abovementioned for libglx.so

And then tried X
with aticonfig --px-dgpu
X started perfectly (fglrxinfo gives ATI finally (!!!!!) running)
and then tried
aticonfig --px-igpu, with Intel running by fglrx (I've not checked if it
turns off the ATI for lowering the consumption)

Attached I enclosed both finally working Xorg logs

These links could be incorporated as slaves in the alternatives of
gl_conf? I guess...

Cheers and many many thanks for your work in having fglrx working
Anton

On 31/03/11 21:20, Alberto Milone wrote:
> @Anton
> The driver doesn't support PowerXpress yet, so those commands are expected to fail. Also by changing links to libraries you risk breaking your system.
>
> @EricDHH
> Try typing "sudo ldconfig"
>
> Also, please attach the output of the following commads:
> 1) ldconfig -p | grep libati
> 2) update-alternatives --display gl_conf
>
> @all
> There's no need to run "aticonfig --initial" as fglrx now works even without xorg.conf.
>

I installed fglrx from jockey update just 5 minutes back. Now Both 'Ubuntu' and 'Unity-2D' take me to unity 2d interface and there is no unity 3d. HELPPP!!!

EricDHH (ericdhh) wrote :
Download full text (3.8 KiB)

Got a screen this boot, sometimes it looks well and sometimes everthing turns black. Lot of nvidia trash here, is there a faq to wipe this out?

eric@agamemnon:/usr/lib$ sudo ldconfig -p | grep libati
[sudo] password for eric:
 libatiuki.so.1 (libc6,x86-64) => /usr/lib/fglrx/libatiuki.so.1
 libatiuki.so.1 (libc6) => /usr/lib32/fglrx/libatiuki.so.1
 libaticalrt.so (libc6,x86-64) => /usr/lib/fglrx/libaticalrt.so
 libaticalrt.so (libc6,x86-64) => /usr/lib/libaticalrt.so
 libaticalrt.so (libc6) => /usr/lib32/libaticalrt.so
 libaticalrt.so (libc6) => /usr/lib32/fglrx/libaticalrt.so
 libaticaldd.so (libc6,x86-64) => /usr/lib/fglrx/libaticaldd.so
 libaticaldd.so (libc6) => /usr/lib32/fglrx/libaticaldd.so
 libaticalcl.so (libc6,x86-64) => /usr/lib/fglrx/libaticalcl.so
 libaticalcl.so (libc6,x86-64) => /usr/lib/libaticalcl.so
 libaticalcl.so (libc6) => /usr/lib32/libaticalcl.so
 libaticalcl.so (libc6) => /usr/lib32/fglrx/libaticalcl.so
 libatiadlxx.so (libc6,x86-64) => /usr/lib/fglrx/libatiadlxx.so
 libatiadlxx.so (libc6) => /usr/lib32/fglrx/libatiadlxx.so

eric@agamemnon:/usr/lib$ sudo update-alternatives --display gl_conf
gl_conf - manueller Modus
  Link verweist zur Zeit auf /usr/lib/fglrx/ld.so.conf
/usr/lib/fglrx/ld.so.conf - Priorität 1000
  Slave 10fglrx: /usr/lib/fglrx/10fglrx
  Slave amdcccle: /usr/lib/fglrx/bin/amdcccle
  Slave amdcccle_desktop: /usr/share/fglrx/amdcccle.desktop
  Slave amdccclesu_desktop: /usr/share/fglrx/amdccclesu.desktop
  Slave amdnotifyui: /usr/lib/fglrx/bin/amdnotifyui
  Slave amdupdaterandrconfig: /usr/lib/fglrx/bin/amdupdaterandrconfig
  Slave amdxdg_su: /usr/lib/fglrx/bin/amdxdg-su
  Slave ati_conf: /usr/lib/fglrx/etc/ati
  Slave aticonfig: /usr/lib/fglrx/bin/aticonfig
  Slave atieventsd: /usr/lib/fglrx/bin/atieventsd
  Slave atiodcli: /usr/lib/fglrx/bin/atiodcli
  Slave atiode: /usr/lib/fglrx/bin/atiode
  Slave fgl_glxgears: /usr/lib/fglrx/bin/fgl_glxgears
  Slave fglrx_dri: /usr/lib/fglrx/dri/fglrx_dri.so
  Slave fglrx_drv: /usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so
  Slave fglrx_modconf: /lib/fglrx/modprobe.conf
  Slave fglrxinfo: /usr/lib/fglrx/bin/fglrxinfo
  Slave grub_fb_blacklist: /usr/share/fglrx/fglrx.grub-gfxpayload
  Slave libAMDXvBA_cap: /usr/lib/fglrx/libAMDXvBA.cap
  Slave libaticalcl.so: /usr/lib/fglrx/libaticalcl.so
  Slave libaticalcl.so_lib32: /usr/lib32/fglrx/libaticalcl.so
  Slave libaticalrt.so: /usr/lib/fglrx/libaticalrt.so
  Slave libaticalrt.so_lib32: /usr/lib32/fglrx/libaticalrt.so
  Slave xorg_extra_modules: /usr/lib/fglrx/xorg
/usr/lib/mesa/ld.so.conf - Priorität 500
  Slave xorg_extra_modules: /usr/lib/xorg/x11-extra-modules
/usr/lib/nvidia-current/ld.so.conf - Priorität 9700
  Slave grub_fb_blacklist: /usr/share/nvidia-current/nvidia-current.grub-gfxpayload
  Slave libvdpau_nvidia.so: /usr/lib/nvidia-current/vdpau/libvdpau_nvidia.so
  Slave libvdpau_nvidia.so.1: /usr/lib/nvidia-current/vdpau/libvdpau_nvidia.so.1
  Slave libvdpau_nvidia.so.1_lib32: /usr/lib32/nvidia-current/vdpau/libvdpau_nvidia.so.1
  Slave libvdpau_nvidia.so_lib32: /usr/lib32/nvidia-current/vdpau/libvdpau_nvidia.so
  Slave man_nvidiaxconfig.gz: /usr/share/man/man1/alt-nvidia-current-xconfig.1.gz
  Slave nvidia-...

Read more...

dart (dart-v85) wrote :

After unity 3.8.2 (already past rev. 1039) update and installation of new fglrx from jockey, i am getting black screen, flickers and tearing in unity that makes it unusable. Some screenshots attached:

dart (dart-v85) wrote :
Alberto Milone (albertomilone) wrote :

@Anton
The links that you created (e.g. libGL.so -> /usr/lib/fglrx/libGL.so) are not necessary. ldconfig should find libGL anyway on a clean system.

@Christopher
I can't guarantee that Natty will work correctly on your computer. It's still in Beta 1.

@dart
Please file a separate bug report about your problem

@EricDHH
You can remove nvidia with:
sudo apt-get remove --purge nvidia-current

Also, next time please put the output of commands in a text file and attach it to the bug report (using the "Add attachment or patch" button) instead of copying and pasting things in the bug report.

EricDHH (ericdhh) wrote :

Nvidia was purged, thank you. Now fglrx comes up clearly and i can use the classic desktop. For me this bug i solved.

Saad Inam (thatguy-akabob) wrote :

the beta was released, I'm wondering if i can update now and be able to work with my ATI 5450 graphics. the top says the status is "fix released" so is it safe to update Ubuntu to 11.04?

HuK (n-uzunov) wrote :

I updated ATI driver via jockey - now it`s OK for me :) 10x to all of you :)

(EE) fglrx(0): PowerXpress: Fail to switch libGL link files.
I get this. I believe that creating those links that were mentioned would fix the problem, as I tried to link them and X started and worked right for a while (then crashed, because I think I created the symlinks wrong).

Anton said:
"I've found that fglrx misses links for libGL in /usr/lib/
so I've created the following:
libGL.so -> /usr/lib/fglrx/libGL.so
libGL.so.1 -> /usr/lib/fglrx/libGL.so.1
libGL.so.1.2 -> /usr/lib/fglrx/libGL.so.1.2"

Please fix this, it causes the driver to crash on start of X if these links aren't found.

stoja (stojabreak) wrote :

In Natty beta 2 , works correctly but very slowly . :(

Alberto Milone (albertomilone) wrote :

@Charles
You should not try to use PowerXpress as it's not supported. Passing either --px-dgpu or --px-igpu to aticonfig will break your system.

Adam (aprzywecki) wrote :

"aticonf --initial" is necessary if you want to check the gpu temperature (using aticonfig --odgt).

Adam

Download full text (3.4 KiB)

I solved !!!!! :) Install compizconfig-settings
In terminal " sudo ccsm "
Go to " Opengl " and deactivate " vblank "
Its sooo faaasster and impresionant effects :)

PD:I´ve ATI MOBILITY RADEON 5730 HD

2011/4/16 Adam <email address hidden>

> "aticonf --initial" is necessary if you want to check the gpu
> temperature (using aticonfig --odgt).
>
> Adam
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/709505
>
> Title:
> [MASTER] fglrx failed to install/upgrade due to being incompatible
> with 2.6.38 kernel
>
> Status in “fglrx-installer” package in Ubuntu:
> Fix Released
>
> Bug description:
> [Problem]
> The -fglrx driver needs updated to work against the 2.6.38 kernel, as the
> current version is incompatible. It also needs updated to work with xserver
> 1.10, which was added to Ubuntu on 1-31.
>
> [Workaround]
> For now, the only work around is to uninstall -fglrx and use the open
> source -ati driver, which supports 2D on all AMD cards, and 3D on nearly all
> of them. AMD will be providing an update to their driver eventually, which
> hopefully should make it in time for the natty release.
>
> [Original Report]
> This problem I have with kernel 37-12 and 38-1.
> But with 37-12 startup is possible with a buggy system.
> With kernel 38-1 gnome will not startup.
>
> ProblemType: Package
> DistroRelease: Ubuntu 11.04
> Package: fglrx 2:8.801-0ubuntu2
> ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
> Uname: Linux 2.6.37-12-generic x86_64
> NonfreeKernelModules: fglrx
> Architecture: amd64
> Date: Fri Jan 28 22:00:14 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> DkmsStatus: fglrx, 8.801, 2.6.37-12-generic, x86_64: installed
> ErrorMessage: fglrx kernel module failed to build
> GdmLog1:
>
> GraphicsCard: Subsystem: Acer Incorporated [ALI] Device [1025:0177]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101231)
> MachineType: Acer Aspire 5535
> PackageVersion: 2:8.801-0ubuntu2
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic
> root=UUID=b1897262-e69a-425a-a767-97e3c7f8507c ro quiet splash vt.handoff=7
> SourcePackage: fglrx-installer
> Title: package fglrx 2:8.801-0ubuntu2 failed to install/upgrade: fglrx
> kernel module failed to build
> dmi.bios.date: 11/04/2008
> dmi.bios.vendor: Phoenix Technologies LTD
> dmi.bios.version: V1.04
> dmi.board.name: Aspire 5535
> dmi.board.vendor: Acer
> dmi.board.version: Rev
> dmi.chassis.type: 10
> dmi.chassis.vendor: Acer
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnPhoenixTechnologiesLTD:bvrV1.04:bd11/04/2008:svnAcer:pnAspire5535:pvr0100:rvnAcer:rnAspire5535:rvrRev:cvnAcer:ct10:cvrN/A:
> dmi.product.name: Aspire 5535
> dmi.product.version: 0100
> dmi.sys.vendor: Acer
> version.fglrx-installer: fglrx-installer N/A
> version.libdrm2: libdrm2 2.4.23-1ubuntu3
> version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
> version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu8
> version.xserver-xorg-video-ati: xserver-xorg-video-ati
> 1:6.13.2+git20110124.fadee040-0ubuntu1
> version.xserver-xorg-vi...

Read more...

I don't know if my comment should be here or in another bug, or it there is a thread particularly for kubuntu. I just installed kubuntu 10.04 amd64, the fglrx driver 2:8.840ubuntu4. My card is an ATI Mobility Radeon HD 4570

Composition with OpenGL does not work (under kwin), it doesn't give any description of the error. I tried aticonfig --initial and I get the error:

Fail to link to fglrx-libglx.so, please check whether driver is installed correctly

What can I do about it?

summary: [MASTER] fglrx failed to install/upgrade due to being incompatible with
- 2.6.38 kernel
+ 2.6.38 kernel (error: unknown field ‘ioctl’ specified in initializer)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.