fglxrx - fullscreen openGL / always on top

Bug #670345 reported by VixsLee on 2010-11-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
New
Undecided
Unassigned
fglrx-installer (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Hiya.

fglrx drivers wont allow you to use ALT + TAB (or CTRL + ALT + Left / Right) when a program is running in full screen mode (openGL) it always stays on the front.

It is actually switching, but the program is always on top.

Easiest way to test is to install fglrx and then run

glxgears -fullscreen

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: fglrx 2:8.780-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Wed Nov 3 12:17:03 2010
DkmsStatus: fglrx, 8.780, 2.6.35-22-generic, i686: installed
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: Hewlett-Packard HP Pavilion dv6 Notebook PC
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=50e24927-fb80-437d-b972-fe7fd328fbdb ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: fglrx-installer
dmi.bios.date: 05/17/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.15
dmi.board.name: 3635
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 33.23
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.15:bd05/17/2010:svnHewlett-Packard:pnHPPaviliondv6NotebookPC:pvr039F200000241210000020000:rvnHewlett-Packard:rn3635:rvr33.23:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6 Notebook PC
dmi.product.version: 039F200000241210000020000
dmi.sys.vendor: Hewlett-Packard
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-22-generic

VixsLee (vixsandlee) wrote :
bugbot (bugbot) wrote :

Hey VixsLee,

Hi, have you had a chance to test if this bug is still present in natty?

If it does (and if you're the original reporter), please boot into natty
and run the command:

  apport-collect <bug-number>

which will update the bug with fresh logs and tag the bug as affecting
natty. (It is best to run this right after reproducing the problem.)

Changed in fglrx-installer (Ubuntu):
status: New → Incomplete
VixsLee (vixsandlee) wrote :

I have no idea I am afriad, my laptop died a few month ago and I am currently using an nvidia card so I dont know about the ATI side of things now.

Sorry I cant be of more help

Bryce Harrington (bryce) wrote :

Since the hardware is no longer available for doing troubleshooting with, we'll have to close the bug for now. However please feel free to reopen if you or anyone else has the same HW and can reproduce this issue using the latest development version of Ubuntu and is willing to do some troubleshooting with it.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Invalid
Luca Manzari (manzariluca) wrote :

guys bug still present in Natty!!! I'm experiencing it : ( Feel free to ask me all the info's you need : )

Luca Manzari (manzariluca) wrote :

Isn't this bug the same of this other one?
https://bugs.launchpad.net/ubuntu/+bug/758609

Changed in fglrx-installer (Ubuntu):
status: Invalid → New
Jaime Pérez (jaime-91) wrote :

I have the same problem with intel haswell 4400

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Jaime Pérez (jaime-91) wrote :

I'm using ubuntu 15.10 devel

no longer affects: unity (Ubuntu)
Jaime Pérez (jaime-91) wrote :

I'm not sure if its a problem of intel driver or compiz, but I suppose is a compiz issue

Jaime Pérez (jaime-91) on 2015-10-14
no longer affects: xserver-xorg-video-intel (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers