desktop mysteriously freezes until keyboard or mouse input

Bug #669535 reported by Shawn Yarbrough on 2010-11-01
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-terminal

Reported this bug as a gnome-terminal issue but it actually affects my entire X desktop.

My Ubuntu desktop mysteriously freezes until I press a key on the keyboard or move the mouse. The entire desktop stops updating. The GNOME clock stops ticking off seconds, cursors stop flashing in web browsers or terminal windows. Simply moving the mouse brings everything back to life.

The following bash command line shows that this issue is causing processes to block. The gaps below where seconds are skipped are where I saw the desktop freeze, waited a little while, and then moved the mouse to bring everything back to life. The bash process was obviously frozen during the gaps because it didn't print out the missing seconds after the mouse movement.

I'm willing to help troubleshoot this issue further. (I'm a C++ programmer.) Note I have a more recent Catalyst driver installed because bugs in the stock Ubuntu Catalyst package were causing me problems (with development of a game).

$ while true; do { date; sleep 1; } done
Mon Nov 1 11:39:24 CDT 2010
Mon Nov 1 11:39:25 CDT 2010
Mon Nov 1 11:39:26 CDT 2010
Mon Nov 1 11:39:34 CDT 2010
Mon Nov 1 11:39:35 CDT 2010
Mon Nov 1 11:39:44 CDT 2010
Mon Nov 1 11:39:45 CDT 2010
Mon Nov 1 11:39:46 CDT 2010
Mon Nov 1 11:39:47 CDT 2010
Mon Nov 1 11:39:48 CDT 2010
Mon Nov 1 11:39:49 CDT 2010
Mon Nov 1 11:39:50 CDT 2010
Mon Nov 1 11:39:51 CDT 2010
Mon Nov 1 11:39:52 CDT 2010
Mon Nov 1 11:39:53 CDT 2010
Mon Nov 1 11:39:54 CDT 2010
Mon Nov 1 11:39:55 CDT 2010
Mon Nov 1 11:39:56 CDT 2010
Mon Nov 1 11:39:57 CDT 2010
Mon Nov 1 11:40:03 CDT 2010
Mon Nov 1 11:40:04 CDT 2010
Mon Nov 1 11:40:05 CDT 2010
Mon Nov 1 11:40:06 CDT 2010
Mon Nov 1 11:40:07 CDT 2010
Mon Nov 1 11:40:08 CDT 2010
Mon Nov 1 11:40:09 CDT 2010
Mon Nov 1 11:40:13 CDT 2010
Mon Nov 1 11:40:14 CDT 2010
^C

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-terminal 2.30.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-25.45-generic 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Mon Nov 1 11:37:46 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-terminal

Shawn Yarbrough (shawnyar217) wrote :
affects: gnome-terminal (Ubuntu) → ubuntu
Book 'em Dano (heymrdjd) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please attach your X server configuration file (/etc/X11/xorg.conf) if it is exists and X server log file (/var/log/Xorg.0.log) to the bug report as individual uncompressed file attachments using the "Attachment:" box below. Could you please also try to run without any /etc/X11/xorg.conf and let Xorg autodetect your display and video card? When you do please also attach the /var/log/Xorg.0.log from this attempt. Thanks in advance.

affects: ubuntu → xorg (Ubuntu)
Changed in xorg (Ubuntu):
status: New → Incomplete
Book 'em Dano (heymrdjd) wrote :

When you experience the freezing on your pc, could you also attach the kern.log and sys.log to this report.

Changed in xorg (Ubuntu):
importance: Undecided → Medium
Shawn Yarbrough (shawnyar217) wrote :
Shawn Yarbrough (shawnyar217) wrote :
Shawn Yarbrough (shawnyar217) wrote :
Shawn Yarbrough (shawnyar217) wrote :
Shawn Yarbrough (shawnyar217) wrote :

I attached four log files. I notice many rtkit-daemon error messages in syslog. The process 1962 mentioned in those error messages at the very bottom of syslog is a pulseaudio process.

Also note, I upgraded to Ubuntu 10.10 today but I still see the issue. I believe the system is now using the proprietary 10.8 Catalyst driver included with Ubuntu.

Book 'em Dano (heymrdjd) on 2010-11-23
Changed in xorg (Ubuntu):
status: Incomplete → New
Jacek Kolodziej (drumlin) wrote :

Same issue on my side. Just bought a new laptop: Lenovo G550, installed Ubuntu 10.10 and am facing issue as above: while it is not all the times, it very often (50% of time?) runs into mode where until I move mouse or press a key the computer completely freezes (does completely nothing, e.g. flash animation on the web stops, or screensaver demo). It does things in the background only as long as I am moving the mouse.

Interesting: this laptop model is known for its issues with touchpad. In my case, when I use touchpad, every few minutes touchpad stops working for approx 5 seconds and then it works again.

Visual effects linkage: not sure if any. E.g. I was using "normal" visual effects mode when the system freezing started. When switched to no visual effects in Ubuntu, the freezing continued.

Jacek Kolodziej (drumlin) wrote :
Jacek Kolodziej (drumlin) wrote :
Jacek Kolodziej (drumlin) wrote :

I do not have xorg.conf on my fresh Ubuntu 10.10.

Bryce Harrington (bryce) wrote :

Hmm, weird, let's troubleshoot it as a driver issue, although I suspect kernel or something else.

affects: xorg (Ubuntu) → fglrx-installer (Ubuntu)
Shawn Yarbrough (shawnyar217) wrote :

I did more testing on my box. With the box in an idle state (~0% CPU load), I used a hitch-detection script (it prints a "hitch" error to stdout every time the system goes more than two seconds without scheduling the script) to try the following:

After sudo /etc/init.d/gdm stop, and logging in at the text console (ctrl-alt-F1), the script still reported hitches, so the issue would not seem to be X-related.

Still on the text console, /etc/init.d stopping apache2, ntop, mysql, ntpd, had no effect, I still saw hitches.

Switching into single-user mode (sudo telinit 1, choose without networking) had no effect, I still saw hitches.

During a hitch, tapping the ctrl key was enough to immediately wake the system back up (causing the hitch to be reported by the script).

After restarting gdm, I tried uninstalling Sun VirtualBox, but I still saw hitches.

I found an old Ubuntu 9.10 CD and booted up from that. No hitches detected after 30 minutes.

Shawn Yarbrough (shawnyar217) wrote :

Resetting the BIOS/CMOS (by selecting "Load Optimized Defaults") appears to have fixed this issue. 5 hours so far with no hitches (freezes). I can't imagine why any BIOS setting would cause this issue with Ubuntu but I'm optimistic about the problem being fixed.

IIRC this box is 16 months old. The only BIOS options I clearly remember tweaking were the boot order and some enable-virtualization setting. I'll continue testing for a few days and see if I can isolate a single setting that causes the issue.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
bnomis (bmlaunchpad) wrote :

I had a similar effect on an AMILO Pi 2550 (Intel T8100 Core 2 Duo processor). The problem was not related to X, but seems to be caused by problems associated with deeper sleep states of the processors (BIOS bug?). Adding "processor.max_cstate=1" to the kernel boot parameters solved the issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers