update to 10.10 fail on dkms and fglrx

Bug #661658 reported by Matthias Taube on 2010-10-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: dkms

At update from 10.04 to 10.10, the update of dkms and fglrx fails.

After reboot the computer is not able to start the graphical login-screen.

I can fix this with an sudo aptitude safe-upgrade from outside with an ssh login.

the message of safe-upgrade is (sorry for german environment):

mati@freya:~$ sudo aptitude safe-upgrade
Löse Abhängigkeiten auf ...
Die folgenden NEUEN Pakete werden zusätzlich installiert:
  dkms{a} fakeroot{a}
0 Pakete aktualisiert, 2 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
Muss 101kB/31,8MB an Archiven herunterladen. Nach dem Entpacken werden 868kB zusätzlich belegt sein.
Wollen Sie fortsetzen? [Y/n/?] y
Hole:1 http://de.archive.ubuntu.com/ubuntu/ maverick/main fakeroot amd64 1.14.4-1ubuntu1 [101kB]
101kB wurden in 0 s heruntergeladen (218kB/s)
Wähle vormals abgewähltes Paket dkms.
(Lese Datenbank ... 257850 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke dkms (aus .../dkms_2.1.1.2-3ubuntu1_all.deb) ...
Wähle vormals abgewähltes Paket fglrx.
Vorbereiten zum Ersetzen von fglrx 2:8.780-0ubuntu2 (durch .../fglrx_2%3a8.780-0ubuntu2_amd64.deb) ...
Entpacke Ersatz für fglrx ...
Wähle vormals abgewähltes Paket fakeroot.
Entpacke fakeroot (aus .../fakeroot_1.14.4-1ubuntu1_amd64.deb) ...
Verarbeite Trigger für man-db ...
Verarbeite Trigger für ureadahead ...
Richte dkms ein (2.1.1.2-3ubuntu1) ...
Richte fglrx ein (2:8.780-0ubuntu2) ...
update-alternatives: Verwende /usr/lib/fglrx/ld.so.conf, um /etc/ld.so.conf.d/GL.conf (gl_conf) in Auto-Modus bereitzustellen.
update-alternatives: Warnung: Überspringe Erstellung von /usr/bin/amdcccle, weil die zugehörige Datei /usr/lib/fglrx/bin/amdcccle
 (der Link-Gruppe gl_conf) nicht existiert.
update-alternatives: Warnung: Überspringe Erstellung von /usr/bin/amdxdg-su, weil die zugehörige Datei /usr/lib/fglrx/bin/amdxdg-su
 (der Link-Gruppe gl_conf) nicht existiert.
update-alternatives: Warnung: Überspringe Erstellung von /usr/share/applications/ubuntu-amdcccle.desktop, weil die zugehörige Datei /usr/share/fglrx/amdcccle.desktop
 (der Link-Gruppe gl_conf) nicht existiert.
update-alternatives: Warnung: Überspringe Erstellung von /usr/share/applications/ubuntu-amdccclesu.desktop, weil die zugehörige Datei /usr/share/fglrx/amdccclesu.desktop
 (der Link-Gruppe gl_conf) nicht existiert.
update-initramfs: deferring update (trigger activated)
Loading new fglrx-8.780 DKMS files...
Building only for 2.6.35-22-generic
Building for architecture x86_64
Building initial module for 2.6.35-22-generic
Done.

fglrx.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/2.6.35-22-generic/updates/dkms/

depmod......

DKMS: install Completed.
update-initramfs: deferring update (trigger activated)
Richte fakeroot ein (1.14.4-1ubuntu1) ...
update-alternatives: Verwende /usr/bin/fakeroot-sysv, um /usr/bin/fakeroot (fakeroot) in Auto-Modus bereitzustellen.
Verarbeite Trigger für python-gmenu ...
Rebuilding /usr/share/applications/desktop.de_DE.utf8.cache...
Verarbeite Trigger für initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.35-22-generic
Verarbeite Trigger für libc-bin ...
ldconfig deferred processing now taking place
Verarbeite Trigger für python-support ...
E: Konnte Sperre /var/lib/dpkg/lock nicht bekommen - open (11: Resource temporarily unavailable)
E: Sperren des Administrationsverzeichnisses (/var/lib/dpkg/) nicht möglich, wird es von einem anderen Prozess verwendet?
E: Konnte die System-Sperre nicht zurückerlangen! (Vielleicht läuft noch ein apt oder dpkg?)
E: Konnte Sperre /var/lib/dpkg/lock nicht bekommen - open (11: Resource temporarily unavailable)
E: Sperren des Administrationsverzeichnisses (/var/lib/dpkg/) nicht möglich, wird es von einem anderen Prozess verwendet?

Aktueller Status: 0 kaputt [-1].

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: update-manager 1:0.142.20
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Sat Oct 16 10:32:42 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
PackageArchitecture: all
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: update-manager

Matthias Taube (m-taube) wrote :
affects: dkms (Ubuntu) → fglrx-installer (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers