Ubuntu

Xorg freeze with fglrx driver update

Reported by i30817 on 2010-09-25
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by Phenix

Bug Description

Binary package hint: xorg

amd 64 machine, running in safe mode now. Started happening after i updated the fglrx version from the ubuntu repositories (from the previous version, don't know exactly what, but it was the previously available version) and doing sudo aticonfig --initial -f as normal. If sudo aticonfig --initial -f wasn't used, it would boot, but fglxr_glxgears would crash.
Crashing fglrx is fglrx-installer (2:8.780-0ubuntu1) maverick; urgency=low

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+5ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CheckboxSubmission: 5338f309e5bc05d25ccb3da66559e5b1
CheckboxSystem: 2954e74ba17fb0e37fc942cd1d9fab4e
Date: Sat Sep 25 13:02:20 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100317.1)
MachineType: Acer Aspire 5738
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic root=UUID=fa953705-1365-420e-af20-4942c9098416 ro single
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
dmi.bios.date: 09/17/2009
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.18
dmi.board.name: JV50
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.18:bd09/17/2009:svnAcer:pnAspire5738:pvr0100:rvnAcer:rnJV50:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 5738
dmi.product.version: 0100
dmi.sys.vendor: Acer
glxinfo: Error: command ['glxinfo'] failed with exit code -11:
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-24-generic

i30817 (i30817) wrote :
i30817 (i30817) wrote :

Maybe it will be fixed by a kernel update when it is released:
(II) Loading /usr/lib/xorg/extra-modules/modules/glesx.so
dlopen: /usr/lib/xorg/extra-modules/modules/glesx.so: undefined symbol: PictureScreenPrivateKeyRec
(EE) Failed to load /usr/lib/xorg/extra-modules/modules/glesx.so
(EE) Failed to load module "glesx" (loader failed, 7)

i30817 (i30817) wrote :

It's possible this was caused by the x-swat/x-updates repository, forgot i had that enabled.

i30817 (i30817) wrote :

Yes, it's from there. I removed the repository, uninstalled fglrx, installed again did the initial aticonfig and it started working. The problem is in the x-swat/x-updates fglrx driver (last update as i said).

i30817 (i30817) wrote :

mmm, i'm still on lucid, and this was for maverik. If i installed maverik would it work? I will try.

i30817 (i30817) wrote :

Yes that worked. User error, but maybe now at least it is documented.

Bryce Harrington (bryce) on 2010-09-26
affects: xorg (Ubuntu) → fglrx-installer (Ubuntu)
Simon (simonjwiles) wrote :

why is the x-swat/x-updates ppa offering to install a maverick package on lucid?

$ apt-cache policy fglrx
fglrx:
  Installed: 2:8.723.1-0ubuntu5
  Candidate: 2:8.780-0ubuntu1
  Version table:
     2:8.780-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ lucid/main Packages
 *** 2:8.723.1-0ubuntu5 0
        500 http://ftp.tku.edu.tw/ubuntu/ lucid-updates/restricted Packages
        100 /var/lib/dpkg/status
     2:8.723.1-0ubuntu3 0
        500 http://ftp.tku.edu.tw/ubuntu/ lucid/restricted Packages

I had to force the version back to the old one from lucid-updates this morning before I could use my system properly...

What happened to the correct lucid version that was installed on Friday and which meant I could see the plymouth splash for the first time since buying this laptop (Mobility Radeon HD 5000 Series)?

Phenix (gandhi51-83) wrote :

I had recently dist-upgrade from lucid to maverick and I had same error in my /var/log/Xorg.0.log (dlopen: /usr/lib/xorg/extra-modules/modules/glesx.so: undefined symbol: PictureScreenPrivateKeyRec) -> Empty black screen after the splash screen at normal startup. Before dist-upgrade, i used fglrx (catalyst 10.9) without problem.
After researchs, I discover some dependancy errors with packages like xserver-xorg or xserver-xorg-core. Versions was build for lucid (why? I don't know).

So I tried :
sudo dselect dist-upgrade --> propose to remove my old lucid package (lucky me)
sudo aptitude install fglrx --> install fglrx and (a lot of) dependancy. Maybe sudo apt-get install fglrx is enough, I don't know, I don't try this first.

At this point, I could boot in recovery mode, lauch failsafeX, use an empty xorg.conf, restart X, log in, and hug my so missed desktop. I already knew this situation after upgrading fglrx with packages from amd/ati. The "undefined symbol" problem was solved.

Finally, I followed instructions to remove fglrx (ubuntu restricted) : http://wiki.cchtml.comindex.phpUbuntu_Lucid_Installation_Guide#Removing_the_Driver
and followed instructions to build and install fglrx (amd/ati) :
http://wiki.cchtml.com/index.php/Ubuntu_Lucid_Installation_Guide#Download_the_latest_Catalyst_package.
3D acceleration back. Smiles on my face too.

Thx for reading.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers