Comment 14 for bug 642518

I used this patch too.

It works perfectly.

For less experienced users, the following commands to apply the patch:

# In your home directory...

# to apply patch, if not already installed...
sudo apt-get install build-essential fakeroot devscripts

# In your home directory...
mkdir fglrx-installer
cd fglrx-installer

# download patch
wget https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/642518/+attachment/1607184/+files/fglrx-installer_8.723.1-0ubuntu5.debdiff

# get sources
apt-get source fglrx

# get depends
sudo apt-get build-dep fglrx

# patch it...
cd fglrx-installer*-* && patch -p1 < ../fglrx-installer_8.723.1-0ubuntu5.debdiff

# rebuild..
debuild -uc -us

# to install patched files..
sudo dpkg -i ../fglrx*.deb