Comment 117 for bug 642518

k-m (k-m) wrote :

I think my issue is related to the previous ones in this thread. 1st to begin with I have an ATI HD Radeon 5000 series and i'm running 10.04 AMD_64. After installing ubuntu I used Jockey (Ubuntu Control Center > Hardware Drivers) to update my graphics card. but I got an error message:

Code:
package fglrx 2:8.721-0ubuntu8 failed to install/upgrade: fglrx kernel module failed to build
Couple of days afterwards, an update was released, and the package is now fglrx 2:8.723.1-0ubuntu5. There was also an update for the kernel 2.6.32.25.27.

Following the instructions from http://ubuntuforums.org/showpost.php?p=9209703&postcount=16 and https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver I was able to update the driver and I think its working correctly.

Code:
phynx@phynx-laptop:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 5000 Series
OpenGL version string: 3.2.9756 Compatibility Profile Context

Code:
phynx@phynx-laptop:~$ glxinfo |grep vendor
server glx vendor string: ATI
client glx vendor string: ATI
OpenGL vendor string: ATI Technologies Inc.

Code:
phynx@phynx-laptop:~$ lspci -nn | grep Radeon
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Redwood [Radeon HD 5600 Series] [1002:68c1]
01:00.1 Audio device [0403]: ATI Technologies Inc Redwood HDMI Audio [Radeon HD 5600 Series] [1002:aa60]

Code:
Section "ServerLayout"
 Identifier "aticonfig Layout"
 Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
 Load "glx"
EndSection

Section "Monitor"
 Identifier "aticonfig-Monitor[0]-0"
 Option "VendorName" "ATI Proprietary Driver"
 Option "ModelName" "Generic Autodetecting Monitor"
 Option "DPMS" "true"
EndSection

Section "Device"
 Identifier "aticonfig-Device[0]-0"
 Driver "fglrx"
 BusID "PCI:1:0:0"
EndSection

Section "Screen"
 Identifier "aticonfig-Screen[0]-0"
 Device "aticonfig-Device[0]-0"
 Monitor "aticonfig-Monitor[0]-0"
 DefaultDepth 24
 SubSection "Display"
  Viewport 0 0
  Depth 24
 EndSubSection
EndSection

Now here are my issues.
1- The video is very laggy with compiz and videos. I used Google Earth to sometimes determine if the driver is not working very well. There are evidents cuts in the reendering of the images, when I use compiz show desktop, there is an evident lag, and the effects are visibly not working as they supposed to be. Unfortunately this issue is very hard to document, and not sure how to.

2- I decided to update to a newer driver using the X UPDATES PPA that has fglrx-installer 2:8.780-0ubuntu1. The problem with that update is that, after reboot, I only have a black screen. When I go to recovery, and go to ACCC with sudo rights it acts like fglrx and amdccle are not there.

Code:
$ sudo aticonfig --initial
Found fglrx primary device section
 Unable to find any supported Screen sections

I tried also what post #116 did, by upgrading the exact same kernel, and I tried to reinstall the fglrx packages, with that new kernel, I only get a black screen, with a loud fan noise, I also tried with the new kernel, with the fglrx packages installed, and installing the latest version from AMD website, same issue, i tried without the fglrx packages and only with the AMD website driver same issue.

For now i'm rolled back to the 723, and i have a laggy but somewhat working driver, but how do i get it to 780? I know my description of my problem is vague, but that's because i don't know yet how to effectively troubleshoot it, could someone give me ideas on what i could do, to make it work?