package fglrx 2:8.723.1-0ubuntu4 failed to install: fglrx kernel module failed to build

Bug #642362 reported by Ricardo on 2010-09-18
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

I have installed ubuntu 9.04 from a live CD coming in a magazine and the build of the driver fglrx worked fine. I have updated all the packages upgradables from the ubuntu repositories and the build of the drive failed. Then I have upgraded to 9.10 because I read in the wiki that new kernel parameters for video cards at setup is work in progress for radeon cards. The upgraded downloaded all the packages but when building the fglrx it failed. At that poin the upgrade was incomplete (nevertheless all the packages were installed). The last two steps, clean up and reboot were not executed.
Now I was working on other stuff but probably the system tried to build again the drive and failed.
Very often I have problems with new releases of Ubuntu, probably my PC, being built by me buying each single piece is not very standard (AMD Sempron, ATI radeon 2400 HD AGP 8x attached to a digital monitor via digital interface instead of VGA).
I had to install (and still using) the vesa mode...

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: fglrx 2:8.723.1-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic x86_64
Architecture: amd64
Date: Sat Sep 18 18:00:55 2010
DkmsStatus: fglrx, 8.723.1: added
ErrorMessage: fglrx kernel module failed to build
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
PackageVersion: 2:8.723.1-0ubuntu4
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic root=UUID=f68ba532-e7e5-42b9-a22a-99609308a504 ro quiet splash
SourcePackage: fglrx-installer
Title: package fglrx 2:8.723.1-0ubuntu4 failed to install/upgrade: fglrx kernel module failed to build
dmi.bios.date: 08/11/2005
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: SiS-760
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd08/11/2005:svn:pn:pvr:rvn:rnSiS-760:rvr:cvn:ct3:cvr:
glxinfo: Error: command ['glxinfo'] failed with exit code -11:
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-24-generic

Ricardo (ricardo-rios-libero) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers