package fglrx 2:8.723.1-0ubuntu4 failed to install/upgrade: fglrx kernel module failed to build

Bug #642110 reported by Nolan Taylor on 2010-09-18
8
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Using Ubuntu 10.04 lucid with kernel 2.6.32-24-generic
Kernel update appears to break fglrx 2.8.723.1. Attempts to reinstall from jockey and synaptic both fail.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: fglrx 2:8.723.1-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic x86_64
Architecture: amd64
Date: Sat Sep 18 09:37:16 2010
DkmsStatus: fglrx, 8.723.1: added
ErrorMessage: fglrx kernel module failed to build
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: System76, Inc. Pangolin Performance
PackageVersion: 2:8.723.1-0ubuntu4
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic root=UUID=625ed789-1cb3-4081-9c7e-f812810b5126 ro quiet splash acpi_os_name=Linux acpi_osi=Linux
SourcePackage: fglrx-installer
Title: package fglrx 2:8.723.1-0ubuntu4 failed to install/upgrade: fglrx kernel module failed to build
dmi.bios.date: 09/03/2010
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: CALPELLACRB.86C.0000.X.0000000000
dmi.board.asset.tag: Tag 12345
dmi.board.name: W76x/M77xCUH
dmi.board.vendor: CLEVO
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: CLEVO
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrCALPELLACRB.86C.0000.X.0000000000:bd09/03/2010:svnSystem76,Inc.:pnPangolinPerformance:pvrpanp7:rvnCLEVO:rnW76x/M77xCUH:rvrNotApplicable:cvnCLEVO:ct9:cvrN/A:
dmi.product.name: Pangolin Performance
dmi.product.version: panp7
dmi.sys.vendor: System76, Inc.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-24-generic

Nolan Taylor (nln-tylr) wrote :
Lumenary (nx-kadams) wrote :

Same thing happening here.

Upgrading to

-- 2.6.32-24.43-amd64-generic

definitely breaks fglrx, both the official Canonical/Ubuntu version, and these versions from the LaunchPad X-Swat PPA:

-- X-Swat PPA Home Page: https://launchpad.net/~ubuntu-x-swat

-- -- Affected Packages:
........ fglrx_2%3a8.753-0ubuntu0sarvatt~lucid_amd64.deb
........ fglrx_2%3a8.762-0ubuntu0sarvatt~lucid_amd64.deb
........ fglrx_2%3a8.771-0ubuntu0sarvatt~lucid_amd64.deb
........ fglrx-amdcccle_2%3a8.753-0ubuntu0sarvatt~lucid_amd64.deb
........ fglrx-amdcccle_2%3a8.762-0ubuntu0sarvatt~lucid_amd64.deb
........ fglrx-amdcccle_2%3a8.771-0ubuntu0sarvatt~lucid_amd64.deb
........ ........ (and associated 'modaliases' packages)

-- Ubuntu Lucid/Canonical Official Repository:

-- -- Affected Packages:
........ fglrx_8.723.1-0ubuntu4_amd64.deb
........ fglrx-amdcccle_8.723.1-0ubuntu4_amd64.deb
........ ........ (and associated 'modaliases' packages)

Lumenary (nx-kadams) wrote :

DKMS make.log for official Canonical package:

-- fglrx-8.723.1-0ubuntu4

Lumenary (nx-kadams) wrote :

DKMS make.log for official Canonical package:

-- fglrx-8.762-x-swat-ppa

Lumenary (nx-kadams) wrote :

Oops, sorry...

Post #4 was for

-- fglrx-8.762

from the Ubuntu X-Swat PPA.

To post a comment you must log in.