package fglrx 2:8.723.1-0ubuntu4 failed to install/upgrade: fglrx kernel module failed to build

Bug #641890 reported by Erhard Hoff on 2010-09-18
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

The problem occured already after installation of karmic, didn't remove fglrx before distribution upgrade.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: fglrx 2:8.723.1-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic x86_64
Architecture: amd64
Date: Sat Sep 18 11:01:55 2010
DkmsStatus: fglrx, 8.723.1: added
ErrorMessage: fglrx kernel module failed to build
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027.1)
MachineType: TOSHIBA Satellite Pro L670
PackageVersion: 2:8.723.1-0ubuntu4
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic root=UUID=56848b5a-ca8a-42d1-a5b2-f715161bf2cb ro quiet splash
SourcePackage: fglrx-installer
Title: package fglrx 2:8.723.1-0ubuntu4 failed to install/upgrade: fglrx kernel module failed to build
dmi.bios.date: 06/17/10
dmi.bios.vendor: TOSHIBA
dmi.bios.version: 1.40
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: NALAA
dmi.board.vendor: TOSHIBA
dmi.board.version: 1.00
dmi.chassis.asset.tag: *
dmi.chassis.type: 9
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvr1.40:bd06/17/10:svnTOSHIBA:pnSatelliteProL670:pvrPSK3FE-016009GR:rvnTOSHIBA:rnNALAA:rvr1.00:cvnTOSHIBA:ct9:cvrN/A:
dmi.product.name: Satellite Pro L670
dmi.product.version: PSK3FE-016009GR
dmi.sys.vendor: TOSHIBA
glxinfo: Error: command ['glxinfo'] failed with exit code -11:
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-24-generic

Erhard Hoff (erhard-hoff) wrote :
Alexander Avdoshin (a-avdoshin) wrote :

--- kcl_ioctl.c.old 2010-09-15 16:38:39.399690030 +0200
+++ kcl_ioctl.c 2010-09-15 16:39:55.632689146 +0200
@@ -193,7 +193,7 @@
  */
 void* ATI_API_CALL KCL_IOCTL_AllocUserSpace32(long size)
 {
- return compat_alloc_user_space(size);
+ return KCL_IOCTL_AllocUserSpace32(size);
 }

 #endif // __x86_64__

Just replace this in /var/lib/dkms/fglrx/8.771/source/kcl_ioctl.c then run sudo dpkg --configure fglrx, or just run sudo apt-get dist-upgrade once more
Alternatively, you can use attached file
Works fine for me

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Alexander Avdoshin (a-avdoshin) wrote :

here is patch

Changed in fglrx-installer (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Fix Committed
tags: added: patch
Paul B (pbarzu) wrote :

sorry for the newb question but how exactly do you apply the patch and where to?

Angelo Corsaro (angelo-corsaro) wrote :

I fixed sucessfully applying the Alexander's indication on fglrx ver 8.771

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers