system "halts/freezes/stops" if not using the computer (aka mouse/keyboard) for 5-30 seconds

Bug #577962 reported by fractaluser on 2010-05-09
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

http://ubuntuforums.org/showthread.php?t=1477258 <-- this is where you can find detailed information about my error.

Basically what it is: If im not using the keyboard or mouse for 5-30 seconds (depends on something im not sure of still today) the system would just "stop working". I can still see the screen but all visual stuff like text marker, smiley animation, downloads, upgrades, installations would just stop progressing if i havent used the mouse or the keyboard for 5-30 seconds. When "freezing/halting/stoping" i can just move my mouse and normal (if its not to much time between and depending on operation) the system would go on working. If i for instance would download the ubuntu iso of aprox 650mb and go out to smoke a cigarette for 5-7 minutes, when i come back to the computer the download would be stuck on the nr of % that it was during the 5-30 second period, same with the clock and anything else thats animated on my desktop.

If i would move my mouse, the clock would show the current time and not 5-7 minutes before, the download though would go down (normaly) to 5-20kb/sec, after being a steady 1100kb/sec before taking the cigarette and normally i wouldnt be able to "resume" the download. Instead i would have to re-download the release and try to keep the mouse active during the whole downloading session. Same goes if im in terminal doing a sudo apt-get upgrade or sudo apt-get install urbanterror (650mb) or even sudo apt-get install webcamstudio (a few megs), in the download of the source it would halt, same as it would do while installing it.....IF im not moving my mouse or using the computer.

This is indeed a weird issue i've never experienced before and this is using linux since 98. Though there is a bright light shining and its the PPM from Alf Gaida: https://launchpad.net/~info-g-com/+archive/xserver-xorg-1.7.6-gc
When i installed this i could "not use" my computer/keyboard/mouse for over 1 minute! This has NEVER happened before, it always was MAX 30 seconds before it would hang, but with this PPM it could hold out for over a minute time. It also solved the issue of the minimize/maximize alt tab, win tab, slowness of 1-3 seconds most fglrx users where experiencing. After running this PPM i've never had a linux dist this fast! Its so amazing! Still im not sorted 100% since it still "hangs" after 1 minute, but on two tries, i could "not use" the computer for 1.18 minutes and second try 1.48 minutes. For me this was AMAZING! thats a real improvement to me and on top of all it made the graphics A LOT faster.

So please include this in the main repos as i think it would help a lot of ppl that really dont understand the problem with ati and their graphics cards. In my topic we speak about this and the issue between maybe Xorg and fglrx, it would be a gold mine to fix this problem (at least for me) but im sure someone else is experiencing the same issue but just cant put the finger on what it is. As you can see on my post, even i had a hard time to see what actually was the issue, since EVERYTHING gets affected.

Thanks to Alf's PPM and Iain (ibuclaw) from ubuntu forums!

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: fglrx 2:8.723.1-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Sun May 9 21:48:30 2010
DkmsStatus: fglrx, 8.723.1, 2.6.32-22-generic, x86_64: installed
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: FUJITSU SIEMENS AMILO Xi 2550
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=c14c4ebd-4dcd-41ac-a88f-bd6adb3b84c3 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: fglrx-installer
dmi.bios.date: 09/30/2008
dmi.bios.vendor: Phoenix
dmi.bios.version: 1.15
dmi.board.name: F44
dmi.board.vendor: FUJITSU SIEMENS
dmi.board.version: 00030D005501535C
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU SIEMENS
dmi.modalias: dmi:bvnPhoenix:bvr1.15:bd09/30/2008:svnFUJITSUSIEMENS:pnAMILOXi2550:pvr:rvnFUJITSUSIEMENS:rnF44:rvr00030D005501535C:cvnFUJITSUSIEMENS:ct10:cvr:
dmi.product.name: AMILO Xi 2550
dmi.sys.vendor: FUJITSU SIEMENS
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-22-generic

fractaluser (fractaluser) wrote :
Billy (lacky111) wrote :

Have you tried booting with the kernel options
processor.max_cstate=1
nohz=off

Hmm nope i havent actually. Though i've upgraded to the latest ubuntu and
the problem semes to be going away slowly. I still experience the same thing
but this time the timeframe is longer.
If i set my clock to show seconds i see exactly when it stops now and as
soon as i move the mouse those "lost" seconds are recovered and the computer
is in normal state as long as i use it.
I'll try to boot with those options u showed me and see if there is any
change and i'll get back to you.

Thanks for showing interest in my weird issue =)

On Sun, Nov 21, 2010 at 10:25 AM, Billy <email address hidden> wrote:

> Have you tried booting with the kernel options
> processor.max_cstate=1
> nohz=off
>
> --
> system "halts/freezes/stops" if not using the computer (aka mouse/keyboard)
> for 5-30 seconds
> https://bugs.launchpad.net/bugs/577962
> You received this bug notification because you are a direct subscriber
> of the bug.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers