Watermark "AMD unsupported hardware" is displayed

Bug #568015 reported by Daniel Kamm on 2010-04-21
This bug affects 13 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)

Bug Description

On the lower right corner of the display, a watermark with it's text "AMD Unsupported hardware" is displayed. On the system, a Sapphire Radeon HD5830 is installed (see lspci).

The system and the fglrx driver itself are working neatlessly (at 30kfps@glxgears).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: fglrx 2:8.723.1-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed Apr 21 20:11:49 2010
 fglrx, 8.723.1, 2.6.32-19-generic, x86_64: installed
 fglrx, 8.723.1, 2.6.32-21-generic, x86_64: installed
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406.1)
MachineType: System manufacturer System Product Name
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-21-generic root=UUID=5d0a9fa1-c3a9-4ca1-a411-8c5157ea8ee0 ro quiet splash
 PATH=(custom, user)
SourcePackage: fglrx-installer
dmi.bios.date: 03/25/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0802
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P7H55-M PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0802:bd03/25/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP7H55-MPRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-21-generic

Daniel Kamm (ylz-ylz) wrote :
Kim Botherway (dj-dvant) wrote :

Same here on an integrated HD4290

Kim Botherway (dj-dvant) wrote :

Still exists on fglrx 2:8.723.1-0ubuntu4

coldReactive (coldreactive) wrote :

Same here on ATI Mobility Radeon HD 5870

Binks (tw01mn-kurzbericht) wrote :

ditto on the integrated HD4290

nimu (n-mussin) wrote :

and the same for Radeon HD 5830

nimu (n-mussin) wrote :

As stated here: http://www.phoronix.com/scan.php?page=news_item&px=NTkyMg
you will have to:

- Download the latest ati driver for your graphics card
- Extract the driver by executing the downloaded *.run file with option --extract in your terminal
- Go to the extracted folder and find common/etc/ati/control
- Copy the file named control into /etc/ati on your file system

With the latest control file the watermark should be gone.

This solved the problem for me.

coldReactive (coldreactive) wrote :

@nimu: And if we can't because the new drivers have a regression?


Or jockey drivers don't cause fatal slowdowns when merely dragging windows (without compiz)? (ATI drivers from the website do, with me. Or from Envy.)

nimu (n-mussin) wrote :

@coldReactive: I did not install the latest drivers. I still use the drivers that came with ubuntu and only replaced the control file located in /etc/ati

I've only downloaded the latest drivers to extract the control file, not to install it :)

So keep your (working) drivers and extract the latest *.run file by adding the option --extract in a terminal.
Then replace your current "control" file with the extracted one (as described above)

Please notice, that this only may help, if your graphics card is already WORKING and you only want to get rid of the watermark.

If your graphics card stopped working with the drivers, that come with ubuntu 10.04 you could try to install an older one and then replace the control file.

FriedChicken (domlyons) wrote :

Installing the latest driver (from 26th Mai I think) solved this problem for me. So I guess a recent version of the driver should be included to Ubuntu.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
BobJ (bobjshannon) wrote :

Bug also affects Ubuntu 10.10 64bit.
AMD Fusion E-350 Processor
Gigabyte Mini-ITX GA-E350-N motherboard Ver 1.0

Proprietary driver installed from Ubuntu Repository
works fine, except for the "AMD Unsupported Hardware" Watermark in the lower right
corner of the screen.

Mantas Kriaučiūnas (mantas) wrote :

I've removed "AMD Unsupported Hardware" watermark from the screen simply - replaced /etc/ati/control file with *older* file, from Ubuntu 10.10 or 10.04 package :)
It seems sometimes control file should be replaced with older file, not with newer :)

Antti Kaihola (akaihola) wrote :

I have the watermark in Ubuntu 11.04 with fglrx 2:8.840-0ubuntu4 and a SUMO 9640.

The exact version in the Catalyst Control Center is 8.84.6-110324a-116088C-ATI.

From /proc/cpuinfo:
AMD A8-3850 APU with Radeon(tm) HD Graphics

Antti Kaihola (akaihola) wrote :

Re #13: I removed the fglrx driver installed by Ubuntu and replaced it with the 11.8 Catalyst driver directly from AMD. The watermark disappeared and also it seems that some of the garbage I occasionally got when running a rotated display are now gone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers