Ubuntu

fglrx fails to identify attached monitor, displays blank screen

Reported by Manuel Sanchez on 2010-04-11
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

After installing fglrx 2:8.721.0ubuntu10 on Lucid Lynx beta 1 and running 'aticonfig --initial', X (1.7.5) only displays a blank screen (system is running, can be ssh'ed in). This is the same effect experienced on a prior Karmic Koala installation with an older version of the driver. On the other hand, xorg's radeon driver runs properly (albeit without GL acceleration).

When running 'aticonfig --query-monitor', I get the following output:
Default Adapter - ATI Radeon HD 5400 Series
# Connected monitors: none
  Enabled monitors: none

If I run xrandr when using xorg's radeon driver, the display is detected:
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 1680 x 1680
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 434mm x 270mm
   1680x1050 59.9*+
   1280x1024 75.0 60.0
   1152x864 75.0
   1024x768 75.0 60.0
   800x600 75.0 60.3
   640x480 75.0 59.9
   720x400 70.1
VGA-0 disconnected (normal left inverted right x axis y axis)

The card is a Saphire Radeon HD 5450 (512 DDR3 model) with 3 outputs: DVI, HDMI and VGA. The DVI output is connected to a DELL 2005 FPW monitor, with 1680x1050 native resolution.

Please advice if any other information is necessary.

Regards

Manuel

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: fglrx 2:8.721-0ubuntu10
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
CheckboxSubmission: 33a6ff8ffd30f8bd1df95c0b208fcb87
CheckboxSystem: 6ce041aeed0a2c17b3343b66d157175d
Date: Sun Apr 11 10:13:51 2010
DkmsStatus: fglrx, 8.721, 2.6.32-19-generic, i686: installed
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
MachineType: HP-Pavilion RR498AA-ABU s7720.uk
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=31fcdf37-c8d7-4b82-be95-905814e9201d ro quiet splash
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: fglrx-installer
dmi.bios.date: 12/18/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 5.03
dmi.board.name: Hematite
dmi.board.vendor: ASUSTek Computer INC.
dmi.board.version: 1.00
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: 1111
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr5.03:bd12/18/2006:svnHP-Pavilion:pnRR498AA-ABUs7720.uk:pvr:rvnASUSTekComputerINC.:rnHematite:rvr1.00:cvnHewlett-Packard:ct3:cvr1111:
dmi.product.name: RR498AA-ABU s7720.uk
dmi.sys.vendor: HP-Pavilion
glxinfo: Error: command ['glxinfo'] failed with exit code -11:
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-19-generic

LarsIvarIgesund (larsivar) wrote :

I should mention that aticonfig --initial does not work at all for me, since the file /etc/ati/control does not appear to be installed (I have tried to remove and reinstall the package several times).

Felix Kuehling (felix-kuehling) wrote :

It would be helpful to see an Xorg.0.log file with fglrx active. Both XorgLog.txt and XorgLogOld.txt attached to this bug are with RADEON active.

Hello Felix,

I'm enclosing the correct version of the log files, along with the xorg.conf file generated by aticonfig. There is a slight change of behaviour since updating gdm; now rather than stalling on a blank screen, X now stalls on the ubuntu 10.04 splash (screen white lettering on top of orange dots). I guess this is not rendered through fglrx, but please correct me if I'm wrong.

As far as I can interpret the log files, I cannot see anything conspicuous apart from the driver mentioning that there is no device section for the pci dev at 1:00:1. This is the HDMI audio dev embedded in the card, as far as I can gather from the lspci output (also enclosed).

The aticonfig --query-monitor output remains the same (not that it should change, I pressume)

Hope this helps, and thanks a lot

Manuel

Felix Kuehling (felix-kuehling) wrote :

The log file just stops half way through the driver initialization. There's no backtrace. There are two possibilities:

1. the Xserver is still spinning at 100% CPU load in the background
2. the system crashed hard and didn't have a chance to write the complete log file to the disk

You could try updating to the latest driver that was published on Saturday. That may fix your problem.

Nick Irvine (nfirvine) wrote :

I think this is a duplicate of Bug#552644.

I'm having similar symptoms to both. System appears to hang at end of splash screen, but is actually running, just broken video. Cannot get to other terminals via (Ctrl)+Alt+Fx Can ssh into it.

I've noticeed that if I remove the fglrx package and switch over to a failsafe xorg.conf then install fglrx again, running aticonfig --initial, then restart GDM, I get my nice hi-res desktop, but as soon as I reboot, no X, frozen splash screen, etc.

I'm about to try new updates, will report back.

Nick Irvine (nfirvine) wrote :

Yes, it appears to be working. I'm always amazed at the speed of fixes in Ubuntu!

I'm afraid I wasn't as lucky as Nick and 2:8.723-0ubuntu1 didn't fix my problem. The only difference I could notice is that there is a slight flash of the screen when it hangs on the splash screen, while the image displayed remains the same.

Out of the two scenarios that Felix described, the 1st is what is happening to me: Xorg is hanging, taking 100% of one core. I tried attaching to it from gdb (su) and get a PC or a stack trace but even the debugger hangs trying to do so. Please let me know if there is any other thing I could try that could be of help to diagnose this problem.

I was hoping this problem would just be a matter of the display not being supported (because of the odd --query-monitor result). It now looks much more complicated.

Regards

Manuel

As by my previous post, I don't think this is a duplicate of Bug#552644, since the latest update didn't fix it. It may be related, though.

description: updated
Gary Cameron (gary-cameron) wrote :

If your card drives multiple monitors, I recall my HD5970 card at least ID'd my monitor correctly when I switched them. It didn't seem to make sense to me, but it might be worth a try.

Thanks Gary, I'm afraid my problem doesn't have to do with multiple monitors as I only have 1 attached. I will try to get hold of a second one to test whether this is due to the monitor not being supported, but from the way it hangs X I doubt so (otherwise it should bail out with "no screens found" or a similar msg...).

Maciek Sujkowski (maciejus) wrote :

looking at the XorgLog it looks similar to the one in the bug I raised for my card https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/566239. I am having this issue since catalyst 9.9 so it looks like some change was made since 9.9 which causes the error however I reported this to ati/amd devs throught their website and had completely no response ...

Hi,

I have what looks to be exactly the same problem with 10.04 and an Saphire 5450 (512 DD3 model) as Manuel. The card is working fine under Windoze. Maybe just a coincidence but I also have an HP Pavilion with a Hermatite motherboard. May not be so surprising as I think many opt to put these cards into the HP slimlines.

As with the first poster, hangs on the splash screen. I have tried different monitors but to no avail. I couldn't get this HW config to work in Karmic either.

Cheers, Chris.

Just to report that the behaviour experienced after updating flgrx to the latest version (2:8.723.0ubuntu4) is identical (brief flash in Plymouth, then Xorg hangs with 100% CPU load on boot). The outputs for all logs all the same (nothing meaningful, AFAIU).

I reiterate my offer to the developers to help retrieving any debugging information that may be relevant.

Regards, Manuel

Have you tried it with the latest Catalyst driver (Catalyst 10.6, driver release 8.743)?

To update using generated Ubuntu packages, download Catalyst into an empty directory and run

    ati-driver-installer...run --buildpkg
    dpkg --install *.deb
    aticonfig --initial -f

and reboot.

Thanks for the hint Felix,

as you suggested I downloaded the latest Catalyst, installed the generated packages (rel 8.741 in my case) and run aticonfig. Unfortunately it failed with the same behaviour as before. Is there any way to put the driver in any sort of 'verbose mode' so I can gather more information?

Also, I didn't know that Catalyst could be installed in Ubuntu 10.04 after the removal of HAL <place Space Odissey joke here>. I will keep track of new releases and try them, rather than waiting for the ubuntu rollout as I was doing until now.

Thanks again

Manuel

I noticed you're using an nVidia MCP51 chipset. I've seen other reports of our driver hanging systems with that chipset.

Indeed, I'm using a socket AM2 motherboard equipping the nForce 430 chipset (aka MCP51); to be more precise it is an Asus model A8MN-BR, marketed as Hematite-GL8E by HP. I presume Chris from post #13 has the same model.

I'll check for other reports with this particular gpu/chipset combo to see whether we can amalgamate them in a master thread.

Regards

Manuel

After some digging, I've found ticket filed for this same issue in ATI's bugzilla:

http://ati.cchtml.com/show_bug.cgi?id=1794

what I gathered from other thread references in the ticket is that the issues with MCP51 follow a regression in Catalyst 9.9

I'm delighted to report that my instance of this bug was fixed by the latest released of the Catalyst drivers (10.7). I've tested this along with kernel 2.6.32-24 and Xserver 2:1.7.6-2ubuntu7.3 (all 32 bit). Compiz and GL in general work fine.

Many thanks to the fglrx team for the fix

Manuel

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.