Ubuntu

Comment 2 for bug 559323

Yuri Baranov (baranov) wrote :

After upgrade to 10.04 beta 2 still unable to install fglrx

$ uname -a
Linux deep42 2.6.32-19-generic #28-Ubuntu SMP Wed Mar 31 17:46:20 UTC 2010 i686 GNU/Linux

$ apt-get install fglrx
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libfreebob0 firefox-3.5-branding xulrunner-1.9.1 libaudio-dev libiec61883-0 libkadm5clnt-mit7
  mplayer-skins comerr-dev libtdb1 libesd-alsa0 libxmu-headers libsqlite0 libkrb5-dev libcln5
  libkadm5clnt6 libglu1-xorg-dev libsqlite0-dev policykit libgssrpc4 sdparm libx264-67
  libqt4-phonon-dev libcelt0 libavc1394-0 libkrosspython0 krb5-multidev gtk2-ex-formfactory-perl
  libssl-dev libxt-dev libxmu-dev libffado1 xlibmesa-gl-dev anyevent-perl fglrx-kernel-source
  firefox-3.5 liblcms1-dev libxml++2.6-2 libpq-dev libkadm5srv-mit7 libcanberra0 libkdb5-4 libmng-dev
  libfaac0 libfaad0
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  fglrx
0 upgraded, 1 newly installed, 0 to remove and 132 not upgraded.
3 not fully installed or removed.
Need to get 18.2MB of archives.
After this operation, 59.8MB of additional disk space will be used.
Get:1 http://ru.archive.ubuntu.com/ubuntu/ lucid/restricted fglrx 2:8.721-0ubuntu7 [18.2MB]
Fetched 18.2MB in 59s (306kB/s)
(Reading database ... 171469 files and directories currently installed.)
Unpacking fglrx (from .../fglrx_2%3a8.721-0ubuntu7_i386.deb) ...
dpkg-divert: mismatch on package
  when removing `diversion of /usr/lib/xorg/modules/extensions/libdri.so to /usr/lib/fglrx/libdri.so.xlibmesa by fglrx'
  found `diversion of /usr/lib/xorg/modules/extensions/libdri.so to /usr/lib/fglrx/libdri.so.xlibmesa by xorg-driver-fglrx'
dpkg: error processing /var/cache/apt/archives/fglrx_2%3a8.721-0ubuntu7_i386.deb (--unpack):
 subprocess new pre-installation script returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/fglrx_2%3a8.721-0ubuntu7_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@deep42:~/Documents# aptitude search fglrx