package fglrx (not installed) failed to install/upgrade: dpkg-divert: mismatch on package

Bug #552782 reported by Craig Chambers on 2010-03-31
720
This bug affects 157 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
High
Alberto Milone
Lucid
High
Alberto Milone

Bug Description

== workaround ==
suggested in bug 546917 comment #5

# apt-get remove xorg-driver-fglrx fglrx fglrx-amdcccle
# dpkg-divert --remove /usr/lib/xorg/modules/extensions/libdri.so
# dpkg-divert --remove /usr/lib/xorg/modules/extensions/libglx.so
# apt-get install fglrx

You can then activate the driver from System > Administration > Hardware Drivers.

upgrade from 9.10 performed on an ACER Ferrari One (AMD Congo chipset)

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: fglrx (not installed)
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
Uname: Linux 2.6.31-20-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Wed Mar 31 20:23:37 2010
DkmsStatus:
 virtualbox-ose, 3.1.4, 2.6.32-18-generic, i686: installed
 virtualbox-ose, 3.1.4, 2.6.31-20-generic, i686: installed
EcryptfsInUse: Yes
ErrorMessage:
 ErrorMessage: no package named `fglrx' is installed, cannot configure
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Acer Ferrari One 200
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic root=UUID=ad0b9fb9-9446-4e01-8dfa-fdeffaa6022e ro quiet splash
SourcePackage: fglrx-installer
Title: package fglrx (not installed) failed to install/upgrade:
dmi.bios.date: 01/14/2010
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: v1.3110
dmi.board.name: California
dmi.board.vendor: Acer
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrv1.3110:bd01/14/2010:svnAcer:pnFerrariOne200:pvrNotApplicable:rvnAcer:rnCalifornia:rvrNotApplicable:cvnAcer:ct10:cvrN/A:
dmi.product.name: Ferrari One 200
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer
glxinfo:
 Error: couldn't find RGB GLX visual or fbconfig
 name of display: :0.0
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.31-20-generic

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

The relevant error is
---
Unpacking fglrx (from .../fglrx_2%3a8.721-0ubuntu7_i386.deb) ...

dpkg-divert: mismatch on package

  when removing `diversion of /usr/lib/xorg/modules/extensions/libdri.so to /usr/lib/fglrx/libdri.so.xlibmesa by fglrx'

  found `diversion of /usr/lib/xorg/modules/extensions/libdri.so to /usr/lib/fglrx/libdri.so.xlibmesa by xorg-driver-fglrx'

dpkg: error processing /var/cache/apt/archives/fglrx_2%3a8.721-0ubuntu7_i386.deb (--unpack):

 subprocess new pre-installation script returned error exit status 2

summary: - package fglrx (not installed) failed to install/upgrade:
+ package fglrx (not installed) failed to install/upgrade: dpkg-divert:
+ mismatch on package
Changed in fglrx-installer (Ubuntu):
importance: Undecided → High
status: New → Confirmed
tags: added: karmic2lucid
description: updated
Bryce Harrington (bryce) on 2010-04-03
Changed in fglrx-installer (Ubuntu Lucid):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer (Ubuntu Lucid):
milestone: none → ubuntu-10.04
Accorte (accorte) wrote :

Hi,

I also get the same message like Jean-Baptiste, but the workaround doesn't work for me. I don't get any drivers listed on System > Administration > Hardware Drivers. I've got an ATI HD 4890 which is quite an modern model.
Installing fglrx with apt-get returns always exit status 2.

spbike (bill-broadley) wrote :

I did the following to fix it.

aptitude update
aptitude purge openoffice-core
<it removed a ton of openoffice packages, fglrx, and some kdelibs>

aptitude install openoffice-core
aptitude install fglrx
aptitude upgrade

Things seem back to normal.

The dpkg-divert commands didn't seem to help, nor could I apt-get remove or apt-get purge they would both give me errors.

Abdó Roig-Maranges (aroig) wrote :

This workaround partially worked for me. Using it I managed to cleanly install fglrx, but after the apparently successful installation there were some missing files.

I upgraded from karmic to lucid in a 64 bit machine with an ATI graphics card using fglrx (i.e. I had the package xorg-driver-fglrx installed on karmic).

1 - Some files in /etc/ati were missing, not sure which ones. It seems that the upgrade script backed up the old karmic files, but forgot to install the new ones. This made aticonfig complain about a missing /etc/ati/control, for example.

2 - Some libraries in /usr/lib/fglrx/ were also missing. The one I remember is libGL.so.1.2. Not sure why this happened.

The solution I found to both this problems is removing fglrx and fglrx-amdcccle completely with:

aptitude purge fglrx fglrx-amdcccle

deleting manually /usr/lib/fglrx and /etc/ati:

rm -R /usr/lib/fglrx
rm -R /etc/ati

and then reinstalling both packages:

aptitude install fglrx

3 - The files libglx.so and libdri.so in /usr/lib/xorg/modules/extensions/ were also missing. Those files belong to the package xserver-xorg-core, and are the ones involved in the diversion thing discussed in this thread. This prevented the open source driver radeon from working, leaving the framebuffer as the only working alternative just after upgrade.

The solution to this was reinstalling xserver-xorg-core:

aptitude reinstall xserver-xorg-core

Oh, by the way, I have ended up with the open source driver by the moment. The fglrx apparently works fine, but the performance is terrible ! 894 fps in glxgears (vs 2620 fps with the radeon driver). Any clue about this ? It may be an upstream issue ?

tags: added: iso-testing
Steve Langasek (vorlon) on 2010-04-08
Changed in fglrx-installer (Ubuntu Lucid):
status: Confirmed → Triaged
Steve Langasek (vorlon) wrote :

I've reviewed the package history, and believe the attached patch is a correct fix for this - the fglrx binary package never provided this diversion, so when cleaning it up we should always pass the previous package name, xorg-driver-fglrx.

Yentl (yentlvt) wrote :

Had the same problem, and solved by executing this command manually, thus removing the xorg-drivers-fglrx instead of fglrx:
"sudo dpkg-divert --remove --rename --package xorg-driver-fglrx --divert /usr/lib/fglrx/libdri.so.xlibmesa /usr/lib/xorg/modules/extensions/libdri.so > /dev/null"
Afterwards, fglrx installs normally. However I still had a problem with the graphics card not being recognized, but this was solved after executing
"sudo aticonfig --initial"
After a reboot everything worked fine.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.721-0ubuntu8

---------------
fglrx-installer (2:8.721-0ubuntu8) lucid; urgency=low

  * debian/rules, fglrx.dirs, fglrx.postinst:
    - Install the blacklist file in /lib/fglrx instead of
      /usr/lib/fglrx so that the file is available early
      in the boot process when /usr is on a different
      partition (LP: #538071).
    - Ignore errors when trying to update the initramfs
      with -k $CURRENT_KERNEL which is known to fail when
      using chroots (LP: #556653).
    - Make 10fglrx a slave link so that it's removed from
      /etc/X11/Xsession.d when we switch to a different
      alternative (LP: #552903).
  * debian/fglrx.preinst:
    - Make sure that any 10fglrx file in /etc/X11/Xsession.d
      which is not a symbolic link is removed.
    - Remove diversions previously added by xorg-driver-fglrx
      not by fglrx (LP: #552782). Thanks to Steve Langasek
      for spotting the problem.
 -- Alberto Milone <email address hidden> Thu, 08 Apr 2010 18:37:48 +0200

Changed in fglrx-installer (Ubuntu Lucid):
status: Triaged → Fix Released
Download full text (3.7 KiB)

How & where to install this package?

2010/4/8 Launchpad Bug Tracker <email address hidden>

> This bug was fixed in the package fglrx-installer - 2:8.721-0ubuntu8
>
> ---------------
> fglrx-installer (2:8.721-0ubuntu8) lucid; urgency=low
>
> * debian/rules, fglrx.dirs, fglrx.postinst:
> - Install the blacklist file in /lib/fglrx instead of
> /usr/lib/fglrx so that the file is available early
> in the boot process when /usr is on a different
> partition (LP: #538071).
> - Ignore errors when trying to update the initramfs
> with -k $CURRENT_KERNEL which is known to fail when
> using chroots (LP: #556653).
> - Make 10fglrx a slave link so that it's removed from
> /etc/X11/Xsession.d when we switch to a different
> alternative (LP: #552903).
> * debian/fglrx.preinst:
> - Make sure that any 10fglrx file in /etc/X11/Xsession.d
> which is not a symbolic link is removed.
> - Remove diversions previously added by xorg-driver-fglrx
> not by fglrx (LP: #552782). Thanks to Steve Langasek
> for spotting the problem.
> -- Alberto Milone <email address hidden> Thu, 08 Apr 2010
> 18:37:48 +0200
>
> ** Changed in: fglrx-installer (Ubuntu Lucid)
> Status: Triaged => Fix Released
>
> --
> package fglrx (not installed) failed to install/upgrade: dpkg-divert:
> mismatch on package
> https://bugs.launchpad.net/bugs/552782
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “fglrx-installer” package in Ubuntu: Fix Released
> Status in “fglrx-installer” source package in Lucid: Fix Released
>
> Bug description:
> == workaround ==
> suggested in bug 546917 comment #5
>
> # apt-get remove xorg-driver-fglrx fglrx fglrx-amdcccle
> # dpkg-divert --remove /usr/lib/xorg/modules/extensions/libdri.so
> # dpkg-divert --remove /usr/lib/xorg/modules/extensions/libglx.so
> # apt-get install fglrx
>
> You can then activate the driver from System > Administration > Hardware
> Drivers.
>
>
> upgrade from 9.10 performed on an ACER Ferrari One (AMD Congo chipset)
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.04
> Package: fglrx (not installed)
> ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
> Uname: Linux 2.6.31-20-generic i686
> NonfreeKernelModules: fglrx
> Architecture: i386
> Date: Wed Mar 31 20:23:37 2010
> DkmsStatus:
> virtualbox-ose, 3.1.4, 2.6.32-18-generic, i686: installed
> virtualbox-ose, 3.1.4, 2.6.31-20-generic, i686: installed
> EcryptfsInUse: Yes
> ErrorMessage:
> ErrorMessage: no package named `fglrx' is installed, cannot configure
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> MachineType: Acer Ferrari One 200
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic
> root=UUID=ad0b9fb9-9446-4e01-8dfa-fdeffaa6022e ro quiet splash
> SourcePackage: fglrx-installer
> Title: package fglrx (not installed) failed to install/upgrade:
> dmi.bios.date: 01/14/2010
> dmi.bios.vendor: Phoenix Technologies LTD
> dmi.bios.version: v1.3110
> dmi.board.name: California
> dmi.board.vendor: Acer
> dmi.board.version: Not Applicable
> dmi.chassis.type: 10
> dmi.chassis.vendor: Acer
> dmi.chassis.version...

Read more...

J Harpster (harpomatic) wrote :

where do I download the fix?

Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Released → Confirmed
status: Confirmed → Fix Released
J Harpster (harpomatic) wrote :

I'm going to remove this (beta don't work) until your stable version comes out at the end of the month.Since you can't send me a downloadable fix that doesn't require writing in manually the solution I have no interest in this beta version. I have wasted two days waiting for this pile to install and at the end of it all you give me a notice of not installed upgrade aborted then installed with problems all at the same time make up your damn minds. It's back to 9.1 or windows if this doesn't work out. I thought you guys had the right idea giving an alternative to the insanely bloated windows that have built in back doors for snooping but I was wrong I guess..........

Accorte (accorte) wrote :

Some days before I also tried "sudo dpkg-divert --remove --rename --package xorg-driver-fglrx --divert /usr/lib/fglrx/libGL.so.1.2.xlibmesa /usr/lib/libGL.so.1.2 > /dev/null
", but every time I started a OGL application I got a memory error.
I upgraded my packages today, installed "fglrx, fglrx-amdcccle" and used "sudo aticonfig --initial". Now the bug is gone and OpenGL works fine again.

Thank you Canonical!

Download full text (3.6 KiB)

Please keep in mind that Ubuntu is completely free of charge, and a lot of the work is done by volenteers on their spare time. Downloading a alpha/beta release and reporting bugs is one way a normal user can contribute. If you where looking for a stable system you should have waited for the final release. The fix for this particular bug should be available in the repositories so a simple update/upgrade should do it.

-opprinn. melding-
Emne: [Bug 552782] Re: package fglrx (not installed) failed to install/upgrade: dpkg-divert: mismatch on package
Fra: J Harpster <email address hidden>
Dato: 09.04.2010 20:14

I'm going to remove this (beta don't work) until your stable version
comes out at the end of the month.Since you can't send me a downloadable
fix that doesn't require writing in manually the solution I have no
interest in this beta version. I have wasted two days waiting for this
pile to install and at the end of it all you give me a notice of not
installed upgrade aborted then installed with problems all at the same
time make up your damn minds. It's back to 9.1 or windows if this
doesn't work out. I thought you guys had the right idea giving an
alternative to the insanely bloated windows that have built in back
doors for snooping but I was wrong I guess..........

--
package fglrx (not installed) failed to install/upgrade: dpkg-divert: mismatch on package
https://bugs.launchpad.net/bugs/552782
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Status in “fglrx-installer” package in Ubuntu: Fix Released
Status in “fglrx-installer” source package in Lucid: Fix Released

Bug description:
== workaround ==
suggested in bug 546917 comment #5

# apt-get remove xorg-driver-fglrx fglrx fglrx-amdcccle
# dpkg-divert --remove /usr/lib/xorg/modules/extensions/libdri.so
# dpkg-divert --remove /usr/lib/xorg/modules/extensions/libglx.so
# apt-get install fglrx

You can then activate the driver from System > Administration > Hardware Drivers.

upgrade from 9.10 performed on an ACER Ferrari One (AMD Congo chipset)

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: fglrx (not installed)
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
Uname: Linux 2.6.31-20-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Wed Mar 31 20:23:37 2010
DkmsStatus:
 virtualbox-ose, 3.1.4, 2.6.32-18-generic, i686: installed
 virtualbox-ose, 3.1.4, 2.6.31-20-generic, i686: installed
EcryptfsInUse: Yes
ErrorMessage:
 ErrorMessage: no package named `fglrx' is installed, cannot configure
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Acer Ferrari One 200
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic root=UUID=ad0b9fb9-9446-4e01-8dfa-fdeffaa6022e ro quiet splash
SourcePackage: fglrx-installer
Title: package fglrx (not installed) failed to install/upgrade:
dmi.bios.date: 01/14/2010
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: v1.3110
dmi.board.name: California
dmi.board.vendor: Acer
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrv1.3110:bd01/14/2010...

Read more...

Steve Langasek (vorlon) wrote :

On Fri, Apr 09, 2010 at 07:45:16PM -0000, Andreas Noteng wrote:
> The fix for this particular bug should be available in the repositories so
> a simple update/upgrade should do it.

Unfortunately, a build failure prevented the fix from being immediately
available on 32-bit installs. This is fixed now, and the package will be
available from the archive in less than an hour.

Yuri Baranov (baranov) wrote :

Still does not work for me.

(1)
$ aptitude search fglrx
p fglrx - Video driver for the ATI graphics accelerators
BdA fglrx-amdcccle - Catalyst Control Center for the ATI graphics accelerat
p fglrx-dev - Video driver for the ATI graphics accelerators (devel
BdA fglrx-kernel-source - Transitional package for fglrx-kernel-source
i fglrx-modaliases - Identifiers supported by the ATI graphics driver
BB xorg-driver-fglrx - Transitional package for xorg-driver-fglrx

(2)
$ apt-get remove xorg-driver-fglrx fglrx fglrx-amdcccle
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package fglrx is not installed, so not removed
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  fglrx-kernel-source: Depends: fglrx but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

(3)
$ dpkg-divert --remove /usr/lib/xorg/modules/extensions/libdri.so
$ dpkg-divert --remove /usr/lib/xorg/modules/extensions/libglx.so

those are ok

(4)
$ apt-get install fglrx
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libfreebob0 firefox-3.5-branding xulrunner-1.9.1 libaudio-dev libiec61883-0 libkadm5clnt-mit7
  mplayer-skins comerr-dev libtdb1 libesd-alsa0 libxmu-headers libsqlite0 libkrb5-dev libcln5
  libkadm5clnt6 libglu1-xorg-dev libsqlite0-dev policykit libgssrpc4 sdparm libx264-67
  libqt4-phonon-dev libcelt0 libavc1394-0 libkrosspython0 krb5-multidev gtk2-ex-formfactory-perl
  libssl-dev libxt-dev libxmu-dev libffado1 xlibmesa-gl-dev anyevent-perl fglrx-kernel-source
  firefox-3.5 liblcms1-dev libxml++2.6-2 libpq-dev libkadm5srv-mit7 libcanberra0 libkdb5-4 libmng-dev
  libfaac0 libfaad0
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  fglrx
0 upgraded, 1 newly installed, 0 to remove and 132 not upgraded.
3 not fully installed or removed.
Need to get 0B/18.2MB of archives.
After this operation, 59.8MB of additional disk space will be used.
(Reading database ... 171467 files and directories currently installed.)
Unpacking fglrx (from .../fglrx_2%3a8.721-0ubuntu7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fglrx_2%3a8.721-0ubuntu7_i386.deb (--unpack):
 trying to overwrite '/etc/ati/signature', which is also in package xorg-driver-fglrx 2:8.721-0ubuntu7
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Errors were encountered while processing:
 /var/cache/apt/archives/fglrx_2%3a8.721-0ubuntu7_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I suppose, the problem is somehow related to a package name containing a colon.

@Yuri Baranov, the fix is available in fglrx-installer (2:8.721-0ubuntu8) and you're installing 2:8.721-0ubuntu7 . The error you're experiencing in point (4) is not this report but bug 559587.

Yuri Baranov (baranov) wrote :

> you're installing 2:8.721-0ubuntu7 .

2:8.721-0ubuntu10 also does not work on my system.

dpkg: error processing /var/cache/apt/archives/fglrx_2%3a8.721-0ubuntu10_i386.deb (--unpack):
 trying to overwrite '/etc/ati/signature', which is also in package xorg-driver-fglrx 2:8.721-0ubuntu7
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Errors were encountered while processing:
 /var/cache/apt/archives/fglrx_2%3a8.721-0ubuntu10_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

You are right, now my problem looks exactly like bug 559587.
I am confused a bit :-(

Alberto Milone (albertomilone) wrote :

@Yuri
You're definitely experiencing bug 559587, as Jean-Baptiste suggested.

Ramit Hora (horar) wrote :

I upgraded from 9.10 -> 10.04 a couple of days ago and since then fglrx has not worked, on 9.10 things were perfect.

Originally 8.721 was installed and since then the upgrade to 8.723.1-0ubuntu3 came out but I'm experiencing the same thing:

$ sudo /usr/lib/fglrx/bin/aticonfig
Unable to open /etc/ati/control, please reinstall the driver.
/usr/lib/fglrx/bin/aticonfig: No supported adapters detected

I have removed and reinstalled the fglrx package about 6 times as that was suggested as a way to fix things in various bugs but that has not helped.

I have confirmed that the packages are installed properly.

$ dpkg -l | grep -i fglrx
ii fglrx 2:8.723.1-0ubuntu3 Video driver for the ATI graphics accelerato
ii fglrx-amdcccle 2:8.723.1-0ubuntu3 Catalyst Control Center for the ATI graphics
ii fglrx-modaliases 2:8.723.1-0ubuntu3 Identifiers supported by the ATI graphics dr
ii xorg-driver-fglrx 2:8.723.1-0ubuntu3 Transitional package for xorg-driver-fglrx

$ dpkg --get-selections | grep -i fglrx
fglrx install
fglrx-amdcccle install
fglrx-modaliases install
xorg-driver-fglrx install

However there is no directory created at /etc/ati after install and no drivers placed within the xorg directory, /usr/lib/xorg/extra-modules/

$ ls /etc/ati
ls: cannot access /etc/ati: No such file or directory

$ ls /usr/lib/xorg/extra-modules
libglx.so libglx.so.195.36.15 nvidia_drv.so

All help appreciated.

Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Released → Incomplete
Steve Langasek (vorlon) wrote :

Separate issue. Please file a new bug report.

Changed in fglrx-installer (Ubuntu Lucid):
status: Incomplete → Fix Released
Alberto Milone (albertomilone) wrote :

@Ramit
I agree with Steve. It's a different issue.

Please remove the driver and install it from Jockey (i.e. "Hardware drivers" in the app menu) instead of installing packages manually. I bet that's the cause of your problem.

greyebeard8550 (n5pci1) wrote :

Worked for me. All is working fine.
Hardware Drivers would install fglrx, but did not work.

On Sun, Apr 25, 2010 at 8:56 AM, Steve Langasek <
<email address hidden>> wrote:

> Separate issue. Please file a new bug report.
>
> ** Changed in: fglrx-installer (Ubuntu Lucid)
> Status: Incomplete => Fix Released
>
> --
> package fglrx (not installed) failed to install/upgrade: dpkg-divert:
> mismatch on package
> https://bugs.launchpad.net/bugs/552782
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “fglrx-installer” package in Ubuntu: Fix Released
> Status in “fglrx-installer” source package in Lucid: Fix Released
>
> Bug description:
> == workaround ==
> suggested in bug 546917 comment #5
>
> # apt-get remove xorg-driver-fglrx fglrx fglrx-amdcccle
> # dpkg-divert --remove /usr/lib/xorg/modules/extensions/libdri.so
> # dpkg-divert --remove /usr/lib/xorg/modules/extensions/libglx.so
> # apt-get install fglrx
>
> You can then activate the driver from System > Administration > Hardware
> Drivers.
>
>
> upgrade from 9.10 performed on an ACER Ferrari One (AMD Congo chipset)
>
> Bob Davenport
Ubuntu 10.04 Lucid Lynx RC2 IA64
(Fantastic Mal-ware removal tool)
It will remove windows from your
computer in 10 seconds..

Ray (dakotacab) on 2010-05-01
Changed in fglrx-installer (Ubuntu):
status: Fix Released → Incomplete
status: Incomplete → New
status: New → Fix Released
ioseba (iosebaere) wrote :

Very thanks, but I made a clean install.
Great release.

2010/5/1 Ray <email address hidden>

> ** Changed in: fglrx-installer (Ubuntu)
> Status: Fix Released => Incomplete
>
> ** Changed in: fglrx-installer (Ubuntu)
> Status: Incomplete => New
>
> ** Changed in: fglrx-installer (Ubuntu)
> Status: New => Fix Released
>
> --
> package fglrx (not installed) failed to install/upgrade: dpkg-divert:
> mismatch on package
> https://bugs.launchpad.net/bugs/552782
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “fglrx-installer” package in Ubuntu: Fix Released
> Status in “fglrx-installer” source package in Lucid: Fix Released
>
> Bug description:
> == workaround ==
> suggested in bug 546917 comment #5
>
> # apt-get remove xorg-driver-fglrx fglrx fglrx-amdcccle
> # dpkg-divert --remove /usr/lib/xorg/modules/extensions/libdri.so
> # dpkg-divert --remove /usr/lib/xorg/modules/extensions/libglx.so
> # apt-get install fglrx
>
> You can then activate the driver from System > Administration > Hardware
> Drivers.
>
>
> upgrade from 9.10 performed on an ACER Ferrari One (AMD Congo chipset)
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.04
> Package: fglrx (not installed)
> ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
> Uname: Linux 2.6.31-20-generic i686
> NonfreeKernelModules: fglrx
> Architecture: i386
> Date: Wed Mar 31 20:23:37 2010
> DkmsStatus:
> virtualbox-ose, 3.1.4, 2.6.32-18-generic, i686: installed
> virtualbox-ose, 3.1.4, 2.6.31-20-generic, i686: installed
> EcryptfsInUse: Yes
> ErrorMessage:
> ErrorMessage: no package named `fglrx' is installed, cannot configure
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> MachineType: Acer Ferrari One 200
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic
> root=UUID=ad0b9fb9-9446-4e01-8dfa-fdeffaa6022e ro quiet splash
> SourcePackage: fglrx-installer
> Title: package fglrx (not installed) failed to install/upgrade:
> dmi.bios.date: 01/14/2010
> dmi.bios.vendor: Phoenix Technologies LTD
> dmi.bios.version: v1.3110
> dmi.board.name: California
> dmi.board.vendor: Acer
> dmi.board.version: Not Applicable
> dmi.chassis.type: 10
> dmi.chassis.vendor: Acer
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnPhoenixTechnologiesLTD:bvrv1.3110:bd01/14/2010:svnAcer:pnFerrariOne200:pvrNotApplicable:rvnAcer:rnCalifornia:rvrNotApplicable:cvnAcer:ct10:cvrN/A:
> dmi.product.name: Ferrari One 200
> dmi.product.version: Not Applicable
> dmi.sys.vendor: Acer
> glxinfo:
> Error: couldn't find RGB GLX visual or fbconfig
> name of display: :0.0
> system:
> distro: Ubuntu
> codename: lucid
> architecture: i686
> kernel: 2.6.31-20-generic
>
>
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/552782/+subscribe
>

To post a comment you must log in.