Installing fglrx results in booting to safe-graphics mode

Bug #552702 reported by Ian Corne on 2010-03-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

$ lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04

$ apt-cache policy fglrx
fglrx:
  Installed: 2:8.721-0ubuntu7
  Candidate: 2:8.721-0ubuntu7

I installed it via the jockey-gtk tool.
After rebooting it threw me into a black screen with the option to either let it generate a general config file, or a hardware specific one.
I selected generic and now I don't have direct rending.
Compiz is disabled.

The old xorg.conf file (before the generic one [ which is actually no file at all] ) had this content:

$ cat /etc/X11/xorg.conf-backup-100331192102

Section "Screen"
 Identifier "Default Screen"
 DefaultDepth 24
EndSection

Section "Module"
 Load "glx"
EndSection

Section "Device"
 Identifier "Default Device"
 Driver "fglrx"
EndSection

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: fglrx 2:8.721-0ubuntu7
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed Mar 31 19:31:59 2010
DkmsStatus: fglrx, 8.721, 2.6.32-18-generic, x86_64: installed
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MachineType: System manufacturer P5E
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-18-generic root=UUID=bdc1d737-6fa9-4e17-ad48-3c43c30796bc ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: fglrx-installer
dmi.bios.date: 04/07/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0702
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0702:bd04/07/2008:svnSystemmanufacturer:pnP5E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5E
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-18-generic

Ian Corne (icorne) wrote :
Olaf Leidinger (leidola) wrote :

Does it work when running aticonfig --initial manually? Seems to work for me.

Ian Corne (icorne) wrote :

This was during developement. It's been fixed

Changed in fglrx-installer (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers