gnome-screensaver-gl-helper crashed with SIGSEGV in XF86DRIQueryVersion()

Bug #545257 reported by fiat1100d on 2010-03-23
This bug affects 367 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-screensaver

Found the crash after unlocking the screen

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Tue Mar 23 18:09:16 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/lib/gnome-screensaver/gnome-screensaver-gl-helper
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: gnome-screensaver 2.29.92-0ubuntu1
ProcCmdline: /usr/lib/gnome-screensaver/gnome-screensaver-gl-helper
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=it_IT.utf8
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
SegvAnalysis:
 Segfault happened at: 0x7f6167a1211e <XF86DRIQueryVersion+174>: mov 0x4(%rax),%eax
 PC (0x7f6167a1211e) ok
 source "0x4(%rax)" (0x00000004) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-screensaver
StacktraceTop:
 XF86DRIQueryVersion ()
 XF86DRIQueryExtension ()
 ?? () from /usr/lib/fglrx/libGL.so.1
 ?? () from /usr/lib/fglrx/libGL.so.1
 glXChooseVisual () from /usr/lib/fglrx/libGL.so.1
Title: gnome-screensaver-gl-helper crashed with SIGSEGV in XF86DRIQueryVersion()
Uname: Linux 2.6.31-20-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WindowManager: metacity

fiat1100d (gratteri-email) wrote :
visibility: private → public

StacktraceTop:
 XF86DRIQueryVersion ()
 XF86DRIQueryExtension ()
 ?? () from /usr/lib/fglrx/libGL.so.1
 ?? () from /usr/lib/fglrx/libGL.so.1
 glXChooseVisual () from /usr/lib/fglrx/libGL.so.1

Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
affects: gnome-screensaver (Ubuntu) → fglrx-installer (Ubuntu)
Felix Kuehling (felix-kuehling) wrote :

You installed fglrx but you didn't configure Xorg to actually use it. You're still using the RADEON driver. Having fglrx installed breaks the open-source 3D driver in the way you're experiencing.

To activate fglrx run the following command and reboot: sudo aticonfig --initial -f

Robert Hooker (sarvatt) wrote :

In every one of these bugs, fglrx is not being used but it is installed. To fix this you should deactivate the driver, delete /etc/X11/xorg.conf and reactivate fglrx through jockey and then reboot if you indeed have a card supported by fglrx. The reboot is required before 3D support is available like the message says when you activate it. Like Felix said, if you have fglrx installed you cannot use the open source drivers without getting this error because it overrides some X libs. This is not a bug in the package but a misconfiguration for various reasons so I am closing this bug. Support can be obtained through http://ubuntuforums.com (free) or http://www.ubuntu.com/support (paid)

Changed in fglrx-installer (Ubuntu):
status: New → Invalid
Chris S (maildepot) wrote :

Have been trying to install fglrx in Ubuntu 10.10. That failed as bug reported elsewhere. Will uninstall and see if this screen saver problem is fixed

with the latest updates fglrx kernel modules compile fine now (unlike before)

Olisemeka Omo (speedbaron) wrote :
Download full text (3.6 KiB)

I am using kubuntu 10.10
Here is my bt:
++++++++++++++++++++++++++++++++

Application: KDE Control Module (kcmshell4), signal: Segmentation fault
[KCrash Handler]
#6 0x00007ffa20c4f38e in XF86DRIQueryVersion () from /usr/lib/fglrx/libGL.so.1
#7 0x00007ffa20c4f529 in XF86DRIQueryExtension () from /usr/lib/fglrx/libGL.so.1
#8 0x00007ffa20c4ee3c in ?? () from /usr/lib/fglrx/libGL.so.1
#9 0x00007ffa20c2e51f in ?? () from /usr/lib/fglrx/libGL.so.1
#10 0x00007ffa20c2a8d1 in ?? () from /usr/lib/fglrx/libGL.so.1
#11 0x00007ffa20c2aaae in glXChooseVisual () from /usr/lib/fglrx/libGL.so.1
#12 0x00007ffa2101bf98 in KSWidget::KSWidget (this=0xfda790, parent=<value optimized out>, wf=<value optimized out>) at ../../../kcontrol/screensaver/kswidget.cpp:74
#13 0x00007ffa21012624 in KSSMonitor (this=0xc62710) at ../../../kcontrol/screensaver/kssmonitor.h:34
#14 KScreenSaver::slotPreviewExited (this=0xc62710) at ../../../kcontrol/screensaver/scrnsave.cpp:521
#15 0x00007ffa21016f8e in KScreenSaver::findSavers (this=0xc62710) at ../../../kcontrol/screensaver/scrnsave.cpp:480
#16 0x00007ffa2101767c in KScreenSaver::qt_metacall (this=0xc62710, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffa7367460) at ./scrnsave.moc:104
#17 0x00007ffa2fb6fb27 in QMetaObject::activate (sender=0xc53af0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3280
#18 0x00007ffa2fb698f9 in QObject::event (this=0xc53af0, e=0x7fffa73648c0) at kernel/qobject.cpp:1183
#19 0x00007ffa2eebefdc in QApplicationPrivate::notify_helper (this=0xb18340, receiver=0xc53af0, e=0x7fffa7367bb0) at kernel/qapplication.cpp:4396
#20 0x00007ffa2eec4aed in QApplication::notify (this=0x7fffa7367f70, receiver=0xc53af0, e=0x7fffa7367bb0) at kernel/qapplication.cpp:4277
#21 0x00007ffa307f3156 in KApplication::notify (this=0x7fffa7367f70, receiver=0xc53af0, event=0x7fffa7367bb0) at ../../kdeui/kernel/kapplication.cpp:310
#22 0x00007ffa2fb57cdc in QCoreApplication::notifyInternal (this=0x7fffa7367f70, receiver=0xc53af0, event=0x7fffa7367bb0) at kernel/qcoreapplication.cpp:732
#23 0x00007ffa2fb876f2 in sendEvent (this=0xb1c030) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#24 QTimerInfoList::activateTimers (this=0xb1c030) at kernel/qeventdispatcher_unix.cpp:602
#25 0x00007ffa2fb844a4 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#26 0x00007ffa2b2a5342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0x00007ffa2b2a92a8 in ?? () from /lib/libglib-2.0.so.0
#28 0x00007ffa2b2a945c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0x00007ffa2fb84193 in QEventDispatcherGlib::processEvents (this=0xb00f90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#30 0x00007ffa2ef71a4e in QGuiEventDispatcherGlib::processEvents (this=0xb28e30, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007ffa2fb56a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#32 0x00007ffa2fb56dec in QEventLoop::exec (this=0x7fffa7367e50, flags=) at kernel/qeventloop.cpp:201
#33 0x00007ffa2...

Read more...

Olisemeka Omo (speedbaron) wrote :

Sorry Guys,

Felix Kuehling is right.
Running 'sudo aticonfig --initial -f' and rebooting solved the problem.

Not a bug.

It would be nice if there is an automated way that the system can fix it itself.

Changed in fglrx-installer (Ubuntu):
status: Invalid → New

Why is this being resurrected. This was not a bug to begin with, but more a support request.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed

Not sure if this is exactly what I'm seeing but on hybrid-gpu systems
(intel+fglrx), there are situations, where having fglrx loaded without
actually being used by X is something one could want.

Power management for example.. without fglrx, the fan of a HP Pavilion
dv7 laptop won't stop. With fglrx, the laptop in question is quiet:

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: ATI Technologies Inc Device 6740

$ lsmod | egrep 'fglrx|i915'
i915 451068 2
drm_kms_helper 40745 1 i915
fglrx 2434640 0
drm 184164 3 i915,drm_kms_helper
i2c_algo_bit 13184 1 i915
video 18951 1 i915

Bryce Harrington (bryce) on 2012-03-06
Changed in fglrx-installer (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers