should not offer -fglrx until it is available in the development version

Bug #508860 reported by Peder Madsen on 2010-01-17
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Wishlist
Unassigned
jockey (Ubuntu)
High
Unassigned

Bug Description

Ubuntu AMD64 Lucid Alpha 2: After install, I enable ATI proprietary drivers through the System --> Administration --> Hardware Drivers menu option. This causes X to crash at next boot. The open source driver works OK, incl. enabling Desktop Effects. The hardware is a HP Envy 15 with ATI 4300 Mobility Radeon and an I7 Quad processor.
xserver-xorg:
  Installed: 1:7.5+1ubuntu1
  Candidate: 1:7.5+1ubuntu1
  Version table:
 *** 1:7.5+1ubuntu1 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Sun Jan 17 20:06:22 2010
Disassembly: 0x0: Cannot access memory at address 0x0
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/Xorg
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100113)
MachineType: Hewlett-Packard HP Envy 15 Notebook PC
NonfreeKernelModules: fglrx
Package: xserver-xorg-core 2:1.7.3.902-1ubuntu8
ProcAttrCurrent: unconfined (enforce)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-10-generic root=UUID=a7b03bef-a3f6-4628-b5d9-df270927cee3 ro quiet splash
ProcCmdline: /usr/bin/X :1 -br -verbose -auth /var/run/gdm/auth-for-gdm-4FEMRS/database -nolisten tcp vt7
ProcEnviron:
 LANG=en_DK.UTF-8
 PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5+1ubuntu1
 libgl1-mesa-glx 7.7-0ubuntu4
 libdrm2 2.4.17-0ubuntu1
 xserver-xorg-video-intel 2:2.9.1-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20091125.0061c4db-0ubuntu2
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: xorg-server
StacktraceTop:
 ?? ()
 FatalError ()
 _start ()
Tags: lucid
Title: Xorg crashed with SIGSEGV in FatalError()
Uname: Linux 2.6.32-10-generic x86_64
UserGroups:

dmi.bios.date: 12/10/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.07
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 7009
dmi.board.vendor: Quanta
dmi.board.version: 36.2B
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.07:bd12/10/2009:svnHewlett-Packard:pnHPEnvy15NotebookPC:pvr0394100000241910001420000:rvnQuanta:rn7009:rvr36.2B:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Envy 15 Notebook PC
dmi.product.version: 0394100000241910001420000
dmi.sys.vendor: Hewlett-Packard
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.32-10-generic

Peder Madsen (pederm) wrote :

StacktraceTop:
 ?? ()
 FatalError ()
 _start ()

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

fglrx doesn't work with the xserver in lucid. Jockey shouldn't offer it though.

visibility: private → public
affects: xorg-server (Ubuntu) → fglrx-installer (Ubuntu)
Bryce Harrington (bryce) wrote :

The fglrx-installer code should keep track of the version of xorg-server and kernel that the binary driver is compatible with and refuse to install if it notices a too-new version of either of these. This is because it's more common than not that newer versions include changes which break the proprietary driver.

summary: - Xorg crashed with SIGSEGV in FatalError() after enabling proprietary ATI
- driver
+ Jockey should not offer -fglrx until it is available in the development
+ version
summary: - Jockey should not offer -fglrx until it is available in the development
- version
+ should not offer -fglrx until it is available in the development version
Changed in fglrx-installer (Ubuntu):
importance: Medium → High
status: New → Triaged
Bryce Harrington (bryce) wrote :

I'm also adding a task against jockey for this issue, because however fglrx-installer is made to refuse to install when it sees versions of xserver and linux that it can't support, jockey should also respect this and not show the driver as available for the hardware.

Possibly, a simpler solution would be to leave fglrx-installer as is, and just manually disable/enable fglrx in jockey each release. As long as someone always remembers to do this going forward, it'd be an acceptable solution. But making it automatically detect would be nice as then (in theory) no one would have to remember to do this step. Also, it would be resilient against the user installing a newer kernel or xserver since these are now pretty easily available via PPAs now.

Changed in jockey (Ubuntu):
importance: Undecided → High
Bryce Harrington (bryce) wrote :

I believe the blocking of installation of fglrx has been implemented for Lucid as of this change, which post-dates this bug:

fglrx-installer (2:8.660-0ubuntu6) lucid; urgency=low

  * debian/control:
    - Provide xserver-xorg-video-5 so as to make the package
      uninstallable until AMD restores compatibility with X.
 -- Alberto Milone <email address hidden> Wed, 10 Feb 2010 10:14:14 -0500

Please re-test to see if it is still proposing this driver in Lucid. I'm leaving the bug open so we can review and consider adding code to make this occur automatically in some fashion. Similarly I'm leaving the jockey task intact. But the issue is worked around for Lucid at least, so the severity of this issue can be dropped to wishlist.

Changed in fglrx-installer (Ubuntu):
importance: High → Wishlist
Martin Pitt (pitti) wrote :

jockey (0.5.6-0ubuntu1) lucid; urgency=low
[...]
  * data/handlers/fglrx.py:
    - Keep fglrx disabled until AMD provides us with a driver that is
      compatible with Lucid's xserver.

Changed in jockey (Ubuntu):
status: New → Fix Released
Changed in fglrx-installer (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers