Ubuntu

[fglrx karmic] Black screen and no response after starting X (Radeon HD3870)

Reported by Maciek Sujkowski on 2009-11-22
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by mclaud2000
Declined for Lucid by Bryce Harrington

Bug Description

I have a problem with fglrx driver since Catalyst 9.9.
After installation and reboot I get only black screen when X tries to start and keyboard doesn't work however when I press power button then the system shuts down properly after a while.
I have noticed this for the first time on Hardy after installing Catalyst 9.9 and since then I have the same problem on Karmic and Catalyst 9.10/9.11 as well.
Last version of fglrx driver which works for me is the one from Catalyst 9.8 patched for Karmic's kernel (2.6.31)

This crash report has been made after reboot from unresponsive system and logging into single mode and then collecting the data by apport-cli

ProblemType: Bug
Architecture: amd64
Date: Sun Nov 22 02:08:47 2009
DistroRelease: Ubuntu 9.10
Lsusb:
 Bus 001 Device 002: ID 0846:4200 NetGear, Inc. WG121(v1) 54 Mbps Wireless [Intersil Prism GT]
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 002: ID 09da:0119 A4 Tech Co., Ltd
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: System manufacturer System Product Name
NonfreeKernelModules: fglrx
Package: xorg-driver-fglrx 2:8.671-0ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-15-generic root=UUID=7eb5b0f0-5bbe-4a2a-ac75-c57db68fa368 ro single gpt
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu10
 libgl1-mesa-glx 7.6.1~git20091118.fe5c4654-0ubuntu0~xup~1
 libdrm2 2.4.15+git20091116.c20706ff-0ubuntu0tormod~karmic
 xserver-xorg-video-intel 2:2.9.0+git20091111.dbb68168-0ubuntu0sarvatt
 xserver-xorg-video-ati 1:6.12.99+git20091117.43711312-0ubuntu0tormod~karmic
SourcePackage: fglrx-installer
Uname: Linux 2.6.31-15-generic x86_64
Xrandr: Error: command ['xrandr', '--verbose'] failed with exit code 1: Can't open display
dmi.bios.date: 02/05/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2NPV-VM ACPI BIOS Revision 1301
dmi.board.name: M2NPV-VM
dmi.board.vendor: ASUSTek Computer INC.
dmi.board.version: 1.xx
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2NPV-VMACPIBIOSRevision1301:bd02/05/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTekComputerINC.:rnM2NPV-VM:rvr1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
glxinfo: Error: command ['glxinfo'] failed with exit code 255: Error: unable to open display
setxkbmap: Error: command ['setxkbmap', '-print'] failed with exit code 255: Cannot open display "default display"
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-15-generic
xdpyinfo: Error: command ['xdpyinfo'] failed with exit code 1: xdpyinfo: unable to open display "".
xkbcomp:
 Error: command ['xkbcomp', ':0', '-w0', '-'] failed with exit code 1: Error: Cannot open display ":0"
                   Exiting

Maciek Sujkowski (maciejus) wrote :
summary: [fglrx-karmic] Black screen and no response after starting X (Radeon
- HD3870
+ HD3870)
description: updated
description: updated
summary: - [fglrx-karmic] Black screen and no response after starting X (Radeon
+ [fglrx karmic] Black screen and no response after starting X (Radeon
HD3870)
description: updated
Philippe Delodder (lodder) wrote :

Same issue with HD2400

Davidaf (davidaf) wrote :

Related to, if not duplicate of, #284687

I can confirm this bug, on a HD 4830 using Ubuntu karmic AMD64 the only driver that works for me is the catalyst 9.8 patched for the 2.6.31 kernel. I tried 9.9 through 9.12 and none of them works.

Struki (struki84) wrote :

I'm having some similar or exact problems, but I'm not sure what does "when X tries to start" means, generally I have random crashes that results in a black screen and then i need to reboot, witch I think is due to ati drivers. I'm running karmic on hp with radeon hd 3200 is there any file logs I can post?
I wrote in details on this thread about it : http://ubuntuforums.org/showthread.php?t=1402806

Bryce Harrington (bryce) on 2010-02-26
tags: added: karmic
Bryce Harrington (bryce) wrote :

[Nominated for lucid, but no evidence exists in bug report that it still affects lucid. A lucid compatible version of -fglrx was added just recently, so this needs retested.]

Giovanni Merlino (j0v4nn1) wrote :

I do-release-upgraded to 64-bit Lucid, and brand new fglrx release exhibits same symptoms here (Xorg 100% CPU, blank screen, and the Xorg.log stopping exactly at the same point as the submitter's one), on a HD5770 w/ 1GB VRAM, and 5 GB of main memory.

It leads to unkillable Xorg, only resort seems to be rebooting.

One more remark: I haven't really had time to delve further on this issue, but from the looks of it on the web (Googling around, and on various scattered forums, i.e ubuntuforums, phoronix.com, etc), it seems exclusive to 64-bit setups, especially with large amounts of RAM and recent models of Radeons (HD3xxx and upwards).

Someone seemed to point to MTRR as culprit, based on past problems with other (Intel or older ATi) cards (and also based on successes after manually fixing MTRR mapping).

Maciek Sujkowski (maciejus) wrote :

I think the issue still persist even on Lucid.
I have just installed today's cdimage of Lucid and everything was going smoothly until installation of fglrx.
Then the screen went white (after log off) and I only could power off my PC.
After reboot all I got is the splash screen with new Ubuntu logo and there is no progress from there.

Maciek Sujkowski (maciejus) wrote :

I also need to add that this time I installed i386 distribution

tags: added: lucid
tags: added: i386
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers