Switch user or guest session always hangs

Bug #478253 reported by Sergio on 2009-11-08
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by mclaud2000
Declined for Lucid by Bryce Harrington

Bug Description

Binary package hint: xorg

With a fresh install of Ubuntu 9.10, when i try to switch user or do a guest session, it goes to a black screen and after a few seconds, the keyboard stops responding (num lock, caps, lock, etc.).

It does not respond to ctrl+back+esc and also cannot change to another terminal.

It happens also when trying to do a switch user when the session is blocked.

I have the Visual effects off and the official fglrx driver than install Ubuntu for my Ati Radeon 3650HD.

It work well in Ubuntu 9.04 (upgraded from 8.04).

ProblemType: Bug
Architecture: i386
CheckboxSubmission: cbe2c330486cfb24be715e3309a0a647
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
Date: Sun Nov 8 12:16:39 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: fglrx
Package: xorg 1:7.4+3ubuntu7
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic-pae root=/dev/sda2 ro quiet splash
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic-pae
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xorg
Uname: Linux 2.6.31-14-generic-pae i686
dmi.bios.date: 06/09/2005
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: K8T800P-8237
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd06/09/2005:svn:pn:pvr:rvn:rnK8T800P-8237:rvr:cvn:ct3:cvr:
fglrx:

system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic-pae

Sergio (sergio-otero) wrote :
Sergio (sergio-otero) wrote :

I've uninstalled fglrx and also the DVB-T drivers and here are the results:

 * Switch user: the switch user screen appears, if i click in the same user, the screen goes blank, the mouse hangs and the keyboard keeps responding but i'm unable to switch to a terminal o end the x session
 * Switch user: i click another user and works. when i close this session, the same as before (blank screen, mouse hangs, etc.)
 * Log off: i can log into the same user or another user without problem

Bryce Harrington (bryce) on 2009-11-08
affects: xorg (Ubuntu) → fglrx-installer (Ubuntu)
jacobdspencer (jacob-d-spencer) wrote :

Same results here. Sony laptop VGN-FW290; I think it also has the 3650. System hangs when trying "switch user". Same behaviour with compiz on and off.

leha (ap-karelin) wrote :

The same behavior on Toshiba Satellite A300D-17M with ATI Mobility Radeon HD 3470.

Bryce Harrington (bryce) on 2010-02-26
tags: added: karmic
Alessio Spadaro (alessios) wrote :

Same behavior on Acer 5738 with Intel Pentium 4300 and ATI 4570

allan999 (allan-laal) wrote :

Using Ubuntu 9.10 32bit on a Lenovo T500 2082-8WG.

When choosing System->Log Out->Switch user: all current users applications are shut down; the screen goes blank, keyboard does not respond; just the wlan light keeps blinking. Only way out is to do a hard restart.

When the screen is locked an I choose Switch user the very same happens.

David Hembrow (david-hembrow) wrote :

I have the same problem. My VGA controller is (according to LSPCI): VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)

I edited xorg.conf in order to swap to the vesa driver but this problem remains (that change did at least allow Google Earth to run - another problem I was having with the other driver).

Bryce Harrington (bryce) wrote :

[Nominated for lucid, but no evidence exists in bug report that it still affects lucid. A lucid compatible version of -fglrx was added just recently, so this needs retested.]

Sergio (sergio-otero) wrote :

I've done some testing with Ubuntu 10.04 Alpha 3 live CD and i haven't been able to reproduce the problem.

I've created 2 users and i've successfully log in both of them, switched from one to the other, closed sessions, opened it again, closed, etc.

Stefan Carslöv (odur) wrote :

This bug is no longer affecting me since fglrx 10.2.
I'm on Kubuntu Karmic with KDE 4.4 SC

ndefontenay (n-de-fontenay) wrote :

Hi.

I've created a new user on Lucid Lynx 10.04 Beta 1 yesterday.
I confirm that the problem still exist.
The test was performed before and after update of the sytem yesterday, same behavior.

I run a DELL Studio 17 Laptop

Anton Gladky (gladky-anton) wrote :

I have Lucid Lynx, fresh install, since Alpha 2, Dell mini 10v. Same problem for me.

Bob Bevan-Jones (bevanjones) wrote :

This happened to me, too. I upgraded karmic to lucid on my ShuttleX a few days ago, and the new installation kept all my old settings - good! - but when I experimented with switching between users, I got the black screen your other correspondents reported, although I did have a white cursor which my mouse controlled. After staring at the computer screen for ages, vainly hoping that something would happen, I suddenly wondered if it might be expecting me to type in the password for the destination user. Doing this enabled me to regain control of the computer, but not straightaway (I miskeyed the password first time). I think the source of this problem lies with the default logon splash screen.

Sergio (sergio-otero) wrote :

It works OK for me with a clean 10.04 installation

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Sergio,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 478253

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 478253 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/478253

Changed in fglrx-installer (Ubuntu):
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
Sergio (sergio-otero) wrote :

In my original bug, the system stopped responding.

I've dome some more tests in 10.04 Lucid and know i can change to another user, but it goes to a black screen always when trying to go back to the original user.

I've done some research and i've found that this is different Lucid bug that has 2 reports and also workarounds, working for me:

https://bugs.launchpad.net/ubuntu/lucid/+source/xorg-server/+bug/546578
https://bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/555870

So, i close the original bug

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers