Xorg crashed with SIGSEGV in atiddxDisplayScreenEnableDisplays()

Bug #469462 reported by schmittche05 on 2009-11-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Medium
Unassigned

Bug Description

it crashed when i opened empathy

ProblemType: Crash
Architecture: amd64
Date: Sun Nov 1 21:15:55 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/Xorg
MachineType: Hewlett-Packard Compaq 615
NonfreeKernelModules: wl fglrx
Package: xserver-xorg-core 2:1.6.4-2ubuntu4 [modified: usr/lib/xorg/modules/extensions/libdri.so usr/lib/xorg/modules/extensions/libglx.so]
ProcCmdLine: root=UUID=f6b40208-6000-46bb-a941-d2113e1fe7cd ro quiet splash
ProcCmdline: /usr/bin/X :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-SnjNJZ/database -nolisten tcp vt7
ProcEnviron:
 LANG=de_DE.UTF-8
 PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SegvAnalysis:
 Segfault happened at: 0x7f4108020e5a <atiddxDisplayScreenEnableDisplays+506>: movswl 0x24(%rax),%r14d
 PC (0x7f4108020e5a) ok
 source "0x24(%rax)" (0x00000024) not located in a known VMA region (needed readable region)!
 destination "%r14d" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: xorg-server
StacktraceTop:
 atiddxDisplayScreenEnableDisplays ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: Xorg crashed with SIGSEGV in atiddxDisplayScreenEnableDisplays()
Uname: Linux 2.6.31-14-generic x86_64
UserGroups:

dmi.bios.date: 08/03/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68GVV Ver. F.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 308C
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 27.07
dmi.chassis.asset.tag: CNU9376V0B
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68GVVVer.F.06:bd08/03/2009:svnHewlett-Packard:pnCompaq615:pvrF.06:rvnHewlett-Packard:rn308C:rvrKBCVersion27.07:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: Compaq 615
dmi.product.version: F.06
dmi.sys.vendor: Hewlett-Packard
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-14-generic

schmittche05 (schmittche05) wrote :

StacktraceTop:atiddxDisplayScreenEnableDisplays ()
SwitchToConnectedDisplay ()
atiddxBlockHandler ()
miSpriteBlockHandler (i=0, blockData=0x0,
AnimCurScreenBlockHandler (

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Bryce Harrington (bryce) on 2009-11-06
tags: added: crash
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-11-21
affects: xorg-server (Ubuntu) → fglrx-installer (Ubuntu)
Timo Aaltonen (tjaalton) on 2009-12-14
visibility: private → public
Bryce Harrington (bryce) on 2010-02-26
tags: added: karmic
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi schmittche05,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 469462

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 469462 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/469462

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.