fglrx causes kernel panic on karmic final amd64

Bug #464525 reported by Benjamin Humphrey on 2009-10-30
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by mclaud2000
Declined for Lucid by Bryce Harrington

Bug Description

When installing the fglrx driver from either Hardware Drivers, or through Synaptic, then running aticonfig --initial to configure the Xorg.conf file, upon reboot, the computer will hang and kernel panic just after loading GRUB.

I'm running Karmic FINAL release, with the .31 linux kernel.

Can anyone confirm what version of Catalyst are currently in the Ubuntu repos? Is it actually Catalyst 9.10, or an earlier version? Because I know versions earlier than 9.10 don't support the linux kernel above .30

As a side note, running "sudo dpkg-reconfigure -phigh xserver-xorg" doesn't do anything, either in recovery mode console or in a terminal. I had to manually re-write my Xorg.conf in recovery terminal to use the radeon driver to boot again.

ProblemType: Bug
Architecture: amd64
Date: Fri Oct 30 23:05:57 2009
DistroRelease: Ubuntu 9.10
MachineType: TOSHIBA Satellite A200
Package: xorg-driver-fglrx (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=884c9e30-3565-455f-bc58-c935a6984621 ro quiet splash
ProcEnviron:
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: fglrx-installer
Uname: Linux 2.6.31-14-generic x86_64
dmi.bios.date: 03/11/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 2.10
dmi.board.name: SANTA ROSA CRB
dmi.board.vendor: Intel Corporation
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr2.10:bd03/11/2008:svnTOSHIBA:pnSatelliteA200:pvrPSAF6A-06S01N:rvnIntelCorporation:rnSANTAROSACRB:rvrNotApplicable:cvnNoEnclosure:ct1:cvrN/A:
dmi.product.name: Satellite A200
dmi.product.version: PSAF6A-06S01N
dmi.sys.vendor: TOSHIBA
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-14-generic

Benjamin Humphrey (humphreybc) wrote :
Benjamin Humphrey (humphreybc) wrote :

Sorry if this is a duplicate, I did look at the other ones but many didn't supply much information, were regarding earlier versions of Karmic (not the final release), were regarding DKMS compiling (which seemed to work in my case), or were marked as "Fix Released" - which this obviously has not been fixed.

Benjamin Humphrey (humphreybc) wrote :

Still happens with the .run file downloaded from ATI AMD themselves. This is useless. Can we get a fix or some information on this please?!?

Peter Cordes (peter-cordes) wrote :
Download full text (3.3 KiB)

fglrx on AMD64 Karmic works (partly) for me, with a 4670 desktop card. I don't see any kernel crashes or boot problems. OTOH, I boot up in text mode with no splash-screen crap of any kind, so when I run startx, it's from VGA text mode, and the video card wasn't in any other mode from POST until then. (text grub, and no splash boot for the kernel either. console-setup or something loads a new VGA font, but that's all.) So perhaps the crashes you're seeing are because the card is in a different state from mine when the module loads?

 Wait, you said it hangs right after _loading_ grub? Before it boots the Linux kernel? So you can't interrupt GRUB's auto-boot timeout and get to its command prompt? That sucks! And maybe I should open a new bug. Ubuntu maintainers, please advise.

The reason I say only partially working for me is that there seems to be an ABI problem with 64bit opengl.

$ glxgears
Error: couldn't get an RGB, Double-buffered visual
$ ~/bin32/glxgears -printfps
43610 frames in 5.0 seconds = 8721.957 FPS
44711 frames in 5.0 seconds = 8942.127 FPS

$ fglrxinfo -v

Visual ID: 23 depth=24 class=TrueColor
    bufferSize=4096 level=0 renderType=ci doubleBuffer=0 stereo=1257495371
    rgba: redSize=107937997 greenSize=0 blueSize=1257495371 alphaSize=0
    auxBuffers=0 depthSize=107937997 stencilSize=0
    accum: redSize=1257495371 greenSize=0 blueSize=107937997 alphaSize=0
    multiSample=0 multiSampleBuffers=0
    Opaque.
Visual ID: 24 depth=24 class=TrueColor
    bufferSize=4096 level=0 renderType=ci doubleBuffer=0 stereo=1257495371
    rgba: redSize=107937997 greenSize=0 blueSize=1257495371 alphaSize=0
    auxBuffers=0 depthSize=107937997 stencilSize=0
    accum: redSize=1257495371 greenSize=0 blueSize=107937997 alphaSize=0
    multiSample=0 multiSampleBuffers=0
    Opaque.
...

every visual has the same garbage numbers. So probably in 64 bit mode, the OpenGL library is looking at the wrong block of memory when looking for the supported visuals from the server, so nothing works. 32bit games work fine, with no performance problems or anything (e.g. I played a bit of nexuiz, and that uses lots of recent OpenGL features.) Linux Descent3 also runs fine. (runs quite well on a c2d + 4670, actually :)

  Xv works, for amd64 and i386 binaries. I haven't noticed any problems on my desktop, running fluxbox, gnome-terminal and firefox, and sometimes other GUI stuff.

 Any 64bit binary that wants to use OpenGL gets the same error about not being able to find a visual. Even glxinfo (unlike fglrxinfo) bails after that:
$ glxinfo -v
name of display: :0.0
Error: couldn't find RGB GLX visual or fbconfig

 same situation with fglrx from Karmic
ii fglrx-kernel-source 2:8.660-0ubuntu4 Kernel module source for the ATI graphics accelerators
or ATI Catalyst 9.10 (8.661)

 I'm running Ubuntu's 2.6.31-14.48-generic kernel.

my xorg.conf was generated from empty by aticonfig, and has nothing special. I moved aside my old one that's been growing cruft for years... (but worked with Jaunty & Catalyst 9.8).

 I've googled, but I haven't seen anyone say anything about the problem I'm seeing (everything works except 64bit ...

Read more...

Benjamin Humphrey (humphreybc) wrote :

No, not after grub, it hangs between usplash and xsplash - ie, when X is tried to start. And it's not just a hang where one can Ctrl+Alt+F2 into a virtual terminal, it's actually a kernel panic. And I tried installing through Synaptic, Hardware Drivers, and the .run file from ATI AMD themselves, all produce the same problem.

Peter Cordes (peter-cordes) wrote :

> it hangs between usplash and xsplash

ok, that makes sense, that would prob. be where the kernel module loads, or at least first gets used.

Can you try uninstalling or disabling usplash? Since that's the most relevant difference I can think of between my system and a stock Karmic one.

Peter Cordes (peter-cordes) wrote :

I noticed I also had i915 in my /etc/modules, so that was getting drm loaded before fglrx pulls it in, another difference from stock karmic.

 My 4670 is in the PCI-e x16 slot, disabling the onboard g965, so the i915 module doesn't find anything to talk to. (lspci shows the only VGA device is the ATI).

Adam (adam-k-92) wrote :

Hi I'm also getting a kernel panic. I'm using a Toshiba A300 laptop with an ATI Mobility Radeon HD 3650, using 64 bit karmic final release. I did a fresh install, ran apt-get update and upgrade, activated the hardware driver. Now I can't remember if I ran aticonfig --intitial then rebooted or forgot and ran it in the recovery console. Also the Xorg log appears to be completely empty.

If there's anything I can do to assist in this please let me know though 'm a linux noob and don't know much, I'm still willing to learn

Benjamin Humphrey (humphreybc) wrote :

Hi Adam, thanks for adding your comment. Could you run lspci in a terminal and copy the output to a .txt file, then attach it to this bug? This will help the developers by giving them some detail of your hardware. Cheers.

Adam (adam-k-92) wrote :

Hi, not sure if I was meant to but I ran the lspci after running apt-get purge xorg-driver-fglrx and clearing out the xorg.conf files and rebooting into ubuntu.

Tiago Sousa (tiagoboldt) wrote :

Can anything else be done to help solving this bug? I'm habing the same problem here (same laptop as Adam)

bitstorm (adelbene) wrote :

I'm having the same kernel panic problem with my brand new desktop. I'm using ATI Radeon HD 3200 controller integrated on motherboard (Gigabyte model GA-MA78GM-S2HP ). I've tried also to use a ATI discrete graphic card (Radeon 4350) but the result is the same.

If there's anything I can do please let me know.

Andrea.

Peter Cordes (peter-cordes) wrote :

 Turns out ATI's installer builds broken .deb packages for --buildpkg Ubuntu/karmic, and only works if you use --install

 I wasn't seeing kernel panics, but I don't use compiz, so I still think this could be the same bug as I commented on earlier, and eventually reported here:
http://ati.cchtml.com/show_bug.cgi?id=1695

 Note that ati...run --install will just drop files into the filesystem, and ignores the package manager.
So you'll have /usr/lib/FGL.renamed.libGL.so.1.2 kicking around, for example. When they fix this, and you go back to the *.deb packages, you'll want to do
locate 'FGL.renamed' | xargs -d'\n' sudo rm -i
or something. And that anything that re-installs any of the fglrx .debs will overwrite the ones from --install. The only good reason to use --install instead of building .deb packages is that the .deb packages are broken on AMD64 right now!

 I now have fully working 2d and 3d (for i386 and amd64) with fglrx catalyst 9.11, on my Radeon HD4670.

Peter Cordes (peter-cordes) wrote :

oh, and lspci has no interaction with any other installed packages. It's a very simple program that queries the hardware on the PCI bus in the standard way. (actually, it asks the kernel, instead of talking to the HW directly, which is why you can run it as non-root.) All PCI devices can tell you their name and number without having to know how to talk to them specially. So don't worry about what you did before running lspci, it doesn't matter.

@Peter Cordes: I disagree with your assessment. I believe the kernel-panic is specific to systems with switchable graphics. Your problem is more generic and affects a completely different part of the driver. I'd recommend opening a separate bug for this 64-bit packaging problem.

Peter Cordes (peter-cordes) wrote :

Ah, switchable graphics. I didn't read other people's report in enough detail to pick up on that, sorry.

Peter Cordes (peter-cordes) wrote :

reported as bug 486486. Thanks again, Felix.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
raduv (raduv) wrote :

So, any updates on this one? I have the same problem ...

I've got a fully updated 64-bit Karmic on a Toshiba Satellite A300-1ID, and I'm still seeing a kernel panic at bootup when attempting to use the fglrx driver.
The proprietary driver used to work on Jaunty 64-bit.
I'd rather use the free driver, but it lacks proper power management, raising the laptop's average temperature from 38ºC to 50ºC and cutting on the battery time.

Barton Chittenden (bartonski) wrote :

Just wanted to add that I'm encountering kernel panic at bootup under Karmic 32-bit on a Toshiba Satellite A300-S6916. This started when I installed the ATI/AMD proprietary FGLRX graphics driver. Output from lspci attached.

Benjamin Humphrey (humphreybc) wrote :

Not that I'm interested in ever using the proprietary drivers again, especially since Lucid will support 3D on my chipset with the radeon driver by default - but, just out of curiosity, when the hell is this going to be fixed?

It's not a good look if fglrx causes a kernel panic right through the alpha/beta/RC AND final releases of Karmic.. and it's not like it's a small niggly bug either.

Adam (adam-k-92) wrote :

Yep I'm the same as Ben. I'm running lucid and 3D is running just great with the open source drivers =D

Tiago Sousa (tiagoboldt) wrote :

Hi,
I've solved this by doing:
sudo aticonfig --initial
sudo aticonfig --acpi-services=off
More details here http://bit.ly/71cJMn

raduv (raduv) wrote :

@Tiago: your fix doesn't work for me, but thanks anyway ... I have an ati mobility radeon hd3650 video card

This is becoming really annoying ... does anyone know when we'll going to have some proper ati drivers to work on 9.10 ?

Tiago Sousa (tiagoboldt) wrote :

@raduv
I've got that same card, and more people with it are claiming success doing as I've described.. I've detailed it here http://tiagoboldt.net/blog/install-fglrx-in-karmic/
Are you sure you've removed all previous configurations?

raduv (raduv) wrote :

@Tiago: Sorry, totally my fault ... I got it working ... I have 2 graphics cards on my laptop and I had to force the dedicated one from the bios. Your fixed worked, yaaay!! Thanks!

Bryce Harrington (bryce) on 2010-02-26
tags: added: karmic
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Benjamin,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 464525

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 464525 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/464525

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.