xrandr reports incorrect maximum screen size

Bug #449867 reported by mback on 2009-10-12
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: x11-xserver-utils

$ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10
$ apt-cache policy x11-xserver-utils
x11-xserver-utils:
  Installed: 7.4+2ubuntu3
  Candidate: 7.4+2ubuntu3
  Version table:
 *** 7.4+2ubuntu3 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

My expectation is that xrandr will recognize the correct maximum 3200x1200 size on my Thinkpad T400 laptop and will allow me to set the size to 3200x1200. My maximum screen resolution is 3200x1200, and I used this resolution on a dual external monitor setup when docked. I use xrandr to set up my screen resolution when docked with the following script that, until this morning, has worked just fine:

#! /bin/sh
xrandr --output LCD --off && \
xrandr --fb 3200x1200 \
       --output DFP1 --auto \
       --output CRT1 --auto --right-of DFP1

Within the past three days of updates to karmic (somewhere between 10/9/9 and 10/12/9), the script above stopped working, and the root cause of this is that the maximum screen resolution as seen by xrandr is only 2048x2048 instead of the required 3200x1200. The following is what xrandr returns when I attempt to set this size:

$ xrandr --fb 3200x1200
xrandr: screen cannot be larger than 2048x2048 (desired size 3200x1200)

ProblemType: Bug
Architecture: amd64
Date: Mon Oct 12 13:48:07 2009
DistroRelease: Ubuntu 9.10
MachineType: LENOVO 2767A15
NonfreeKernelModules: fglrx
Package: x11-xserver-utils 7.4+2ubuntu3
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=0db23939-f761-46f2-9285-220fb8cc6b9e ro acpi_osi="Linux" quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.44-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0-1ubuntu2
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu3
SourcePackage: x11-xserver-utils
Uname: Linux 2.6.31-13-generic x86_64
dmi.bios.date: 01/09/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7UET56WW (2.02 )
dmi.board.name: 2767A15
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7UET56WW(2.02):bd01/09/2009:svnLENOVO:pn2767A15:pvrThinkPadT400:rvnLENOVO:rn2767A15:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2767A15
dmi.product.version: ThinkPad T400
dmi.sys.vendor: LENOVO
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-13-generic

mback (mback) wrote :
Bryce Harrington (bryce) on 2009-10-13
Changed in x11-xserver-utils (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-11-03
affects: x11-xserver-utils (Ubuntu) → fglrx-installer (Ubuntu)
mback (mback) wrote :

After a couple of days updating Karmic, this bug "went away." I have no idea if it is an intermittent thing, or if someone just caught it & fixed it, or if rebooting solved the issue.

Bryce Harrington (bryce) on 2010-02-26
tags: added: karmic
Stephen Sandlin (sandlst) wrote :

This appears to happen in Lucid as of 4/21/2010. Only by changing the maximum screen size via Virtualsize in xorg.conf can Xrandr appropriately setup multiple screens.

Felix Kuehling (felix-kuehling) wrote :

@mback: Your xorg.conf specifies the virtual size as 2048x2048. If you set it to 3200x1200, it should work fine.

I guess this bug can be closed as Invalid.

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi mback,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 449867

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 449867 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/449867

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers