Ubuntu

[FGLRX] kernel drivers kills USB subsystem

Reported by Marek Mirczynski on 2006-04-25
20
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
High
Unassigned
xorg (Ubuntu)
Medium
Unassigned

Bug Description

I'm working on Toshiba Satellite L20-183 laptop with Ati Xpress 200M. I'm also using logitech optical wired mouse. I've installed Ubuntu. And everything was ok. Then I've installed fglrx drivers in that way:
sudo apt-get install xorg-driver-fglrx fglrx-control
and just changed vesa to fglrx
After that i have big problem with my mouse. After login to ubuntu its working fine, but after some time mouse died. But not only mouse. I think that all usb is dead. Also I can't switch between terminals by pressing [alt]+[ctrl]+[Fx]. I can't restart x server ([ctrl]+[alt]+[<-]) and i cant turn my computer off normally. I must turn the power off. I can use my touchpad to move cursor.
I was trying to unplug it and plug it again. Nothing happened.
I wad trying other mouse. The same effect.
Whats more this problem was when I was using 5.10 and other released of 6.06 and when i was using other methods of installing fglrx.
I hope that you will look at this problem because it last at least for month and I can't use my ubuntu :(

Changed in xorg:
status: Unconfirmed → Rejected

I am having this exact issue, I am using a Toshiba L25-S1193 laptop with a Radeon mobility x200m. It seems using the fglrx drivers that the USB is doomed, sometimes it will take 5 minutes and then stop, sometimes it will go for hours. When this happens all devices attached to the USB bus seem to dissapear.

here is output from lspci:
0000:00:00.0 Host bridge: ATI Technologies Inc: Unknown device 5a31 (rev 01)
0000:00:01.0 PCI bridge: ATI Technologies Inc: Unknown device 5a3f
0000:00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
0000:00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
0000:00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
0000:00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
0000:00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller ATI
0000:00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
0000:00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
0000:00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
0000:00:14.6 Modem: ATI Technologies Inc ATI SB400 - AC'97 Modem Controller (rev 02)
0000:01:05.0 VGA compatible controller: ATI Technologies Inc: Unknown device 5a62
0000:09:01.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
0000:09:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:09:04.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001a (rev 01)

It seems that ATI is responsible for both graphics and USB on this board. If there is any other output or logs I could post to help troubleshoot or shed light on this problem please reply.

Radoslaw Kolodziej (veareal) wrote :

I have the same issue on Toshiba Satellite L20-182 (basically, it's the same as L20-183, it just has got less RAM and smaller HDD, AFAIK). I can't shutdown my laptop normally, lsusb doesn't work, re-pluging the mouse (Logitech BT 58 OEM optical mouse) doesn't help (the computer doesn't even provide power for the mouse, it's red light is off), my pendrive doesn't work either.
However, graphics acceleration seem to work flawlessly.

I've also filed this bug at the ati developer's site:
http://ati.cchtml.com/show_bug.cgi?id=420

Changed in linux-restricted-modules-2.6.15:
status: Unconfirmed → Confirmed
David Rando (david-rando) wrote :

Same problem here, confirmed and replicated. Using fglrx from ubuntu restricted modules (and using 8.24 from ati binary), usb mouse randomnly freezes (synaptic keeps working) on Fujitsu Amilo L1310G (ati x200 mobile).

If i use normal ati no problem.

I had sometimes problem with the ethernet connection too, that freezes, but not so frequently than the mouse, that is horrible and very frustrating. Only rebooting make it work again.

Everything is up to date, using latest 2.6.15-23

Ala (ala-luszczak) wrote :

Same problem at ASUS A6R-B002.
I have problems with shutdown (but not always). USB works good for about 20 min and after that - stops responding. Reboot is needed. That's very frustrating.

David Rando (david-rando) wrote :

Just to correct my original message. I'm using 2.6.15-25, everything is updated on my ubuntu 6.06. Tried with propietary and original.

Just noticed it makes my wlan connection to freeze too. So actually i lose usb connection, ethernet and wlan (not tested anything else).

thanks god it's confirmed, and has high importance :-D

Ala (ala-luszczak) wrote :

I have noticed that if I use older kernel (2.6.12-10) then this problem doesn't occure. No mouse, usb or shutdown problems. When I switch to 2.6.15-25 - mouse dies. Everything is updated.

It still seems to happen with the new 8.26.18 drivers, although not as often. This is on a fresh install of dapper beta prior to updating anything other than the kernel (2.6.15-25-686). I mistakenly listed the cchtml page above as an "official" ati support channel, it is not. I have however went ahead and started a trouble ticket at the ATI customer service site, and the customer service reps have forwarded this issue to the linux driver team, along with the links to both bugzillas, so hopefully they are well aware of the issue.

In the meantime, I'll try downgrading the kernel if it continues or appears to happen more frequently after updating. Thanks for the tip, Ala!

David Rando (david-rando) wrote :

Can you post the link to the ticket? We can go there, confirm, comment or whatever we can do to give more importance to this issue.

Ticket #737-1055182 (Fglrx kills the USB subsystem.)
Is the ticket number and
http://support.ati.com/ics/support/default.asp?deptID=894&ticketID=1055182
is the direct link from ATI's email. You'll need an ATI customer care id/pass to login and I'm not sure if the tickets are public, but the above number is what they sent.

David Rando (david-rando) wrote :

Confirmed that hangs my ethernet card (broadcom 4401) and my wifi card (atheros 5005), and can be anytime, before or after disabling the usb ports. Did someome tried with a custom made kernel? 2.6.16? tried with Edgy?

David Rando (david-rando) wrote :

Another thing for the devs? (maybe they know it actually).

It's just the DRI. Just it. If I run the driver with option "nodri" "yes", the driver works (i see the difference in the gdm login fonts), don't have 3d acceleration, but the driver doesn't freeze the system, neither kill usb or network cards.

David Rando (david-rando) wrote :

Just installed latest 8.27 released yesterday. 3D going better, but still freezing the usb ports.

David Rando (david-rando) wrote :

Looking for solutions for this painful problem (is anyone still alive about this?? ;-) )

Looks like everybody with ATI chipset on the laptop have it. For example: http://www.marcussmit.nl/linux-on-laptops/asus_a6r_fc5.html

This guy runs an Asus laptop using Fedora 5 and 2.6.16 kernel

It lost the usb ports aftera short time.

I'm still trying to get anyone from the logs or whatever wtih no luck, still no clues on this?

Marek Mirczynski (corn) wrote :

Im stil waiting for the solution. I hope ati will open drivers like intel did.

I'm beginning to suspect this is something to do with Debian based distros, as I switched to Slackware-current and am currently running 2.6.16.10 with the proprietary drivers and am not having this issue at all now. Perhaps my modules list is missing something that was causing the lockup, or there was something added in whatever versions of libraries the stuff got compiled against that's causing it in Ubunutu/Mepis. This has worked with the latest three sets of drivers from ATI, with only one lockup total in the last month that I suspect had to do with something I was doing in wine and opengl.

I hope that doesn't muddy the waters too much. If you have any questions about my current setup please let me know and I'll provide as much information as I can to help pinpoint the difference.

David Rando (david-rando) wrote :

Here i've found another link with exactly the SAME problems: http://www.linux-on-laptops.com/forum/showthread.php?t=295

Looks like it's the IO-APIC option in the kernel that causes our problems in our laptops. Since we don't have anything in the logs it's hard to find you know.

Going to try with nolapic option in the kernel boot to see.

David Rando (david-rando) wrote :

All right, that was it. For my case, the problem was the APIC on the kernel on my laptop. If I boot with "noapic" added to the kernel boot line, i can use fglrx with DRI acceleration and no usb freezing. I'm running it since i posted the comment and working great.

buster (gregb420) wrote :

@Eversmann

Hey that worked. fglrx works great with no lockups BUT now i cant get my network to work. Card is recognized (eth0) but dhcp fails to grab an ip. Tried static but that didnt work either. Tried restarting network. Nothing. Any thoughts??

Toshiba Satellite
ATI x200

buster (gregb420) wrote :

nevermind. next time i read attached link. needed "irqpoll" also

Lorenzo F. (saltatempo) wrote :

I think this is the same problem I report on my PC. Sorry I may be wrong, but this is my first bug report so be patient :)

It isn't a laptop, but on my desktop pc. I think FGLRX has been automatically installed during the upgrade, cause now 3d acceleration is working fine.
I'm attaching my lspci.

What happens is that USB (mouse, pen drive, external HD) is not working at all if I boot with the kernel 2.6.17-10-386.
With the kernel 2.6.15-27-386 USB works properly only if there isn't any USB device plugged during the boot.
With the kernel 2.6.15-23-386 everything seems to work fine.

This problem of course critically compromises the usability of the whole system cause I cannot operate with the mouse so it's quite hard to do.

If there is something I can do in order to report more effectively this bug, please just tell me.

shibby (valleaum) wrote :

i have a toshiba laptop with a X200 and i have got the same problem, my usb work for 20 minutes and stop...

Pi4uks (theme-one) wrote :

Xm, i have this problem with my laptop Fujitsu Siemens Amilo L1310G with ATI Radeon x200 video card...

I'm not a PRO in linux, i just learn it... and i install Kubuntu 7.2 linux. My USB porst stops workin and CPU FUN dont working...

i edited /boot/grub/menu.lst:

kernel.... quiet splash
>
kernel.... quiet splash noapic

but my USB stops after some period anyway.. :(

Can someone help me?

And i cant turn my Atheros Wireless AR5005G Radio Len On... cant find any wireless network :( Computer found the card, but it just dont work and button on my laptop dont turn radio led on :(

Can someone help me? Please....

Here is something about this bug:
http://ubuntuforums.org/showthread.php?t=189572&page=2
(#14 is probably most important)

For those, who use Dapper -> change 'fglrx' to 'ati' driver
For those, who use Edgy -> change 'ati' to 'fglrx' driver

Both worked for me on Asus a6r. This is VERY strange.

Pi4uks -> I found nothing about version 7.2. Just try changing your video driver.
This problem has probably nothing in common with your wifi led. Even if led is off, it don't mean that your wifi doesn't work. Type your card name in google and you will find solution for wifi.

Timo Aaltonen (tjaalton) wrote :

Seems like there has been no update to this bug in a while. Closing it because of that, but if you can reproduce it with 8.04 or the development version (Intrepid Ibex), feel free to reopen.

Changed in linux-restricted-modules-2.6.15:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments