New GDM doesn't play well with ati fglrx

Bug #403175 reported by Dave Morley on 2009-07-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gdm

Installing from 20090722.1 alternate cd while the radeon driver is in play gdm displays correctly.

However if you use jockey and install the fglrx drivers for your ati card the new gdm screen turn grey on reboot and you can't access the console using ctrl-alt-Fx either.

This is almost a hard freeze in that nothing you do has any effect on the machine apart from a hard reset or a power off.

Sebastien Bacher (seb128) wrote :

the bug is rather an xorg one than a gdm, gdm only use xorg to display the screen, also don't abuse the title to specify the version you are using

affects: gdm (Ubuntu) → xorg-server (Ubuntu)
summary: - Karmic: New GDM doesn't play well with ati fglrx
+ New GDM doesn't play well with ati fglrx
Martin Pitt (pitti) wrote :

Sounds like an fglrx bug, but to be sure, can you please boot with "text" in grub (to disable gdm), log into a VT, and do "startx"?

Martin Pitt (pitti) on 2009-07-22
affects: xorg-server (Ubuntu) → fglrx-installer (Ubuntu)
Dave Morley (davmor2) wrote :

I followed martin's instructions and it isn't specific to gdm. The minute I hit startx the system gains a grey screen and nothing. This included the inability to get back to the terminal.

I'm getting the same deal (again as soon as x starts) on my dell studio, can't remember exact model (current release I think, bought 4 months ago) being full lockup with odd glitches on screen. I'll peruse the logs tomorrow after work.

Bryce Harrington (bryce) wrote :

There isn't enough information to troubleshoot this as an X bug. Please see http://wiki.ubuntu.com/X/ for guidance on how to report bugs about X.org. You might also wish to include a screenshot or photo to demonstrate the problem, as "doesn't play well" is not very descriptive.

Changed in fglrx-installer (Ubuntu):
status: New → Invalid
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers