Delay at maximizing/restoring a window

Bug #381003 reported by Roman Leuprecht on 2009-05-27
68
This bug affects 14 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Jeff Campbell

Bug Description

I use Ubuntu 9.04 on a new ThinkPad T500 with an ATI Mobility Radeon 3650.
Everytimes i activate Desktop effects with Compiz or the Metacity Compositing Effects, minimized Windows got a delay of 1-2 seconds after the click to restoreuntil they get maximized/restored. Without compositing in Metacity all things run great, the restoring runs very well. Another Detail: Everytime i restore a Window , the CPU-Usage shoots up to 50%, after the effect it is normal again.

Pascal Reiß (ronfle) wrote :

I can confirm this bug. I'm using a ATI Mobility Radeon HD 3430 with a 64bit Jaunty, dual core. I had installed the fglrx driver via jockey, now I'm using ATI Catalyst 9.5 - both had the same problem:

Activating compiz or compositing in metacity causes a delay between half a second and two seconds to maximize or restore a window. It does not depend on what application the window belongs to (gnome-terminal, nautilus, OOo, firefox - all the same). The maximize button looks pushed down but nothing happens - then, after a while, the window is suddenly maximized.

I can also confirm that the CPU usage of one core rises up to 50%.

If you need some logs, let me know, I will post them!

sKwa (setarckos) wrote :

I have the same problem - delay for 2+ seconds at maximizing/restoring a window when compiz is enabled (video card - Radeon HD 3850 and OS - Jaunty x86_64). I tried different drivers: from repositories, 9.5 and 9.6 - all of them the same problem. Probably this is a problem with the cards of ATI Radeon HD 3xxx series. In previous versions of Ubuntu (Hardy) this problem has not been ( I suppose that this is because in Jaunty new version of X Window server: 7.4 in Jaunty against 7.3 in Hardy).
But (fix me) Canonical does not provide support as the driver is proprietary, so (for us) most likely have to wait for a new driver from ATI with the right support this series of this cards or for new open drivers from X.org with 3D support for RV6xx/RV7xx series.
Sorry fo my English :(

sKwa (setarckos) on 2009-07-18
tags: added: ati radeonhd
affects: ubuntu → fglrx-installer (Ubuntu)
Changed in fglrx-installer (Ubuntu):
assignee: nobody → sKwa (setarckos)
sKwa (setarckos) on 2009-07-18
Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Pascal Reiß (ronfle) wrote :

Actually, I was able to "fix" the problem by installing another version of X: I added the ppa
http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu
(the corresponding website is https://launchpad.net/~ubuntu-x-swat/+archive/xserver-no-backfill)
to my repository and installed the provided x-server. Now the problem doesn't happen anymore.

OMG !
It functions !
Thank you very much, i think it should run on all ATI Radeon Mobility Solutions.

sKwa (setarckos) wrote :

Yeap... it's work!!! (for me Radeon HD 3850 & Jaunty x86_64) No garbage!!! X Window a little faster!!!
ronfle - thnx

sKwa (setarckos) on 2009-07-28
Changed in fglrx-installer (Ubuntu):
assignee: sKwa (setarckos) → nobody
Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
Jeff Campbell (jeff-soupbowl) wrote :

I was able to reproduce this bug in 9.10 Alpha-6 (29 Sep 2009)

Viktor Basso (basso) wrote :

I am also able to reproduce this bug in 9.10 Beta with ATI 3650

GrosMario (ttkspam) wrote :

I had the same problem, ATI 3450.
I installed the proposed patch, computer hangs upon reboot. SysReq keys won't work , hard reboot needed. So I logged in in recovery mode and reinstalled xorg without the ppa. Then I switched back to radeon driver and it worked. Wanted to go back to ATI driver (ubuntu version) but X fails to start after reboot...

tx (372046933-qq) wrote :

It seems that if you turned of the PowPlay option in amdcccle delay becomes a little shorter

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers