Compiz memory leak / Xorg memory leak

Bug #372345 reported by EneergE on 2009-05-05
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Low
Unassigned

Bug Description

I have had a system crash/halt due to my Xorg consuming up ALL of my memory. Here's a thread I posted over on the forums: http://ubuntuforums.org/showthread.php?t=1149294

Basically what happens is that whenever I maximize/restore a window, memory in Xorg shoots up 25MB. Regardless of how many times I restore/maximize, it keeps allocating new memory and it never frees it up. Xorg also allocates memory for programs when they open up and never frees that memory when they close. After I re-open that same application, it allocates even more memory. This is repeated each time the application is loaded. Even when opening a Nautilus window, about 4MB is re-allocated every single time. I have to restart the system or X after I have used my system for a day or so.

This seems to also happen when you "shade" a window. Each time new memory is allocated when you "shade" it and it is never freed up.

The problem appears to only occur when compiz/effects are enabled. Unlike a previous reported bug, compiz.real does not seem to be the culprit this time. The Xorg process just continuously allocates memory for no reason. I posted a screenshot over on the forums displaying the issue. It seems to be compiz related since I cannot reproduce the bug when effects are disabled.

Here's a detailed list of my setup:
Jaunty 9.04
Xorg 1.6
Compiz 0.8.2
Emerald 0.7.2
ATI HD 4850 w/ ATI proprietary driver 9.4 - already a host of bugs for this, too

Feel free to tell me what else you need.

~ Evan

Canoblus (noto99) wrote :

I can confirm this bug. The problem emerged since I updated to 9.04. I also have an ATI HD 4850, Compiz enabled. After some hours Xorg uses several GBs of memory. It takes noticably longer compared to 8.04 to maximize/minimize windows (it seems to hang for 2 seconds, then the window appears). Xorg is using almost 100% of one core (I have 4).

Andres Mujica (andres.mujica) wrote :

Confirmed by an user at irc and forum. Waiting for the apport-collect information

affects: ubuntu → xorg (Ubuntu)
Changed in xorg (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Martin Olsson (mnemo) on 2009-05-06
affects: xorg (Ubuntu) → fglrx-installer (Ubuntu)

Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: fglrx
Package: fglrx-installer
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersion: Linux version 2.6.28-11-generic (buildd@crested) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009
Uname: Linux 2.6.28-11-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin mythtv plugdev video

Canoblus (noto99) wrote :
Canoblus (noto99) wrote :
Canoblus (noto99) wrote :
Canoblus (noto99) wrote :
Canoblus (noto99) wrote :
Canoblus (noto99) wrote :
Canoblus (noto99) wrote :
EneergE (eneerge) wrote :
QIII (qiii) wrote :

If anyone is still interested.

I was going to C&P the link, but didn't get the C part, apparently.

www.x.org's bug site directed me to bugzilla.

Apparently this is a regression from an earlier version of Xorg.

The bug was reopened very recently with

Priority: High
Severity: Major

It's not Jaunty or Compiz related. It's a bug in the latest Xorg.

Bryce Harrington (bryce) wrote :

I've posted a new version of the -fglrx driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get fglrx 8.620 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in fglrx-installer (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Adam B. (adamrb) wrote :

I have the same setup as the original poster, with the same bug. Xorg would eventually consume about 2GB of RAM.

After 15 hours of uptime, Xorg seems to be behaving much better with the packages from that repository. I'll continue to use it for a few days to see if it jumps back up.

Adam B. (adamrb) wrote :

After 2 days of uptime, my xorg memory usage is only 300MB. Typically, it would be about 1GB by now, so it would appear the bug has been fixed.

Bryce Harrington (bryce) wrote :

Thanks for letting us know the issue is resolved.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Fix Released
jcat (jcat) wrote :

Hi,

I'm experiencing this exact same issue with Jaunty, but using the Intel driver.
I have to restart X twice a day at work! :)

Can we get a similar fix for Intel users?

Cheers,
jcat

Hi. I would like to confirm this bug. Just installed package from xorg-edgers PPA. Testing

Bryce, i've just got back to this bug https://bugs.launchpad.net/bugs/351186 what was fixed with https://edge.launchpad.net/~ubuntu-x-swat/+archive/xserver-no-backfill. Could you please provide the work around ?

Installed latest fglrx from ati.com like described here http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide#Installing_the_drivers_manually and no memory leak problem anymore

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers