fglrx crashes x.org at startup

Bug #367222 reported by Pite(R) on 2009-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Hi.
After installing fglrx 8.593 from AMD download page or 8.600 from repositories and rebooting drivers crash x.org server. System is unable to run, until I remove fglrx by the recovery mode. I tried few times to launch system with no success, but one time it didn't crashed at all and I could save crash logs, which are attached. What's the problem?
Graphic card: Radeon X1950 RV570; system: Ubuntu 9.04; Linux kernel: 2.6.28-11-generic.

[lspci]
tmp/failsafeX-backup-090425150856.aII/

[lspci]
tmp/failsafeX-backup-090425150856.aII/

[lspci]
tmp/failsafeX-backup-090425150856.aII/

[lspci]
tmp/failsafeX-backup-090425150856.aII/

[lspci]
tmp/failsafeX-backup-090425150856.aII/

Pite(R) (pieter-pippin) wrote :
Bryce Harrington (bryce) on 2009-04-28
description: updated
Bryce Harrington (bryce) on 2009-05-01
tags: added: crash
Bryce Harrington (bryce) on 2009-05-05
description: updated
Bryce Harrington (bryce) on 2009-05-06
description: updated
Bryce Harrington (bryce) on 2009-05-17
description: updated
Bryce Harrington (bryce) on 2009-06-02
description: updated
Bryce Harrington (bryce) wrote :

I've posted a new version of the -fglrx driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get fglrx 8.620 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in fglrx-installer (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Invalid
quequotion (quequotion) wrote :

Did i dupe this bug?

https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/503260

If you need to use the legacy driver (like I do) try changing grub's vga mode to 0xf06 (instructions in my bug report).

By the way, anyone handy with grub have any idea what 0xf06 means? I'm just curious.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers