[HD 3870] Display Preferences causes 100% CPU usage and does not open correctly

Bug #366757 reported by triciens on 2009-04-25
42
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Ubuntu 9.04

1. I activated ATI/AMD proprietary FGLRX graphics driver from within Harware Drivers.
2. I restarted PC.
3. I tried to open Display Preferences
4. CPU usage shoots up to 100% on one of my two cores. Other core % is low. Cores alternate with one always near 100% and the other hardly being used. Display Properties is white with a green/blue streak across it.

My GPU is one ATI Radeon HD3870. Photograph of screen attached.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82X38/X48 Express DRAM Controller [8086:29e0] (rev 01)
     Subsystem: ASUSTeK Computer Inc. Device [1043:8295]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon HD 3870 [1002:9501]
     Subsystem: ASUSTeK Computer Inc. Device [1043:81f8]

triciens (triciens) wrote :
triciens (triciens) on 2009-04-25
description: updated
Martin Olsson (mnemo) wrote :

If you switch to the "Processes" TAB in which specific program does it show 100% CPU?

Also it would be useful if you downloaded debug symbols for the program that hogs CPU and the you attach gdb to it and collect a couple of backtraces continuing the program between each backtrace. That way we can see which functions the program is running while consuming all that CPU.

To get debug symbols you need follow these steps (add the "deb http://ddebs..." lines and do the gpg command and then the sudo apt-get update thing etc):
https://wiki.ubuntu.com/DebuggingProgramCrash

Then, if the CPU is spinning inside the gnome-display-preferences you can use "dpkg -S gnome-display-preferences" command to see what package that file ships with (which in this case in gnome-control-center). And then you do:
sudo apt-get install gnome-control-center-dbgsym

And then you attach gdb using "gdb -p $(pidof gnome-display-preferences)" and you can activate logging in gdb using "set logging file gdb.txt" followed by "set logging file on". Finally you just press CTRL-C to break the program and run "bt full" to collect the stack. Then you run "c" to resume execution of the program, wait like 1 second then you press CTRL-C again and repeat "bt full".

Afterwards, attach the gdb.txt file to this bug report.

---

Also, I recommend reporting this bug to the ATI proprietary driver devs because no one else can fix a bug in that code since it's closed source.

Bryce Harrington (bryce) on 2009-04-28
affects: xorg (Ubuntu) → fglrx-installer (Ubuntu)
Bryce Harrington (bryce) wrote :

Hi craigmforrest,

Thanks for including an image to demonstrate the issue. Could you also please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log or Xorg.0.log.old file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
Changed in fglrx-installer (Ubuntu):
status: New → Incomplete
omnius (omnius06) wrote :

Hi,
i'm having the same problem.
My videocard is an ATI 4850. My Monitor is a Samsung 2243 BW.
When i start display preferences my cpu usage jumps to 100%(xorg). After a while the display properties show up, saying "unknown monitor".
If i look at mail xorg.log during the startup i see a listing of possibly resolutions get repeated over and over(Printing DDC gathered Modelines:)

I have attached xorg.log

Bobnova (pskovinsky) wrote :

ATI 4830 here, on 9.04 amd64.

Before installing the proprietary driver(s) display opens just fine.
After installing them (and rebooting) trying to open it puts the CPU (both cores) to 100% and gives me a ~5fps frame rate, the Display window is narrower then it should be and stays blank indefinitely.
Using System Monitor to close display properties removes the window, but the CPU stays maxed till reboot.

I've tested it on two installs (i killed the first install trying to get a kubuntu desktop), and both do exactly the same thing.

I haven't edited anything related to the display, nor have i changed any options in the display panel before (or, obviously, after) installing the prop. drivers.

Simon Hansen (simonboba) wrote :

Same problem here. Have ATI 4850. 100 % usage on one core, but in the Processes tab, Xorg runs at about 50 %, and nothing else have any notisable CPU usage.

Arutha (devplace) wrote :

Problem has been bugging me since 9.04 (64-bit) beta.
After start of display preferences, one core maxes out, the other runs normally. Display preferences window remains blank. Closing it is possible however (but takes a while), 1 cpu core stays at max. Have to reboot to have a normal situation again.

Hardware: ATI Radeon 4670 HD, using FGLRX proprietary driver.

levicivita (cbontas) wrote :

I have same same exact problem with an ATI 4890 and the proprietary fgrlx driver.

Authentik (newsham) wrote :

I have the exact same problem with ATI HD 4850. I normally don't use linux, and I'm trying out Ubuntu just today... a bit disappointed with the graphics issue. Without the proprietary drivers, everything is too slow (and I can't choose my monitor's native resolution), so really need those drivers to work.

On my AMD x4, I get 1 core at 100%, 1 core about 90%, and the other two cores idle. top shows Xorg at 100%, so I killed Xorg, X restarted, and things were back to normal.

By the way, not sure why this is marked as incomplete and tagged as needing Xorg log. A previous commenter attached Xorg log.

triciens (triciens) wrote :
triciens (triciens) wrote :
triciens (triciens) wrote :
triciens (triciens) wrote :

Xorg is the process which uses 100% CPU.

Bryce Harrington (bryce) on 2009-05-05
Changed in fglrx-installer (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-05-05
description: updated
devtrue (dtrueit) wrote :

I have an ATI Technologies Inc RV630 [Radeon HD 2600XT] and was experiencing the same problem.

I disabled RandR 1.2 and it seems to have fixed, or at least created a workaround, for the issue. Perhaps it will give someone much smarter than I am a chance to actually get to the bottom of the problem.

I added "EnableRandR12=Sfalse" (no quotes) to /etc/ati/amdpcsdb under [AMDPCSROOT/SYSTEM/DDX] and added "Option "EnableRandR12" "false"" (no outer quotes) to the device section of my xorg.conf. I restarted GDM and went to the display manager from the System menu and it opened with no problems. I was then able to setup my dual-head system, which is how I got into this mess in the first place.

Attaching my xorg.conf

Corey Abshire (corey-abshire) wrote :

This seems to be fixed for me using the latest ATI drivers. CPU is not 100% in the gnome display panel and I can resize the desktop and rearrange monitors fine with it. Can anyone else confirm?

Bryce Harrington (bryce) on 2009-06-26
summary: - Display Preferences causes 100% CPU usage and does not open correctly
+ [HD 3870] Display Preferences causes 100% CPU usage and does not open
+ correctly
Bryce Harrington (bryce) wrote :

I've posted a new version of the -fglrx driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get fglrx 8.620 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in fglrx-installer (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Markus Lindenberg (markusl) wrote :

Bryce, i can confirm that the new fglrx version from the xorg-edgers PPA fixes the problem on Jaunty.

(I'm using a RV610 [Radeon HD 2400 XT] on amd64)

Thanks for that!

Also, shouldn't this bug be merged with #348400 ?

Bryce Harrington (bryce) wrote :

Thanks for confirming the issue is no longer occurring.

@triciens, feel free to reopen if you find it is still a problem.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Fix Released
Bryce Harrington (bryce) wrote :

[Actually I should wait until I upload this package to close the bug...]

Changed in fglrx-installer (Ubuntu):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.620-0ubuntu2

---------------
fglrx-installer (2:8.620-0ubuntu2) karmic; urgency=low

  * Issues resolved since 9.4 (No package changes; Mario just beat me to the upload):
    + With desktop effects enabled, transparent desktop no longer causes desktop icons and
      application windows to disappear
    + Video playback no longer exhibits corruption when desktop effects are enabled and
      Composite is not explicitly disabled
    + [Ubuntu 8.10] System now functions properly when starting X on surround view
      systems
    + Resizing DVD playback window on Mplayer no longer causes blank video
    + System instability no longer occurring when switching to full screen DVD playback
      with Totem Player
    + Terminal window no longer displays error message when launching Catalyst Control
      Center in MultiView
    + [Ubuntu 9.04] Xserver now starts properly with ATI Radeon HD 4870 GPU
      configurations
    + [Ubuntu 9.04] When xrandr --prop is evoked, Xserver failure no longer occurs under
      various system configurations
    + The engine clock and memory clock values are now reported properly by ATI CAL
    + Catalyst Control Center, the primary display is now identified when using the
      Identify Displays button
    + Error message no longer occurs while setting the TV geometry
    + Game corruption does not happen in full screen when 2 monitors are connected and
      RandR 1.2 is enabled
    + TV screen corruption is no longer visible while starting the X-server on some ASICs
    + Executing the following command : aticonfig --initial -f does not cause the following
      message "No supported adapters detected" on some display adapters
    + Detecting second display using amdccle "Detect Display" button no longer results in
      error and will require a relaunch to detect both displays properly
      (LP: #348400)
    + Mplayer does not fail to render video when resizing DVD playback window
    + Fixed: Some system may become unresponsive after starting and killing X-server
      (LP: #355821)
    + System no longer fail to respond when executing multiple server
      generations
    + Memory leak on RV630 (LP: #368271)
    + dpms switches off backlight on laptop screen properly (LP: #363059)
    + Display Preferences no longer causes 100% CPU usage and failure (LP: #366757)

 -- Bryce Harrington <email address hidden> Fri, 26 Jun 2009 22:07:19 -0700

Changed in fglrx-installer (Ubuntu):
status: In Progress → Fix Released
Poppafuze (poppafuze) wrote :

This is still happening for amd64 / x86_64, presumably because Jaunty's xorg-driver-fglrx package is still 2:8.600-ubuntu2. Symptom is 100% CPU taken by the X process on one core when launching gnome-display-properties. Also terrible problems with OpenGL screensavers.

I have an HD4850, kernel 2.6.28-15-generic x86_64, X.org 1.6.0 (fglrx, randr extensions loaded) ...basically the current Jaunty with 'proposed' and 'backports' in sources.list.

Is this 2:8.620-0ubuntu2 version going into x86_64?

Thanks!

Poppafuze (poppafuze) wrote :

....Umm, I mean is it going into Jaunty-proposed or Jaunty-backports?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers