Kaffeine player crashes with ATI Catalyst Driver (ati-driver-installer-9-4-x86.x86_64.run)

Bug #366549 reported by toepper on 2009-04-25
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

1) Ubuntu 9.04 - Jaunty Jackalope 64-bit edition
2) kaffeine 0.8.7-1ubuntu5 versatile media player for KDE and ATI Catalyst Driver installer Package (ati-driver-installer-9-4-x86.x86_64.run)
3) kaffeine player should work with Ubuntu visual effects, normal mode and without without crashing Ubuntu
4) After installing the above ATI Driver with the installer provided by ATI the kaffeine player crashes Ubuntu immediatley after running with Ubuntu visual effects running. Without visual effects the kaffeine TV Player presents a bad television picture and crashes Ubuntu after a few seconds. Hardware used: Terratec Cinergy T2 USB DVB-T Receiver.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: fglrx
Package: yelp 2.25.1-0ubuntu5
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.28-11-generic x86_64

toepper (blogconnect) wrote :
description: updated
affects: ubuntu → kaffeine (Ubuntu)
Pyoverdine (pyoverdine) wrote :

Same problem, but with native fglrx (those obtain by proprietary fglrx proposed by Jaunty.
If you want information, tell me.

Floyd42 (axelheider) wrote :

See last comment of Bug #97341 for a solution that worked fine for me:

Kaffeine -> Settings ->xine Engine Parameters -> Video -> driver: change from "auto" to "xshm"

Maybe somebody can provide some technical background infos, why this works and if it is the best driver to use....

Jonathan Thomas (echidnaman) wrote :

Full Ubuntu crashes are most likely Xorg crashes, which are usually driver bugs.

affects: kaffeine (Ubuntu) → fglrx-installer (Ubuntu)
Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
hannuko (hannu-kotipalo) wrote :

Same here. /var/log/messages shows some hint:
messages.0:Aug 25 20:53:35 cave kernel: [81514.750897] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
messages.0:Aug 25 20:53:35 cave kernel: [81514.752284] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
messages.0:Aug 25 20:53:35 cave kernel: [81514.753730] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
messages.0:Aug 25 20:53:35 cave kernel: [81514.755136] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
messages.0:Aug 25 20:53:35 cave kernel: [81514.756544] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
messages.0:Aug 25 20:53:35 cave kernel: [81514.757127] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53

Bryce Harrington (bryce) on 2009-09-04
tags: added: kubuntu
GruntZ (gruntz) wrote :

No crash for me, but it seems to be another effect on my fresh Karmic x64 :
Sometime, whatever I do, mouse cursor freeze (dont move anymore) and I need to return to login screen with keyboard to un-freeze the cursor.

Proprietary ATI drivers for ATI Radeon HD 3200 Graphics (Gyga-Byte GA-MA78GM-S2H)

dmesg output as :
[157194.690816] usb 4-1: USB disconnect, address 14
[157196.221284] usb 4-1: new low speed USB device using ohci_hcd and address 15
[157196.417217] usb 4-1: configuration #1 chosen from 1 choice
[157196.428507] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:12.1/usb4/4-1/4-1:1.0/input/input19
[157196.428589] generic-usb 0003:046D:C50E.0010: input,hidraw2: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:12.1-1/input0
[157349.912202] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
... many, many time repeat the same line
[157360.710852] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[157361.185719] [fglrx:fireglAsyncioIntEnableMsgHandler] *ERROR* IRQMGR returned error 1 when trying to enable interrupt source ff000034

Yuriy Vidineev (adeptg) wrote :

I have the same bug with HD3200 (Asus M3A-H/HDMI)
cat /var/log/messages:
...
Dec 16 17:42:37 user-desktop kernel: [29654.739132] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
Dec 16 17:42:37 user-desktop kernel: [29654.741067] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
Dec 16 17:42:37 user-desktop kernel: [29654.743051] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
...

Murz (murznn) wrote :

Same problem on Karmic AMD64 with ATI Radeon HD4200 (Asustek M4A785T-M motherboard) using KDE:

Jan 3 01:41:49 kit kernel: [24515.707090] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
Jan 3 01:41:49 kit kernel: [24515.708016] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
Jan 3 01:41:49 kit kernel: [24515.708695] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53

On this error the screen is hangs, but after some (1-20) seconds goes back to work normally.

Murz (murznn) wrote :

But I didn't use kaffeine, I use firefox when this issue shows.
GruntZ and adept - you got this bug when using kaffeine or another software? If another, I think, we need to open new bug.

Brian Candler (b-candler) wrote :

I get approximately 35 of these lines logged when switching between screens (e.g. Ctrl-Alt-F9, Ctrl-Alt-F7) on a Dell Zino HD, which has ATI Radeon HD 3200 (Ubuntu Karmic, 64bit; after install I was asked if I wanted to install the proprietary drivers, and I said yes)

...
Jan 3 15:47:07 zino kernel: [26078.316327] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
Jan 3 15:47:07 zino kernel: [26078.319528] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
Jan 3 15:47:07 zino kernel: [26078.321583] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
Jan 3 15:47:07 zino kernel: [26078.323570] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
Jan 3 15:47:07 zino kernel: [26078.325523] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
...

However the machine doesn't crash, so these seem to be benign.

A bit more info:

# lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:01.0 PCI bridge: Dell Device 9602
00:07.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 3)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3200 Graphics
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)

Nicolas1970 (nic1) wrote :

Hello,

Same issue here: "Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53". It was due to RAM failures (frequency too high). When issue was solved, not more such crash. Conclusion: run memtest86+ to be sure it does not come from a RAM issue.

Nicolas

Doug Morse (dm-dougmorse) wrote :
Download full text (7.1 KiB)

Hi,

Me too. Assertion failed in hal_rs780.c error messages in groups of 30-40 messages at a time. Errors seem mostly to occur on waking from sleep/suspend. Far as I can tell, they are benign, but troubling none the less.

Proprietary ATI drivers for ATI Radeon HD 3200 Graphics (HP dv7 nr1451 laptop).

[28570.800080] usb 3-2: reset low speed USB device using ohci_hcd and address 6
[28571.140236] PM: resume devices took 3.090 seconds
[28571.140397] PM: Finishing wakeup.
[28571.140399] Restarting tasks ... done.
[28571.196569] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.198548] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.200537] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.202555] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.204486] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.206473] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.208480] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.210468] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.212484] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.214463] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.215053] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.217042] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.219022] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.221016] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.223022] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.225001] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.225600] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.226319] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.241868] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.243340] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.243734] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.245732] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.247722] Assertion failed in ../../../../../../../../drivers/2d/lnx/fgl/drm/kernel/hal_rs780.c at line: 53
[28571.249708] Assertion failed in ../../../../.....

Read more...

Installing a the driver from 11.04 seems to resolve this for me.

Bryce Harrington (bryce) on 2011-04-28
Changed in fglrx-installer (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers