[R700] fglrx broken in Jaunty with SyncMaster 305T and HD4870x2

Bug #366536 reported by earthforce_1 on 2009-04-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg-driver-fglrx

ubuntu-bug -p xorg
unknown chip id 0x9441, can't guess.

Just upgraded my primary desktop to 64-bit Jaunty, but when I restarted the system was completely unusuable. Had to invoke the rescue kernel and boot into the command line to remove all fglrx packages. The open source drivers are usable with metacity, but I have completely lost compiz and all desktop effects. I am using a Samsung Syncmaster 305t (2560x1600 resolution) with a Sapphire HD4870x2 graphics card on an i7/940.

Worse, when I switched to the open source drivers it initially seemed to have problems recognizing my display and assumed my monitor was a lower resolution 4:3 display, resulting in a fuzzy, stretched desktop. (Didn't seem to detect it properly) Only with a complete purge and reconfigure using information gleaned from others bitten by Jaunty ATI issues allowed the open source driver to properly detect my monitor.

I have attached my (working) open source xorg.conf along with inline dumps the busted ones generated by fglrx if it helps. I realize you don't have much control over closed source drivers, but unfortunately this is the sort of thing that prevents Bug #1 from ever being fixed. Non technical users with ATI cards would be completely hosed by the upgrade and have no idea how to fix it. If you want, I can retry the fglrx drivers when you think a fix is available. I really miss compiz.

* Note *

When the fix becomes available, be sure to check it against VLC, movie player, google earth. and celestia with compiz enabled. These were problematic with 8.10+ compiz, and I had to turn compiz off to use them.

( Broken xorg.conf.fglrx-0)

# xorg.conf.failsafe (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
 Identifier "aticonfig Layout"
 Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Monitor"
 Identifier "aticonfig-Monitor[0]-0"
 Option "VendorName" "ATI Proprietary Driver"
 Option "ModelName" "Generic Autodetecting Monitor"
 Option "DPMS" "true"
EndSection

Section "Device"
 Identifier "Configured Video Device"
 Driver "vesa"
 Option "UseFBDev" "true"
EndSection

Section "Device"
 Identifier "aticonfig-Device[0]-0"
 Driver "fglrx"
 BusID "PCI:4:0:0"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "Configured Video Device"
 Monitor "Configured Monitor"
EndSection

Section "Screen"
 Identifier "aticonfig-Screen[0]-0"
 Device "aticonfig-Device[0]-0"
 Monitor "aticonfig-Monitor[0]-0"
 DefaultDepth 24
 SubSection "Display"
  Viewport 0 0
  Depth 24
 EndSubSection
EndSection

============ Broken xorg.conf.fglrx-1 ==================================
# xorg.conf.failsafe (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
 Identifier "aticonfig Layout"
 Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
 Identifier "aticonfig-Monitor[0]-0"
 Option "VendorName" "ATI Proprietary Driver"
 Option "ModelName" "Generic Autodetecting Monitor"
 Option "DPMS" "true"
EndSection

Section "Device"
 Identifier "aticonfig-Device[0]-0"
 Driver "fglrx"
 BusID "PCI:4:0:0"
EndSection

Section "Screen"
 Identifier "aticonfig-Screen[0]-0"
 Device "aticonfig-Device[0]-0"
 Monitor "aticonfig-Monitor[0]-0"
 DefaultDepth 24
 SubSection "Display"
  Viewport 0 0
  Depth 24
 EndSubSection
EndSection

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
Package: xorg 1:7.4~5ubuntu18
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@crested) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009
SourcePackage: xorg
Uname: Linux 2.6.28-11-generic x86_64
XorgLogOld:

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation X58 I/O Hub to ESI Port [8086:3405] (rev 12)
     Subsystem: ASUSTeK Computer Inc. Device [1043:836b]
04:00.0 VGA compatible controller [0300]: ATI Technologies Inc R700 [Radeon HD 4870 X2] [1002:9441]
     Subsystem: ATI Technologies Inc Device [1002:2542]

earthforce_1 (earthforce1) wrote :
Bryce Harrington (bryce) on 2009-04-28
Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-04-28
description: updated
earthforce_1 (earthforce1) wrote :

I installed your updated drivers from your PPA hoping it might fix my problem from:

> https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates/

Unfortunately, fglrx is still broken and in trying to get back to my old configuration I am unable to reinstall/reconfigure the x server:

Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  fglrx-kernel-source
The following packages will be REMOVED:
  fglrx-kernel-source
0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
1 not fully installed or removed.
Need to get 0B/2320kB of archives.
After this operation, 7328kB disk space will be freed.
(Reading database ... 335322 files and directories currently installed.)

Preparing to replace xserver-xorg-core 2:1.6.0-0ubuntu14 (using .../xserver-xorg-core_2%3a1.6.0-0ubuntu14_amd64.deb) ...

Unpacking replacement xserver-xorg-core ...

dpkg (subprocess): unable to execute old post-removal script: Permission denied

dpkg: warning - old post-removal script returned error exit status 2

dpkg - trying script from the new package instead ...

dpkg: ... it looks like that went OK.

dpkg: error processing /var/cache/apt/archives/xserver-xorg-core_2%3a1.6.0-0ubuntu14_amd64.deb (--unpack):

 unable to install (supposed) new info file `/var/lib/dpkg/tmp.ci/postrm': Is a directory

Processing triggers for man-db ...

Errors were encountered while processing:

 /var/cache/apt/archives/xserver-xorg-core_2%3a1.6.0-0ubuntu14_amd64.deb

What is weird here, is the /var/lib/dpkg/tmp.ci path it complains about doesn't even exist! How do I fix this?

Yfrwlf (yfrwlf) wrote :

Confirmed on my 4850x2 with Syncmaster T260. After installing fglrx from the restricted driver manager, I get the black screen of death and my computer is unusable until I remove the driver.

earthforce_1 (earthforce1) wrote :

Tried again with the newly released 9.5 catalyst drivers. ->Still utterly broken and unusable. <-

At least I could boot into the rescue system and un-install ok. But if you noticed the new 9.5 catalyst drivers on the ATI site and hoped it would fix this but, your hopes are dashed - I have a near useless $500 GPU.

earthforce_1 (earthforce1) wrote :

The catalyst driver has fixed the problem, fix should be incorporated in the package driver.

Changed in fglrx-installer (Ubuntu):
status: Confirmed → In Progress
Bryce Harrington (bryce) on 2009-06-26
summary: - fglrx broken in Jaunty with SyncMaster 305T and HD4870x2
+ [R700] fglrx broken in Jaunty with SyncMaster 305T and HD4870x2
Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
Bruce Balestier (bbalestier) wrote :

Hello
I also did the same and it worked then for some reason it just stopped working and just became unusable.
I have 2.5 ghz P4 and a ATI Radeon 3650 HD agp card.
I thought the Catalyst 9.5 would fix it but not the case.
SHOOT!

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi earthforce_1,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 366536

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 366536 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/366536

Changed in fglrx-installer (Ubuntu):
status: In Progress → Incomplete
tags: added: needs-retested-on-lucid-by-june
earthforce_1 (earthforce1) wrote :

Yes, fixed in Lucid, thanks.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers