dpms does not switch off backlight on laptop screen

Bug #363059 reported by Slobodan Simić on 2009-04-17
46
This bug affects 4 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

I don't know if this is dpms or fglrx driver issue but backlight are not switched off when display goes in suspended mode
Even
"xset dpms force off" command doesn't do the trick and that worked fine in Intrepid on same laptop and fglrx module.

daponz (daponz) wrote :

Same here,

Only vbetool can switch the backlight off. but that's not a solution for a desktop :/

Calvin Morrow (calvin-morrow) wrote :

Same behavior here:

Jaunty amd64 with an ATI 4850 (also tried with a 3850) using Catalyst 9.4 fglrx driver.

xset dpms commands make the screen blank, however the backlight is still on. Vbetool is able to turn off the backlight.

hgergo (hutongergo) wrote :

i think is it dmps problem same problem with open source drivers ati x200m acer Aspire 5105

Paul Moir (paul-moir) wrote :

I'm having the same problem with a Radeon HD 2400 XT in an Acer Extensa 5450 running kubuntu. xset dpms results in a blank screen with the backlight on while vbetool works. Nothing suspicious in the logs that I see. DPMS enabled, etc.

Martin Burch (mburch) wrote :

I am having the a similar problem with a Compaq Presario V5000, ATI Radeon 200M graphics and the open source drivers: changing the power management or screensaver options just blanks the screen.

However both "xset dpms force off" and "sudo vbetool dpms off" turn off the backlight for me.

Brian Morton (rokclimb15) wrote :

Also affects Radeon HD 3300 video card on 64bit Jaunty. This is definitely shaping up to be an fglrx bug.

Diaa Sami (diaa.sami) wrote :

Doesn't happen with me when using the open-source "ati" driver, but does when using fglrx.

Same trouble.
Apple 20" iMac7,1
ATI Mobility Radeon HD 2600 XT
fglrx video driver.

command "xset dpms force off"
  in Ubuntu 9.04 - don`t turn backlight off, only blank screen
  in Ubuntu 8.04 and Ubuntu 8.10 (updated from 8.04) - works fine

Hello,
after installing the latest 9.5 release from ATI, it works as expected. The driver Version overall works better than the one released with ubuntu!

Kurt Wall (kwall) on 2009-06-01
affects: ubuntu → fglrx-installer (Ubuntu)
Bryce Harrington (bryce) on 2009-06-26
summary: - [jaunty] dpms does not switch off backlight on laptop screen
+ dpms does not switch off backlight on laptop screen
Bryce Harrington (bryce) wrote :

I've posted a new version of the -fglrx driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get fglrx 8.620 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in fglrx-installer (Ubuntu):
status: New → Incomplete
Paul Moir (paul-moir) wrote :

Thank you Mr. Harrington, it's completely resolved the problem for me. xset dpms force off and setting suspend in kubuntu (System Settings->display->Power Control) works as expected.

"xset dpms force off" works fine for me after install latest fglrx driver from AMD site.

Bryce Harrington (bryce) wrote :

Thanks for confirming the issue is no longer occuring

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Fix Released
Bryce Harrington (bryce) wrote :

[Actually I should wait until I upload this package to close the bug...]

Changed in fglrx-installer (Ubuntu):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.620-0ubuntu2

---------------
fglrx-installer (2:8.620-0ubuntu2) karmic; urgency=low

  * Issues resolved since 9.4 (No package changes; Mario just beat me to the upload):
    + With desktop effects enabled, transparent desktop no longer causes desktop icons and
      application windows to disappear
    + Video playback no longer exhibits corruption when desktop effects are enabled and
      Composite is not explicitly disabled
    + [Ubuntu 8.10] System now functions properly when starting X on surround view
      systems
    + Resizing DVD playback window on Mplayer no longer causes blank video
    + System instability no longer occurring when switching to full screen DVD playback
      with Totem Player
    + Terminal window no longer displays error message when launching Catalyst Control
      Center in MultiView
    + [Ubuntu 9.04] Xserver now starts properly with ATI Radeon HD 4870 GPU
      configurations
    + [Ubuntu 9.04] When xrandr --prop is evoked, Xserver failure no longer occurs under
      various system configurations
    + The engine clock and memory clock values are now reported properly by ATI CAL
    + Catalyst Control Center, the primary display is now identified when using the
      Identify Displays button
    + Error message no longer occurs while setting the TV geometry
    + Game corruption does not happen in full screen when 2 monitors are connected and
      RandR 1.2 is enabled
    + TV screen corruption is no longer visible while starting the X-server on some ASICs
    + Executing the following command : aticonfig --initial -f does not cause the following
      message "No supported adapters detected" on some display adapters
    + Detecting second display using amdccle "Detect Display" button no longer results in
      error and will require a relaunch to detect both displays properly
      (LP: #348400)
    + Mplayer does not fail to render video when resizing DVD playback window
    + Fixed: Some system may become unresponsive after starting and killing X-server
      (LP: #355821)
    + System no longer fail to respond when executing multiple server
      generations
    + Memory leak on RV630 (LP: #368271)
    + dpms switches off backlight on laptop screen properly (LP: #363059)
    + Display Preferences no longer causes 100% CPU usage and failure (LP: #366757)

 -- Bryce Harrington <email address hidden> Fri, 26 Jun 2009 22:07:19 -0700

Changed in fglrx-installer (Ubuntu):
status: In Progress → Fix Released
konstantin (k-g-stoyanov) wrote :

Ok, but when this fix will be addted to official reppos, i cant try does it works..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers