Maximized windows spans to both monitors

Bug #347758 reported by Jonathan Ernst on 2009-03-24
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Medium
Unassigned

Bug Description

In jaunty, with two monitors configured with xrandr when maximizing a window it spans to both monitors which makes it unusable (particulary because de second monitor has a different resolution). I don't know if it's a regression as I didn't have the second monitor at the time.

This is with a Radeon card with both -ati and -fglrx.

Allcolor-g (allcolor) wrote :

I have the same problem here.

Before on intrepid, I used the "big desktop" funcitonnality of the fglrx driver... but on jaunty, big desktop does not want to be enabled complaining about randr 1.2 being enabled. I've found no way to disable it and make aticonfig happy so I did try enabling with xrandr, added the virtual mode in the xorg.conf. But now as the bug reports, maximizing windows, maximize on both screen which render the thing unusable.

tags: added: regression-potential
Steve Beattie (sbeattie) on 2009-04-03
Changed in metacity (Ubuntu):
assignee: nobody → canonical-desktop-team
importance: Undecided → Medium
status: New → Confirmed

bryce - could you please see if there is an obvious fix for this?

Changed in metacity (Ubuntu):
assignee: canonical-desktop-team → bryceharrington
Bryce Harrington (bryce) wrote :

@Rick, hard to say, works fine for me on -ati so probably something particular with the user's setup. Without seeing their conf, log, etc. I couldn't hazard a guess. My experience with these kinds of issues is usually a configuration issue.

Allcolor-g (allcolor) wrote :
Allcolor-g (allcolor) wrote :

Here are my xorg.conf and the xorg log file

Allcolor-g (allcolor) wrote :
Allcolor-g (allcolor) wrote :
Jonathan Ernst (jonathan.ernst) wrote :

01:00.0 VGA compatible controller: ATI Technologies Inc RV710 [Radeon HD 4350]

Jonathan Ernst (jonathan.ernst) wrote :
Bryce Harrington (bryce) wrote :

Well, if it's a bug in -fglrx there is probably little we can do.

You mentioned you could reproduce it with -ati; can you attach a conf and log file from after reproducing it with -ati on Jaunty?

Fwiw, I use -ati with dual screens and have never had this problem.

Changed in metacity (Ubuntu):
status: Confirmed → Incomplete
Allcolor-g (allcolor) wrote :

Hi,

I personally don't know if the bug is in the radeon driver, I didn't try with it. But it happens with fglrx, but isn't it the window manager that handles maximisation ? what does the driver as to do with it ? (giving the correct resolution of the desktop I suppose, which would imply that's what is incorrect)

Anyway, I'll try with the radeon driver (I simply have to put the device section in comment in the xorg.conf) and put here back the results.

Allcolor-g (allcolor) wrote :

Ok, I did the test, it was a little more complicated than just commenting out the entry in xorg.conf, I had also to purge fglrx packages for it to start.

So, with the radeon driver, maximization works as expected, only on one monitor not both. But my gnome panel was moved to the second monitor (right) and I didn't find a way to put it back on the first one. Also I've noticed that in the display applet my monitors have their correct name displayed instead of "unknown" like with fglrx. Except for the misplaced panel (and no 3d :'( ), it works.

I've reinstalled fglrx and retry, still the same problem.

So it seems only related to fglrx and not ati-*.

But in fact, like I said earlier, it worked with intrepid with ati big desktop feature... but on jaunty it seems not possible to use "big desktop" and I must use xrandr instead. ati-config complains:

root@trantor2:~# aticonfig aticonfig --initial --dtop=horizontal
Uninitialised file found, configuring.
Error: Options, e.g. --dtop and --desktop-setup, are not supported when RandR 1.2 is enabled

So as I understand, I would need to disable RandR 1.2 for it to work... but I'm unable to do that, is there a way to disable RandR ?

thanks

Bryce Harrington (bryce) wrote :

[Seems to be an -fglrx xrandr bug or something, based on last comment.]

affects: metacity (Ubuntu) → fglrx-installer (Ubuntu)
Changed in fglrx-installer (Ubuntu):
assignee: Bryce Harrington (bryceharrington) → nobody
status: Incomplete → New
Allcolor-g (allcolor) wrote :

I've found a way to disable RandR 1.2 and make ati big desktop setup work again.

To do that: log in a tty and shutdown X.

Add the following in the file '/etc/ati/amdpcsdb' in the section "[AMDPCSROOT/SYSTEM/DDX]":
EnableRandR12=Sfalse

add the following in the xorg.conf in the "Device" section:

Option "EnableRandR12" "false"
Option "DesktopSetup" "horizontal"

Then reboot, and big desktop works (and maximization also).

Regards,
Quentin

I'll attach my xorg.conf and amdpcsdb.

Allcolor-g (allcolor) wrote :
Cruncher (ubuntu-wkresse) wrote :

Could this be related to bug #152894? Just stumbled upon.

mhayenga (hayenga) wrote :

Thank you very much. Allcolor-g's config changes fixed the issue for me on 9.04 with the fglrx driver.

Steve Beattie (sbeattie) on 2009-04-29
tags: added: jaunty regression-release
removed: regression-potential
mjs7231 (mike5060) wrote :

Awesome, the fix worked for me as well using fglrx in Jaunty with RV610 video device [Radeon HD 2400 PRO].
Thanks.

Following Allcolor-g's instructions not only worked, but made another problem go away:

- As long as xrandr12 was enabled, whenever I launched a wine of cxoffice-application, the xserver-process would eat 100% cpu. Switching to the console and back made the xserver behave again.
- It was only after I noticed that gnome-display-properties induced the same behaviour that I started researching xrandr problems.

Curious.

Jaunty
xorg-driver-fglrx 2:8.600-0ubuntu2
xserver-xorg: 1:7.4~5ubuntu18
lspci -nns 01:00.0
-> 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV610 [Radeon HD 2400 XT] [1002:94c1]

Bryce Harrington (bryce) wrote :

I've posted a new version of the -fglrx driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get fglrx 8.620 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in fglrx-installer (Ubuntu):
status: New → Incomplete
Mario S. (sm666) wrote :

hi,
@bryce: your change worked for me, but I had some troubles to get the dualscreen work (first the external went black when enabling dual screen, then the Laptop LCD went black, but finally - after 5 tries it worked, I could not find out what was wrong, but it seems as if the resolution settings for the two displays get lost in some point in time - restart after install and config helped)

best
mario

Bryce Harrington (bryce) wrote :

Thanks for testing Mario, that's a good sign. Would be nice to get Jonathan's feedback on the issue.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Invalid
GodNobody (godnobody) on 2011-05-01
Changed in fglrx-installer (Ubuntu):
status: Invalid → New
status: New → Invalid
GodNobody (godnobody) on 2011-05-01
Changed in fglrx-installer (Ubuntu):
status: Invalid → New
GodNobody (godnobody) wrote :

Hey there,

I want to reopen this bug, since I still have this issue with randr and the fglrx driver on my new natty installation.

I'm on ubuntu 11.04

and have tried with the newest fglrx-installer (2:8.840-0ubuntu4).

I also have open a duplicate bug to get all information to launchpad:

https://bugs.launchpad.net/ubuntu/+bug/774656

Attached you will also find my xorg.confs I tried.

Thanks!

GodNobody (godnobody) wrote :
GodNobody (godnobody) wrote :
GodNobody (godnobody) wrote :
GodNobody (godnobody) wrote :
GodNobody (godnobody) wrote :
GodNobody (godnobody) wrote :
GodNobody (godnobody) wrote :
Bryce Harrington (bryce) on 2012-03-02
Changed in fglrx-installer (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers