fglrx 8.6 graphic corruption on 4850

Bug #345511 reported by Luigi Maselli on 2009-03-19
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

I'm on an updated Jaunty release. It is completly unusable and I had to remove xorg-driver-fglrx to restore a "working" system.

The xorg.conf seems to not be considered anymore. I have "radeon" inside it but still loaded fglrx

Luigi Maselli (grigio) wrote :

The unique fglrx log I found (but with the past Xorg)

Luigi Maselli (grigio) wrote :

Picture: http://grigio.org/files/jaunty-fglrx.jpg

The workaround is to come back to the radeon driver:
restart in recovery mode

sudo apt-get remove --purge xserver-xorg-video-fglrx
sudo dpkg-reconfigure -phigh xserver-xorg
sudo init 5

Luigi Maselli (grigio) wrote :

sudo aticonfig --initial -f

to fix it

M Rolle (rolle) wrote :

Thanks Luigi.. I been following this one as its the same error (or close enough to it). If want to merge my thread with this that's fine: https://bugs.launchpad.net/ubuntu/+bug/345264

aticonfig --initial -f worked the other stuff the post above didn't.

Now---before I reboot, do I need to add aticonfig --inital -f somewhere to make it stay put? Should I stop doing upgrades?

rbmorse (rbmorse) wrote :

Running

sudo aticonfig --initial -f

needs only be run once after installing the driver. All it does is write the proper options into the /etc/X11/xorg.conf file.

M Rolle (rolle) wrote :

Gotcha =) then I'm good to go now. The new kernel update really seems to have fixed many of the graphical errors. Firefox scrolling, notification dialog, list goes on. Gracias

Luigi Maselli (grigio) wrote :

This issue still happens with latest fglrx on jaunty

Monkey (monkey-libre) wrote :

I´ve assigned this bug to the fglrx package.

Thank You for making Ubuntu better.

affects: ubuntu → fglrx-installer (Ubuntu)
Bryce Harrington (bryce) on 2010-03-05
tags: added: jaunty
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Luigi,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 345511

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 345511 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/345511

Changed in fglrx-installer (Ubuntu):
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments