Ubuntu

[fglrx] vsync issues - screen tearing unrelated to compiz

Reported by Benjamin Drung on 2008-11-30
186
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
fglrx
Fix Released
Undecided
Unassigned
fglrx-installer (Ubuntu)
Medium
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Since Catalyst 11.1 AMD starting open test of EnableTearFreeDesktop fglrx option.
If you want yo test is you should run "aticonfig --set-pcs-u32=DDX,EnableTearFreeDesktop,1" and restart X.Org Server or reboot computer.
Please be careful - it's experimental feature. Some people have reported hard locks when this is enabled. If you experience this, please boot in safe mode and use "sudo mv /etc/ati/amdpcsdb /etc/ati/amdpcsdb.old" to reset your driver settings.

Latest Catalyst driver: http://support.amd.com/
Source: http://www.phoronix.com/scan.php?page=article&item=amd_catalyst_111&num=1
Confirmations: see in comments since #84 and here http://phoronix.com/forums/showthread.php?29919-Has-AMD-Finally-Fixed-Tearing-With-Its-Linux-Driver

Bug description:
=====================================
Videos tear when I play them with xv extension. I enabled vsync with Catalyst Control Center and running 'aticonfig --initial --input=/etc/X11/xorg.conf --overlay-type=Xv', but the video still tears. I tried several Xorg.conf settings but without any improvement. Removing Xorg.conf does not change anything.

I have this problem since Hardy with a Radeon HD 3650. Even Windows XP with Catalyst driver tears. Some time ago I switched to a Radeon HD 4670 (see lspci-vvnn.log), but even this card tears.

The videos tear and do not flicker. This bug also occurs with Compiz disabled.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller [8086:29c0] (rev 02)
     Subsystem: Intel Corporation Device [8086:5044]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV730XT [Radeon HD 4670] [1002:9490]
     Subsystem: Hightech Information System Ltd. Device [1787:2268]

---
Architecture: amd64
DistroRelease: Ubuntu 10.10
DkmsStatus: fglrx, 8.723.1, 2.6.32-22-generic, x86_64: installed
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: fglrx
Package: fglrx-installer (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=dd94e74a-7def-467c-9887-28330d739490 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: maverick maverick
Uname: Linux 2.6.32-22-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/15/2009
dmi.bios.vendor: Intel Corp.
dmi.bios.version: DPP3510J.86A.0572.2009.0715.2346
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: DG33TL
dmi.board.vendor: Intel Corporation
dmi.board.version: AAD89517-802
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrDPP3510J.86A.0572.2009.0715.2346:bd07/15/2009:svn:pn:pvr:rvnIntelCorporation:rnDG33TL:rvrAAD89517-802:cvn:ct3:cvr:
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.32-22-generic

Benjamin Drung (bdrung) wrote :
Benjamin Drung (bdrung) wrote :
Benjamin Drung (bdrung) wrote :
Bryce Harrington (bryce) on 2008-12-01
Changed in fglrx-installer:
importance: Undecided → Medium
status: New → Triaged
Changed in fglrx:
importance: Undecided → Medium
unggnu (unggnu) wrote :

It seems to be a general FGLRX problem. I can confirm this with Ati 4870. The only workaround so far is to enable vsync in the Control Center and use the OpenGL video output. But the OpenGL output is far from perfect too.

Bryce Harrington (bryce) on 2008-12-15
Changed in fglrx:
status: New → Confirmed
Benjamin Drung (bdrung) wrote :

fglrx 8.561 (Catalyst 8.12) is still affected.

unggnu (unggnu) wrote :

I am pretty sure that this isn't a duplicate of bug #179042 since the tearing happens even without Compiz.
Imho Compiz isn't usable atm with FGLRX and newer ATI cards.

Benjamin Drung (bdrung) wrote :

It is definitely not a duplicate of bug #179042. I have Compiz disabled (because of bug #179042) and videos tear.

description: updated
Bryce Harrington (bryce) on 2009-01-16
description: updated
quazar (spamdani) wrote :

Have same issue with latest 9.1 driver on my HD3100.

unggnu (unggnu) wrote :

Opened a bug report upstream http://ati.cchtml.com/show_bug.cgi?id=1434 but it doesn't seem to be the official tracker. I don't know if the developers check it regularly.

Changed in fglrx:
importance: Medium → Unknown
status: Confirmed → Unknown
importance: Unknown → Undecided
status: Unknown → New
importance: Undecided → Unknown
status: New → Unknown
Changed in fglrx:
status: Unknown → Confirmed

Again, it is NO Compiz issue. It happens all the time, even without Compiz.

hapubun (sdeal2) wrote :

disable compiz will fix

 intel compiz is fixed or ati drivers fixed its one of these that is the prob

update Ati driver to newest 9.1 i seen improvement

Benjamin Drung (bdrung) wrote :

I am currently using fglrx 8.573 (released in January 2009) with Compiz disabled and the tearing is not improved.

@hapubun: I think your comment refer to bug #179042.

unggnu (unggnu) wrote :

9.1 doesn't fix the problem, at least with 4870.

gsf_atx (gsf-atx) wrote :

I have the same issue using the 9.2 driver and a HD3400 onboard an ASUS M3A78-EM MB connected to a SONY KDS-50XBR1 via HDMI (NO DVI/HDMI adaptor). Glad to test beta driver or any other software/configuration mods.

Thanks for addressing this issue! It is a showstopper on my HTPC.

hapubun (sdeal2) wrote :

get nvidia card no probs i had to go back to nvidia 5700FX card and everything fine ati allways sucked

hapubun (sdeal2) wrote :

also the improvement was when i was using lindvd and compiz was enabled no tear at fullscreen or windowed but sluggish in window form so just say no to ati intel they do a better job i never buying ati products again

hapubun (sdeal2) wrote :

also intel they support is better for linux windows ect...

Ha! Funny, I bought this board because of the past problems I've had with
nvidia. I think any new hardware will have issues in linux or windows,
regardless.

I had 2 6800GT cards, paid $350 for each. One died and the other one is on
its way out now. No overclocking, upgraded cooling.

We'll see how this plays out. I'm pissed I can't watch a video on my new
htpc.

On Mar 6, 2009 9:20 PM, "hapubun" <email address hidden> wrote:

also intel they support is better for linux windows ect...

-- [fglrx] video tearing / vsync problems - independent of compiz use
https://bugs.launchpad.net/b...

The OpenGL video output doesn't tear if you enable always to vsync in the Catalys Control Center at least on my pc.

gsf_atx (gsf-atx) wrote :

I've tried enabling the OpenGL video output in xorg.conf as well as selecting it as output type in vlc. There is still tearing, it doesn't seem to improve.

On a good note, I have built, installed and set up the RadeonHD free xorg driver (v1.2.4) and video playback is superb. Unfortunately, that driver doesn't have any DRI support for my video chip, so I must use full software rendering. My CPU can handle HD resolution video without any noticeable problem.

I restarted with the FGLRX driver and played the video under vlc with the same options (hardware acceleration disabled) and there was still tearing.

unggnu (unggnu) wrote :

Workaround:
1.install the packages fglrx-amdcccle and vlc (vlc isn't needed if your video player support OpenGL video output too)
2.run Accessories - ATI Catalyst Control Center or run amdcccle in console
3.choose category 3D - More Settings and set "Waiting for vertical refresh" to "Always on" on the right
4.start vlc or your video player and choose OpenGL video output

Afterwards it should work. The OpenGL output is not perfect, sometimes a little bit grainy with red colors but much more better than the Xorg output.

I have a HD 4870 so it should work on older cards too I guess.

gsf_atx (gsf-atx) wrote :

Many thanks for attempting to help me solve this. I had already performed the steps you outlined above to no avail.

I also tried using the aticonfig -ov command to modify xorg.conf for gl overlay.

I mistyped the model# of my video chip, it's the 3200, it's an onboard 780 video chip, one of the newer low-end chips I believe.

hapubun (sdeal2) wrote :

new driver 9.3 and updates fix this at least for me works with compiz enable

hapubun (sdeal2) wrote :

the new ati driver 9.3 and updates fix this at least for me works with compiz enable but the default sound is still the hdmi i used asoundconf set-default-card to set the one to default but still no help i have another prob with my Belkin usb 2.0 5-port pci card freezing the computer when i plugin keyboard and other devices why don't know works sometimes

Daniel Pirch (dpirch) wrote :

The tearing of xv video output is still present in Jaunty (with or without compiz enabled). OpenGL video output (-vo gl for mplayer) works without tearing.

laysan_a (laysan-a) wrote :

On my system (when it was installed - I got rid of it) every video object, meaning every object on my screen, shortcuts, folders, plasma widgets, everything, was torn horizontally across the screen, except when the screen was updating, then it would momentarily clear.

I had the fglrx from the repository (8 something?) installed, and the latest 9-5. Both exhibited this tearing.

Oh, and if I played a video the objects on the video screen tore as well.

I do not have desktop effects on.

I have kubuntu 9.04 installed.

Nothing I changed in the ati configuration utility had any effect whatsoever.

This is very unfortunate. I watch a lot of video on my machine, and the xorg drivers just aren't good enough to render high quality streamed media in full screen on my system. Fglrx worked perfectly well in intrepid. It was a disappointment to find it broken in jaunty.

MB:ASUS M3A78-EM AM2+/AM2 780G HDMI, Proc: Athlon 64 X2 5000+ Brisbane 2.6 GHz 2x512KB L2 Cache, Graph: Int. ATI Radeon HD 3200, Aud: Int. Realtek ALC1200 8 channels, Ram: 2GB Corsair XMS2 DDR2 800 SDRAM, Monitor: Dell SE198WFP 19" Wide FPM

Bryce Harrington (bryce) on 2009-06-26
summary: - [fglrx] video tearing / vsync problems - independent of compiz use
+ [RV730XT] [fglrx] video tearing / vsync problems - independent of compiz
+ use
Bryce Harrington (bryce) on 2009-08-13
tags: added: hardy

On Thu, 2009-08-13 at 21:48 +0000, Bryce Harrington wrote:
>
> Maybe this problem have something to do with the on-board Intel
> Graphics Media Accelerator 3100 of the Intel DG33TL [1] mainboard.
>

No, this is a known issue with the fglrx drivers. IIRC, the underlying
issue is that there is no formal specification for vsynced XV.

Benjamin Drung (bdrung) on 2009-08-13
description: updated
tags: added: intrepid
tags: added: jaunty

What worked for me on Jaunty with 9.8 ATI driver. Go to Catalyst Control Centre a select Always On for Vertical sync in 3D/Preferences section. However, when I first tried this the X server froze. Then I updated (flashed) the motherboard BIOS (Asus M3A78-EM) to the newest revision and the freezing problem (and tearing) was gone.

Alberto Milone (albertomilone) wrote :

Can you see if you can still reproduce the problem with the latest driver in Ubuntu Karmic, please?

Benjamin Drung (bdrung) wrote :

fglrx 2:8.660-0ubuntu1 is still affected.

kreggz (jasonkregting) wrote :

i can also confirm that Karmic is still affected.

psarhjinian (psarhjinian) wrote :

Still happens with Karmic (updated to 20091023), with Totem set to use Xv and fglrx 2:8.660-0ubuntu4 driving a Radeon HD4770. No modifications to xorg.conf. Tests with fullscreen video

Without Compiz
In Totem, normal X output doesn't tear (or if it does, it's subtle) but does more than double CPU usage. Using OpenGL in VLC doesn't tear, uses less CPU (but not as little as Xv). Xv tears with a progressive tear line proceeding distractingly down the screen

With Compiz (and with sync to vblank and refresh set to match amdcc)
In Totem, normal X and Xv tear in a progressive manner, with the tear line progressing down the screen a bit more haphazardly than without Compiz. VLC with GL tears, but in an odd, flickery fashion. CPU is slightly higher (10%) across the board.

Zenigata (ispettore) wrote :

Same problem with 9.04 and Ati drivers 9.10. :(

Andru (andru-kun) wrote :

The same problem for me with Ubuntu 9.10, fglrx 8.671(aka Catalyst 9.11) and Radeon HD 4650

Sean (svz90) wrote :

Updated bug report in ATI bug tracker so that it now references this report. Also voted for the bug in the ATI tracker.

Sean (svz90) on 2010-01-20
tags: added: karmic
Sean (svz90) wrote :

Filed feedback within the AMD official driver feedback system, available here:
http://www.amdsurveys.com/se.ashx?s=5A1E27D23CFE9B36

ybdjkfd (ybdjkfd) wrote :

I don't know if this helps with your tearing, but this seemed to fix my issues on my machine with video problems. I checked to fix the permissions of "/dev/dri/card0", but that did not exist per some other recommendations. I then did a search for "card0" and saw that it existed in "/dev/ati/card0". I changed permissions by adding the ability for the group to use it (g+rw) and made confirmed that I was part of the video group. It seemed to improve my video handling on my machine. Of course your bug is independent of Compiz, but thought this may help others just in case.

Remi Gauvin (rashkae) wrote :

I can confirm that XV output in karmic and flgrx still tears. I can use gl output, but that corrupts the video in interesting ways when using Compiz (seems to work well without compiz). However, if not using Compiz, I get perfect XV video output with the open source drivers.

jamebus (james-hicag) wrote :

Yes. One thing to note is the radeon driver in karmic has anti-tearing features when using XVideo. flgrx and older radeon don't have that.

I can confirm radeon = no tearing, whereas flgrx = tearing

Remi Gauvin (rashkae) wrote :

More information:

If Vsync is enabled in Catalyst control centre, and gl video output is used, then video does not tear, *as long as desktop effects are not enabled*. It appears as though compiz prevents vsync from working. I don't know if this bug should be filed against compiz, or remain with the fglrx driver.

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Benjamin,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 303697

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 303697 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/303697

Changed in fglrx-installer (Ubuntu):
status: Triaged → Incomplete
tags: added: needs-retested-on-lucid-by-june

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

It's still there in Ubuntu 10.04 (lucid).

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Triaged
Bryce Harrington (bryce) on 2010-05-14
tags: added: maverick

I have had more time to test this on another computer.

Both R7** and R8** suffer from tearing with fglrx proprietary drivers.

summary: - [RV730XT] [fglrx] video tearing / vsync problems - independent of compiz
- use
+ [fglrx] vsync issues - screen tearing unrelated to compiz
unggnu (unggnu) wrote :

You are right that tearing appears even without Compiz but this could be circumvented by using OpenGL video output and activating vsync for everything in the AMD Controlcenter. This workaround doesn't work with Compiz so the main problem is with Compiz.

I disagree, if the problem exists without compiz, then it is not a "main" problem with compiz.

The issue lies in the driver.

unggnu (unggnu) wrote :

Of course it is a driver issue. I just meant the to my knowledge not circumventable issue appears in combination with Compiz.

Nevertheless I have given up hope that this bug will be fixed in the near futures. This issue is known since several years and it seems that some serious changes are needed for this to be fixed otherwise they would have already done it.

The good thing is that except of a proper power management the free driver has all the features for my card 4870 now. Maybe it renders 3D not as fast as the fglrx but it just works and doesn't have all this annoying bugs (which never seem to get fixed).

PsYcHoK9 (psychok9) wrote :

Only compiz ignores the opengl vsync setting. Glxgears does it.

PsYcHoK9 (psychok9) wrote :

Opengl game, like World of Warcraft, works flawlessy with vsync on at 60Hz/fps.
Please fix compiz.

Benjamin Drung (bdrung) wrote :

@PsYcHoK9: This bug is unrelated to compiz. It happens with metacity.

PsYcHoK9 (psychok9) wrote :

Metacity have another problem... (isn't opengl), but why compiz don't works like an normal opengl app?

Paul K (kucher) wrote :

Here is what I have found since I first reporting my problem. It turns out this is a Catalyst Driver issue. On a different computer running Ubuntu 10.04 and with a Radeon HD 4890 I was able to get solid graphics performance with no screen tearing using the latest open source ati driver. However, on the same machine with 10.04 and the Catalyst driver, I am seeing screen tearing.

Just to recap my other machine has a Radeon HD 5870 and I am seeing tearing with the Catalyst driver. Unfortunately, however, the open source ati driver does not currently support the Evergreen series of GPUs, so I am stuck with this pitiful driver. I am now hopeful that my problems will be solved later this year when 5xxx series cards are supported in the open source graphics stack.

I'm looking forward to Ubuntu 10.10 and beyond. I think this problem won't be fixed until that time and any future AMD/ATI GPUs I would advise staying away from until the open source driver can support them out of the box. It is my understanding that this screen tearing issue is rooted in something fundamental to the proprietary Catalyst driver and is not going away any time soon.

Please check with 10.7 driver.

Chris Billington (cjbil1) wrote :

Still present with the newest driver (fglrx 2.8.753) running on an otherwise fresh lucid install

PsYcHoK9 (psychok9) wrote :

Thank you AMD/ATi for don't fix the problem... I like so much!
Today I've installed Ubuntu with and old ATi 1300/1500 and I got with open source driver perfect video experience without problems...

artik (jeff-artik) wrote :

Still here in 10.8 ... ATI totally suxxx ....... I had 2 very bigs issues with graphic cards in my life, both time : ATI ... I give up !

Download full text (3.3 KiB)

artik,

I really think a lot of the blame (at least half?) belongs with the xorg devs. Fglrx worked great for me on intrepid. It wasn't until they improved X that the incompatibility issues began.  I wouldn't be surprised if the devs are so excited by the prospect of finally being able to code their own drivers up to industry standards (since ati/amd opened their sources) that there just isn't as much interest in getting the proprietary drivers to work.

--- On Tue, 8/31/10, artik <email address hidden> wrote:

From: artik <email address hidden>
Subject: [Bug 303697] Re: [fglrx] vsync issues - screen tearing unrelated to compiz
To: <email address hidden>
Date: Tuesday, August 31, 2010, 9:28 PM

Still here in 10.8 ... ATI totally suxxx ....... I had 2 very bigs
issues with graphic cards in my life, both time : ATI ... I give up !

--
[fglrx] vsync issues - screen tearing unrelated to compiz
https://bugs.launchpad.net/bugs/303697
You received this bug notification because you are a direct subscriber
of the bug.

Status in AMD fglrx video driver: Confirmed
Status in “fglrx-installer” package in Ubuntu: Triaged

Bug description:
Videos tear when I play them with xv extension. I enabled vsync with Catalyst Control Center and running 'aticonfig --initial --input=/etc/X11/xorg.conf --overlay-type=Xv', but the video still tears. I tried several Xorg.conf settings but without any improvement. Removing Xorg.conf does not change anything.

I have this problem since Hardy with a Radeon HD 3650. Even Windows XP with Catalyst driver tears. Some time ago I switched to a Radeon HD 4670 (see lspci-vvnn.log), but even this card tears.

The videos tear and do not flicker. This bug also occurs with Compiz disabled.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller [8086:29c0] (rev 02)
        Subsystem: Intel Corporation Device [8086:5044]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV730XT [Radeon HD 4670] [1002:9490]
        Subsystem: Hightech Information System Ltd. Device [1787:2268]

---
Architecture: amd64
DistroRelease: Ubuntu 10.10
DkmsStatus: fglrx, 8.723.1, 2.6.32-22-generic, x86_64: installed
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: fglrx
Package: fglrx-installer (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=dd94e74a-7def-467c-9887-28330d739490 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: maverick maverick
Uname: Linux 2.6.32-22-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/15/2009
dmi.bios.vendor: Intel Corp.
dmi.bios.version: DPP3510J.86A.0572.2009.0715.2346
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: DG33TL
dmi.board.vendor: Intel Corporation
dmi.board.version: AAD89517-802
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrDPP3510J.86A.0572.2009.0715.2346:bd07/15/2009:svn:pn:pvr:rvnIntelCorporation:rnDG33TL:rvrAAD89517-802:cvn:ct3:cvr:
system:
 distro:             Ubuntu
 codename:           maverick
 archit...

Read more...

Looks like it's affected both of AMD, nVidia and probably Intel GPU (I not test Intel GPU for tearing). Maybe I wrong, but maybe cause of this bug in xorg?
What talk AMD and nVidia developers about tearing problem?

wirespot (wirespot) wrote :

I'm also affected by the bug described by laysan_a at #26: all objects on the desktop (widgets, icons etc.) are tearing heavily. I'm on Lucid. Had same issue on Karmic. There is no Compiz or compositing activated. It's a Radeon HD 3200 (780 chipset onboard video). I regularly try the newer Catalyst releases as well as what Ubuntu pushes through "hardware drivers" but so far no luck.

Interestingly enough, in fullscreen OpenGL applications there's no tearing, only on the desktop. And the tearing also stops while glxgears is running on the screen.

Changed in ubuntu-release-notes:
status: New → In Progress
Kate Stewart (kate.stewart) wrote :

Changed target to maverick to denote its documented in maverick's release notes.

jisaac (jisaac) wrote :

Just installed 11.04 Alpha 1 on my iMac i7 27" (Radeon HD 4850) and there is NO MORE vsync issue!!! The "Wait for vertical refresh" option simply works!

Regards.

Someone, who already try Nattty, can confirm it for other ATI GPU?

jisaac (jisaac) wrote :

I'm getting good results too with full updated Ubuntu 10.10.

No tearing at all (Desktop experience with or without compiz) but very low performance when playing videos.

noobish (noobish) wrote :

FYI ati-linux-bugs #1434 no longer exists at ati.cchtml.com, because the web hosting of that site has just changed and the old database could not be restored.

Anybody that has the old bug data should please resubmit to ati.cchtml.com.

The Fiddler (stapostol) wrote :

2011/1/26 RussianNeuroMancer <email address hidden>

> fglrx users, please test new Catalyst 11.1 driver:
> http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.42&lang=English

The new driver causes a hard lock on my system as soon as the tearfree
option is enabled. There might be a reason why it is disabled by default.

However, other people have confirmed that it solves the tearing issues. This
bug may be finally reaching its end.

description: updated
The Fiddler (stapostol) on 2011-01-26
description: updated
Fiodor (u-giorgi) wrote :

I confirm, works well with my ATI HD 2600 XT

driver fglrx 11.1 are tearing free :-)

bye.

Fiodor (u-giorgi) wrote :

...I forgot to mention :
just go in and set up Catalyst Control Center No tearing.

Chris Billington (cjbil1) wrote :

Holy Jesus I never thought I'd see the day. Tearing gone on a System76 Panp7 running Ubuntu 10.10 with ccc 11.1 and after doing:

sudo aticonfig --set-pcs-u32=DDX,EnableTearFreeDesktop,1

...Now to go check how the Plymouth issues are doing...

The Fiddler (stapostol) wrote :

Fix confirmed! You can enable tearfree through amdccle, too.

Changed in fglrx:
importance: Unknown → Undecided
status: Confirmed → New
status: New → Fix Released
Changed in fglrx-installer (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntu-release-notes:
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.