Corruption (ambiguous) of the Screen in a GLX game [EPR#257842]

Bug #289628 reported by drakesoft on 2008-10-26
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
fglrx
Triaged
Medium
Unassigned
fglrx-installer (Ubuntu)
Low
Unassigned

Bug Description

Hello,
I have a ati HD3200 (onboard) graphics adapter. I installed the newest ati driver (8.54.3) on ubuntu 8.04 (AMD64) but I got a corrupt output in games like quake3 and Nexuiz, then I updated to ubuntu 8.10 (amd64) in the hope it would work, but i have the same problem. The crazy things is fgl_glxgears runs perfektly.

drakesoft (powerschorsch21) wrote :

sorry I made a misstake, I boot the old kernel (2.6.24), the new one doesnt work, but I think this problem is public knowen.

Changed in fglrx-installer:
status: New → Invalid
drakesoft (powerschorsch21) wrote :

Ok new update, the ati driver works under ubuntu 8.10, but the same problem of corruption (3D).

Changed in fglrx-installer:
status: Invalid → New
drakesoft (powerschorsch21) wrote :

I can exclude the hardware as initiatior of this problem, because with an other OS it works perfektly.

Changed in fglrx-installer:
importance: Undecided → Low
status: New → Triaged
drakesoft (powerschorsch21) wrote :

I add an screenshot ... this is for example ioquake3

Bryce Harrington (bryce) wrote :

I've upstreamed this to AMD; they're looking into it.

I'm wondering if perhaps it's just a dupe of bug #179042, which is a known issue with similar symptoms.

Changed in fglrx:
status: New → Confirmed
drakesoft (powerschorsch21) wrote :

I dont know. Compiz works a bit slowly but no corruption, the fgl_glxgears test works perfektly too but in games like ioquake3, etracer .... I got curruptions like in the screenshot.

Winston Smith (abgasturbolader) wrote :

I can confirm this bug. I am running Intrepid AMD64 with a HD3200 (780g). I noticed that this only happens in fullscreen mode.

Jens Christian (jc-westly) wrote :

This is not a x64 spesific problem. I have installed a x86 version of Intrepid with a HD3200 and I have the same problem when I run XBMC or Boxee in fullscreen mode.

Jens Christian (jc-westly) wrote :

@Bryce: I had the blinking issue (#179042) with hardy, but then it worked ok in fullscreen. I do not have the blinking issue any more, but I have the corruption issue when running programs in fullscreen mode. I do not have compiz enabled and didn't have it enabled when I ran hardy either.

Bryce Harrington (bryce) wrote :

This has been forwarded upstream to AMD as EPR#257842

Changed in fglrx:
status: Confirmed → Triaged
Bryce Harrington (bryce) on 2008-11-06
Changed in fglrx:
importance: Undecided → Medium
Jens Christian (jc-westly) wrote :

Additional info:
http://xbmc.org/forum/showthread.php?t=39717&page=5

Full screen seems to be okey in xmbc when running xbmc as su. (sudo xmbc). Se thread for more details.

Yözen Hernández (yhernand) wrote :

Confirmed here too on an integrated ATI Radeon HD 3200. Winston is right that this only seems to happen in fullscreen: changing any games to run in windowed mode causes no corruption. OpenGL screensavers also cause this problem.

I have installed catalyst 8.11 (8.522) by enabling the proposed updates in intrepid. The bug seems to be fixed with the new driver.

drakesoft (powerschorsch21) wrote :

Yes, I can confirm this.

Yözen Hernández (yhernand) wrote :

Confirmed here too! Updating to the newest driver in proposed as suggested worked. Fullscreen gaming, here I come!

Bug 284119 was marked as a duplicate of this, in that situation, running elisa (fullscreen) with sudo strangely resolved the problem.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.600-0ubuntu1

---------------
fglrx-installer (2:8.600-0ubuntu1) jaunty; urgency=low

  * New upstream release. (Closes LP: #313027, #314600)
    - Fixes LP: #253988, #179042, #241176, #284408, #287229, #296497,
      #288620, #289628
  * README.Debian: Update the update procedure a bit

 -- Bryce Harrington <email address hidden> Tue, 17 Mar 2009 15:40:42 -0700

Changed in fglrx-installer:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers