fglrx suspend works, resume doesn't return with working X

Bug #287901 reported by Jarkko Lietolahti on 2008-10-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx
New
Undecided
Unassigned
fglrx-installer (Ubuntu)
High
Unassigned

Bug Description

After installing the latest fglrx from fglrx-installer resuming from sleep doesn't work as expected.
The system does something on resume but X never appears. Sometimes there's is garbled red markings on the screen.
Caps-lock doesn't work. Shutdown doesn't work properly. Something after resuming hard-drive led shows some activity.

Description: Ubuntu 8.10
Release: 8.10

Jarkko Lietolahti (jarkko-jab) wrote :
Jarkko Lietolahti (jarkko-jab) wrote :

I took another laptop and used it to ssh back to my main laptop. And it worked. So the resume is working, but restoring the graphical screen doesn't. The keyboard of the main laptop is stuck (e.g. Alt-SysRq doesn't work), however power-off button works sometimes.

Jarkko Lietolahti (jarkko-jab) wrote :
Bryce Harrington (bryce) wrote :

Hi jarkko-jab,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in fglrx-installer:
status: New → Incomplete
skoczko (skoczko) wrote :

Same issue here, on t43p with Mobility FireGL V3200 and Ubuntu 8.10. Driver installed by enabling it in the restricted drivers popup. i'm running compiz on top of it. The system suspends fine but resumes with blank screen and non-responsive keyboard, hard-reset is the only option to bring it back to life. I tried dmesg and kernel.log but nothing there. Will look in xrorg.log too.h

Bryce Harrington (bryce) wrote :

@skoczko, suspend/resume issues tend to have identical symptoms but quite different causes, and are especially hardware-dependent. So it's likely your issue is unrelated to Jarkko's. Please file a new bug. You should also check if you can reproduce the issue with the -ati or -vesa driver - if so, then you should file your bug against the kernel rather than fglrx-installer.

@Jarkko, I'm closing this bug as expired at this time, but please feel free to reopen with the requested information if you can still reproduce it.

Changed in fglrx-installer:
status: Incomplete → Invalid
Jonathan Steinhart (jsteinhart) wrote :

I'm definitely still seeing this -- and have been for quite some time. I'm on a Thinkpad T60p with a Mobility FireGL V5200.

lspci -vvnn and /var/log/Xorg.0.log.old (from a crashed standby) attached

Same symptoms: system comes back up (I can ssh in from elsewhere), but display is useless. Changing to text console (ctrl-alt-f1) or restarting X (ctrl-bksp) don't help. I can ctrl-alt-delete reboot though.

Jonathan Steinhart (jsteinhart) wrote :
Changed in fglrx-installer:
status: Invalid → Confirmed
Bryce Harrington (bryce) on 2008-11-24
Changed in fglrx-installer:
importance: Undecided → High
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

Ahh, this seems to be a dupe of 197209, thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers