r3xx Hardware does not work with fglrx [EPR#257839]

Bug #284408 reported by Pat Double on 2008-10-16
394
This bug affects 44 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Software Updater
Invalid
Undecided
Unassigned
fglrx
Won't Fix
Medium
Unassigned
fglrx-installer (Ubuntu)
Medium
Unassigned
Nominated for Karmic by vyncere
Intrepid
Undecided
Unassigned
Jaunty
Medium
Unassigned
update-manager (Ubuntu)
Medium
Michael Vogt
Nominated for Karmic by vyncere
Intrepid
Undecided
Unassigned
Jaunty
Medium
Michael Vogt

Bug Description

Using fglrx-installer 2:8.543-0ubuntu4, r3xx hardware such as Radeon 9500, Mobility Radeon 9700 and similar don't work

They are not explicitly listed in the modaliases, so they will not be offered by Jockey. In the past, this hardware did work with the fglrx driver. Now the fglrx driver indicates memory errors when trying to load.

Here is a snippet of what the memory error will look like:
[ 1024.699204] [fglrx] Maximum main memory to use for locked dma buffers: 1169 MBytes.
[ 1024.700616] [fglrx:drm_alloc] *ERROR* [driver] Allocating 0 bytes
[ 1024.700683] [fglrx:firegl_init_device_list] *ERROR* Out of memory when allocating device heads
[ 1024.700757] [fglrx:firegl_init_module] *ERROR* firegl_init_devices failed

WORKAROUND:
You'll need to completely remove the proprietary driver and [re]install the open-source driver. As a plus, many users report improved performance with the open-source drivers in Intrepid versus ATI's fglrx in Hardy for 2D purposes such as normal desktop use and video playback.
1. sudo apt-get remove --purge fglrx*
2. sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
3. sudo apt-get install xserver-xorg-video-ati
4. Restart.

TEST CASE:
1. Install intrepid w/ r3xx hardware.
2. attempt to activate fglrx and reboot verifying unable to start X
3. Activate intrepid-proposed
4. update to new fglrx version, verify that X starts up properly

Pat Double (patdouble) wrote :
Pat Double (patdouble) wrote :

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] [1002:4e50]
        Subsystem: Dell Device [1028:017c]
        Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 32, IRQ 16
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at c000 [size=256]
        Memory at fcff0000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at fc000000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel modules: radeonfb

Martin Pitt (pitti) wrote :

modalias:pci:v00001002d00004E50sv00001028sd0000017Cbc03sc00i00
modalias

Indeed the current /usr/share/jockey/modaliases/fglrx-modules.alias.override does not contain this model. If you confirm that your card works with fglrx, then the list shuold be updated to include this. Thanks!

Changed in jockey:
status: New → Triaged
Pat Double (patdouble) wrote :

It doesn't work :( I have used fglrx on this machine for at least a year, the last version was 8.9 on Hardy. There are two problems. The fglrx module won't load, I have included a kernel snippet. Perhaps the mtrr errors are important? The second is that X won't start.

[ 54.001576] mtrr: base(0xf0000000) is not aligned on a size(0x7ff0000) boundary
[ 61.356036] eth0: no IPv6 routers present
[ 131.947429] mtrr: no MTRR for f0000000,7ff0000 found
[ 151.017569] pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 161.449071] mtrr: base(0xf0000000) is not aligned on a size(0x7ff0000) boundary
[ 181.315090] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[ 181.358014] [fglrx] Maximum main memory to use for locked dma buffers: 1896 MBytes.
[ 181.359293] [fglrx:drm_alloc] *ERROR* [driver] Allocating 0 bytes
[ 181.374755] [fglrx:firegl_init_device_list] *ERROR* Out of memory when allocating device heads
[ 181.390432] [fglrx:firegl_init_module] *ERROR* firegl_init_devices failed
[ 376.592709] mtrr: no MTRR for f0000000,7ff0000 found
[ 450.141471] mtrr: base(0xf0000000) is not aligned on a size(0x7ff0000) boundary

It sounds like the driver is perhaps accurately indicating that it
doesn't support your card then.

On 10/16/2008, Pat Double <email address hidden> wrote:
> It doesn't work :( I have used fglrx on this machine for at least a
> year, the last version was 8.9 on Hardy. There are two problems. The
> fglrx module won't load, I have included a kernel snippet. Perhaps the
> mtrr errors are important? The second is that X won't start.
>
> [ 54.001576] mtrr: base(0xf0000000) is not aligned on a size(0x7ff0000)
> boundary
> [ 61.356036] eth0: no IPv6 routers present
> [ 131.947429] mtrr: no MTRR for f0000000,7ff0000 found
> [ 151.017569] pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
> [ 161.449071] mtrr: base(0xf0000000) is not aligned on a size(0x7ff0000)
> boundary
> [ 181.315090] fglrx: module license 'Proprietary. (C) 2002 - ATI
> Technologies, Starnberg, GERMANY' taints kernel.
> [ 181.358014] [fglrx] Maximum main memory to use for locked dma buffers:
> 1896 MBytes.
> [ 181.359293] [fglrx:drm_alloc] *ERROR* [driver] Allocating 0 bytes
> [ 181.374755] [fglrx:firegl_init_device_list] *ERROR* Out of memory when
> allocating device heads
> [ 181.390432] [fglrx:firegl_init_module] *ERROR* firegl_init_devices failed
> [ 376.592709] mtrr: no MTRR for f0000000,7ff0000 found
> [ 450.141471] mtrr: base(0xf0000000) is not aligned on a size(0x7ff0000)
> boundary
>
>
> ** Attachment added: "/var/log/Xorg.0.log"
> http://launchpadlibrarian.net/18618768/Xorg.0.log.baseconf-with-fglrx
>
> --
> jockey does not offer fglrx for ATI Radeon Mobility 9700
> https://bugs.launchpad.net/bugs/284408
> You received this bug notification because you are subscribed to fglrx-
> installer in ubuntu.
>

--
Sent from my mobile device

Mario Limonciello
<email address hidden>

Attached is the user-manual/index.html file that came with this 8.543 driver.
It does show Mobility Radeon 9700 as supported.

Changed in fglrx-installer:
importance: Undecided → Medium
Marco (0m3g4) wrote :

Package: xorg-driver-fglrx
State: not installed
Version: 2:8.543-0ubuntu3
Priority: optional
Section: multiverse/misc
Maintainer: Mario Limonciello <email address hidden>
Uncompressed Size: 37.6M
Depends: libc6 (>= 2.2.4), libdrm2 (>= 2.3.0), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.3.5), libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libice6
         (>= 1:1.0.0), libsm6, libx11-6, libxcursor1 (> 1.1.2), libxext6, libxi6 (>= 2:1.1.3-1ubuntu3), libxrandr2, libxrender1, xserver-xorg-core,
         fglrx-kernel-source
Recommends: fglrx-amdcccle, libamdxvba1
Conflicts: fglrx-driver, nvidia-glx, nvidia-glx-173, nvidia-glx-177, nvidia-glx-71, nvidia-glx-96, nvidia-glx-legacy, nvidia-glx-new, xfree86-driver-fglrx
Replaces: fglrx-driver, xfree86-driver-fglrx
Description: Video driver for the ATI graphics accelerators
 Video driver for the ATI Radeon and FireGL graphics accelerators.

 This version of the ATI driver officially supports:
 * RADEON X1300, X1600, X1800, X1900
 * RADEON 8500, 9000, 9100, 9200, 9500, 9550, 9600, 9700, 9800
 * RADEON X800, X700, X600, X550, X300 series (AGP and PCI Express)
 * MOBILITY RADEON 9000, 9200, 9600, 9800, X700
 * MOBILITY RADEON 9000/9100 IGP Series
 * FireGL 8700, 8800, E1, E2, X1, X2, X3, Z1, T2
 * MOBILITY FireGL 9100, T2
 * RADEON XPRESS 200

 This package provides 2D display drivers and hardware accelerated OpenGL.
Homepage: http://ati.amd.com/support/driver.html

Pat Double (patdouble) wrote :

It seems there is some confusion about what the driver claims to support. In some documentation the Mobility 9700 is supported, in others it is not listed. I visited ATI's site and the Mobility 9700 is available in the driver selection and it goes to Catalyst 8.10.

In a previous note the lspci output reports my card as a 9600 M10. In the Xorg.0.log it reports as:

Chipset: "ATI Radeon Mobility 9600/9700 (M10/M11) NP (AGP)" (ChipID = 0x4e50)

Should upstream be contacted to determine if they intend to support the Mobility 9700 ? Up to Catalyst 8.9 the card has been supported. I have not tried 8.10 because I am using Intrepid.

Same problem here. I have an ATI Mobility Radeon 9700 that is identified by lspci as:

01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

Jockey doesn't list the fglrx driver and if I install it manually every attempt to insert the kernel module produces the following errors:

[ 1024.699204] [fglrx] Maximum main memory to use for locked dma buffers: 1169 MBytes.
[ 1024.700616] [fglrx:drm_alloc] *ERROR* [driver] Allocating 0 bytes
[ 1024.700683] [fglrx:firegl_init_device_list] *ERROR* Out of memory when allocating device heads
[ 1024.700757] [fglrx:firegl_init_module] *ERROR* firegl_init_devices failed

I also attached the output of dmesg.

Hardware: Acer TravelMate 4002LMi with ATI Mobility Radeon 9700
System: Kubuntu 8.10 (release candidate)

Mauricio Ramalho (phreaker) wrote :

I'm using a fresh installation of Intrepid (downloaded and installed today).

I have the same problem. My Mobility Radeon 9700 is listed as:

01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

Jockey won't display any drivers for me to download. I'm afraid of installing them manually because the last time I did that (on Hardy 8.04) the login screen went white (I found on my searches through Google some people calling it the white screen of death lol)

What can we do to fix this?

description: updated
description: updated
Changed in ubuntu-release-notes:
assignee: nobody → superm1
status: New → Fix Released
Changed in fglrx-installer:
importance: Medium → High

Same problem.my ATI Mobility Radeon 9700 that is identified by lspci as:

01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

stomlin (sethtomlin) wrote :

Does anyone know if ATI plans to re implement the 300 series chips in future releases, and also is 8.9 working in Intrepid. Thanks for any replies

Bryce Harrington (bryce) on 2008-10-30
Changed in fglrx:
importance: Undecided → High
status: New → Triaged
Bryce Harrington (bryce) wrote :

This issue has been upstreamed to AMD. They believe it matches one of two issues they know of (one is particular to AGP systems).

For now, r3xx users with this problem should focus on using the -ati or -vesa driver.

horizontaleight (mbyoung) wrote :

Thanks for the update, Bryce. I can also confirm a segmentation fault running aticonfig --initial on my Radeon 9700 pro after a manual installation on Intrepid. Jockey is still not displaying anything for restricted drivers. Is this still intentional because of this issue?

Hali (sahaly) wrote :

for my radeon 9700 TX the following instructions in a duplicate thread worked:
1. sudo apt-get remove --purge fglrx*
2. sudo apt-get remove --purge xserver-xorg-video-ati
xserver-xorg-video-radeon
3. sudo apt-get install xserver-xorg-video-ati

Waldeck Schützer (waldeck-dm) wrote :

I would like to report that upgrading from 8.04 to 8.10 disabled both 3D acceleration and wifi on my Acer Aspire 5100 notebook. Here is an excerpt from lscpi:

01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]
06:02.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)

Both required proprietary drivers to work properly and none are presently available. It is strange that Jockey will tell me that the fglrx driver is available but I cannot activate it. I am assuming that this is some leftover from the upgrade.

It is really unfortunate to loose all that functionality on an otherwise nice notebook. Perhaps in the future new upgrades will actually make things work better, not worse.

Waldeck

Tomasz Czapiewski (xeros) wrote :

I was scared by the Ubuntu 8.10 Release Notes instruction:
"ATI "fglrx" video support

The ATI video driver in 8.10 drops support for video cards with r300 based chips (the Radeon 9500 - X600 Series of cards). If you have such a card, please use "Hardware Drivers" at System/Administration to disable it before the upgrade. Please see bug 284408 for more information "

Is it confirmed that AMD has dropped support for R300 chips or is it just a bug in the new Xorg and kernel adaptation in the driver?
I use AMD FGLRX 8.10 driver on Hardy downloaded from AMD website and it works without problems on my (desktop) Radeon 9600 (RV350).
I was managing to upgrade to Intrepid in few days.

Patrick Dickey (pdickeybeta) wrote :

Like Thomas, I was concerned but I followed their instructions and disabled the driver. After restarting, I reactivated the driver that Ubunut offered me. Everything seems to be running alright.

"[ 21.015916] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[ 21.254211] [fglrx] Maximum main memory to use for locked dma buffers: 927 MBytes.
[ 21.254450] [fglrx] vendor: 1002 device: 4153 count: 1
[ 21.255269] [fglrx] ioport: bar 1, base 0xc000, size: 0x100
[ 21.255310] pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 21.256111] [fglrx] PAT is enabled successfully!
[ 21.274926] [fglrx] module loaded - fglrx 8.54.3 [Oct 10 2008] with 1 minors
..........
[ 54.151636] [fglrx] AGP detected, AgpState = 0x1f000207 (hardware caps of chipset)
[ 59.625790] agpgart-via 0000:00:00.0: AGP 2.0 bridge
[ 59.625855] agpgart-via 0000:00:00.0: putting AGP V2 device into 4x mode
[ 59.625924] fglrx_pci 0000:01:00.0: putting AGP V2 device into 4x mode
[ 59.625944] [fglrx] AGP enabled, AgpCommand = 0x1f000304 (selected caps)
[ 59.632699] [fglrx] Setup AGP aperture
[ 59.634285] [fglrx] GART Table is not in FRAME_BUFFER range
[ 59.646322] [fglrx] CMM init INV FB MC:0xc8000000, length:0x8000000
[ 59.646373] [fglrx] Reserved FB block: Shared offset:0, size:40000

" (from my dmesg results)

As far as I know, I have an ATI 9550 AGP video card. So, it recognizes that card. I'm not entirely sure where to find the exact maufacturer and model of the card though, since it's not showing in dmesg anywhere.

If there's anything else that I can (or need to) provide, let me know.
Have a great day:)
Patrick.

Same here on my 9600 - thankfully the OS driver is quite competent but I wouldn't mind the real deal as with this driver the screen doesn't turn off when the lid is closed.

On Sun, Nov 2, 2008 at 9:21 AM, David Taylor <email address hidden> wrote:
> Same here on my 9600 - thankfully the OS driver is quite competent but I
> wouldn't mind the real deal as with this driver the screen doesn't turn
> off when the lid is closed.
>

That just sounds like a power setting issue, make sure it is set to
blank screen appropriately in System -> Preferences -> Power
Management. Mine with a 9600 and the OS drivers actually turns off the
screen when closed.

I'm not sure if I'm seeing this same bug. Due to ATI's ornate nomenclature, I don't know if my machine is on the list of supported machines or not. (Has anyone got an ATI taxonomy?)

root@dzur:~# lspci | grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc RS690 [Radeon X1200 Series]
root@dzur:~# pre fglrx
root@dzur:~# lsmod | grep -i fgl
root@dzur:~#

I was able to use Hali's method (https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/284408/comments/15) to get the video-ati driver installed (xserver-xorg-video-ati-1:6.9.0+git20081003.f9826a56-0ubuntu2--i386). So far so good.

Two problems:

* I can only use one of my two monitors. This severely crimps my ability to earn my living. Thanks.

* The power control system does not shut off the one LCD monitor I can use. This means it sits there running at 40 watts instead of less than half a watt. It also means I have to turn it on and off manually, at least a 15 year regression.

I will enter separate bugs for these, but I will also go back to the ATI proprietary driver as soon as I can.

David A. Rountree (darountree) wrote :

My experience was like PatrickDickey's. I have a Gateway CX200X with a Mobility Raedon X600 video card. I disabled the proprietary flgrx driver, performed the upgrade to Ubuntu 8.10, and then activated the proprietary flgrx driver. No problems! 3D acceleration works as well as it ever did. The bootup is much faster than 8.04 as well.

montag (montag-fire) wrote :

Same problem here.
With a new installed Kubuntu 8.10, jockey-kde doesn't detect my Ati Radeon Mobile 9600 as needing for the restricted driver.
I also tried with Envy-ng, but same problem: the Ati driver 8.543-0ubuntu4 is listed as NOT compatible.

lspci:
01:00.0 VGA compatible controller: Ati Technologies Inc RV350 [Mobility Radeon 9600 M10]

Michael Vogt (mvo) on 2008-11-04
Changed in update-manager:
assignee: nobody → mvo
importance: Undecided → Medium
milestone: none → intrepid-updates
status: New → In Progress
status: New → Invalid
Michael Vogt (mvo) on 2008-11-04
description: updated
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in fglrx-installer:
status: New → Fix Committed
Changed in update-manager:
status: New → Fix Committed
Martin Pitt (pitti) on 2008-11-04
Changed in fglrx-installer:
status: Fix Committed → Triaged
Esteban00 (esteban-diezlaiz) wrote :

Sorry Martin, what have been added on proposed repos ?
A new driver update ?
i only saw some updates for Compiz and nothing more ...

Esteban00:

This is an update to transition people with r3xx away from fglrx to the open
source driver. It's applicable to anyone running hardy w/ r3xx and fglrx
that is considering upgrading.

On Tue, Nov 4, 2008 at 14:24, Esteban00 <email address hidden> wrote:

> Sorry Martin, what have been added on proposed repos ?
> A new driver update ?
> i only saw some updates for Compiz and nothing more ...
>
> --
> r3xx Hardware does not work with fglrx
> https://bugs.launchpad.net/bugs/284408
> You received this bug notification because you are a bug assignee.
>

--
Mario Limonciello
<email address hidden>

Oleksiy Kokachev (lelikv) wrote :

Dear Mario.
Why the status of this bug for Intrepid is marked as "Fix Commited"?
Where is the "fix" itself? Problem is still there.

On Wed, Nov 5, 2008 at 7:31 AM, Mario Limonciello <email address hidden>wrote:

> Esteban00:
>
> This is an update to transition people with r3xx away from fglrx to the
> open
> source driver. It's applicable to anyone running hardy w/ r3xx and fglrx
> that is considering upgrading.
>
> On Tue, Nov 4, 2008 at 14:24, Esteban00 <email address hidden>
> wrote:
>
> > Sorry Martin, what have been added on proposed repos ?
> > A new driver update ?
> > i only saw some updates for Compiz and nothing more ...
> >
> > --
> > r3xx Hardware does not work with fglrx
> > https://bugs.launchpad.net/bugs/284408
> > You received this bug notification because you are a bug assignee.
> >
>
>
> --
> Mario Limonciello
> <email address hidden>
>
> --
> r3xx Hardware does not work with fglrx
> https://bugs.launchpad.net/bugs/284408
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

@Oleksity: the fix is that update-manager detects the non-longer supported cards and offers to transition them to the free ati driver. We can not fix fglrx itself because we have no access to the source code. If you are affected help with the steps in "TEST CASE" in the description would be much appreciated so that we can ensure the fix works for everyone.

Michael, I am reading a conflicting message from your last statement:

"the non-longer supported cards"

"We can not fix fglrx itself"

Is this due to ati dropping support for these cards or due to a bug in the driver, both are implied in your last statement or do we just not know?

Tomasz Czapiewski (xeros) wrote :

Yesterday I've installed Intrepid (Kubuntu) with Radeon 9600 and the installation went without problems with xserver-xorg-video-ati as default video driver. (Internet connection was enabled durring installation)
I've tested livecd on other computers with R300 cards (like X300 and some motherboard-integrated) - everywere the livecd used xserver-xorg-video-ati driver, desktop effects were enabled, glxinfo and xvinfo worked OK.

If fglrx cannot be fixed without AMD/ATI, will you provide updated fglrx driver in intrepid-updates when AMD/ATI release new driver this month?
xserver-xorg-video-ati driver works without problems but fglrx driver provides better speed and many more opengl functions for these cards.

Esteban00 (esteban-diezlaiz) wrote :

So the fix is to use free drivers instead of fglrx.
I'm using xserver-xorg-video-radeon packages, are they the same xserver-xorg-video-ati one ?
For desktop use they seen to be ok, so use them instead of fglrx, t'll AMD/ATI release a new driver supporting R3xx chipsets.

The fix here is not a "fix" for the fglrx issues as those will have to
be resolved by AMD/ATI. The fix is for Ubuntu users who are upgrading
to Intrepid and using the fglrx driver, the upgrade will prompt them
to disable the restricted driver and use one of the open source ones.
That is, Intrepid users with R300 drivers should use the open source
drivers for the time being.

No doubt this is a triage fix in order to prevent an "unusable" system
following an upgrade - which depending on AMD/ATI's resolution will
have a more permanent solution in the future -- fix the bug for R300
hardware, or discontinue support for it. Due to the widespread use of
this hardware I would assume that the latter will be the choice with
support being discontinued in the not-so-distance future.

Regards, Cole

On Wed, Nov 5, 2008 at 9:58 AM, Esteban00 <email address hidden> wrote:
> So the fix is to use free drivers instead of fglrx.
> I'm using xserver-xorg-video-radeon packages, are they the same xserver-xorg-video-ati one ?
> For desktop use they seen to be ok, so use them instead of fglrx, t'll AMD/ATI release a new driver supporting R3xx chipsets.
>
> --
> r3xx Hardware does not work with fglrx
> https://bugs.launchpad.net/bugs/284408
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Cole Nielsen

Could anybody point me in the direction of how to use the open drivers, I reinstalled Ubuntu, tried to do as Hali suggested but the package ati wasn't found tried radeon, no luck I thik I'll have to go back to hardy

I'm probably going to get frowned upon because this is a question for the forums but hey ho. The open drivers should have installed automatically and it is the 'xserver-xorg-video-ati' driver however if you have already installed the 'xorg-driver-fglrx' package you will need to 'sudo apt-get remove xorg-driver-fglrx' as it seems now that x11 is not dependant on the xorg.conf file it automatically picks the fglrx driver but I think specifying the ati driver in the xorg file should also suffice. The reason I answer this here at the risk of getting frowned upon is that the new version of 'Adept' in Kubuntu is very poor and search results are pretty terrible so I have had my own brand of troubles in a similar vein and found using 'apt-cache search' a much superior tool.

Oleksiy Kokachev (lelikv) wrote :

Dear Mario.
I think it's a good idea to mark fglrx-driver and xserver-xorg-video-ati as conflicting packages. Installing of xserver-xorg-video-ati should automatically remove fglrx-driverand vise-versa, because these packages replace files of each other, thus they are conflicting.

Bryce Harrington (bryce) wrote :

This issue has been forwarded to AMD as EPR#257839.

I understand there are a number of bugs duped to this, and several people feeling they're seeing this same issue, and it's great seeing people share workaround tips, but please take care not to clutter this bug with unrelated information or unnecessary "me-too's", because it could make it confusing for the people who will be working to try to solve this problem.

Changed in fglrx:
importance: High → Medium
Martin Pitt (pitti) wrote :

update-manager copied to intrepid-updates. Michael, please upload the fix to jaunty, too.

Changed in update-manager:
status: Fix Committed → Fix Released
milestone: none → intrepid-updates
milestone: intrepid-updates → jaunty-alpha-1
Matthew Helmke (matthelmke) wrote :

In the new release, Catalyst 8.11, the release notes state support for many of the cards that have been experiencing troubles.

Here is the link: https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/catalyst_811_linux.pdf

Sorry it is a pdf, that is how it is linked from the main site here: http://ati.amd.com/support/drivers/linux/linux-radeon.html

I am posting this in the hopes that once it is seen someone will have time to give it a test and perhaps get it into Intrepid Proposed for testing.

Matthew Helmke (matthelmke) wrote :

Wait, the new release I just mentioned supports up to xorg 7.3, it does not mention 7.4, so what I said above may be useless info. Sorry for the static.

W. Prins (wprins) wrote :

Well, the new 8.11 ATI driver release cured the problems for me. I have an ATI Radeon 9800XT (RV350/R360). (I downloaded the 8.11 driver from ATI and installed that, then went back into the System->Administration->Hardware drivers and enabled there as well. Driver is working fine.

Changed in fglrx-installer:
status: Triaged → Fix Released
description: updated
Changed in fglrx-installer:
milestone: none → intrepid-updates
Martin Pitt (pitti) on 2008-11-14
Changed in fglrx-installer:
milestone: intrepid-updates → none
status: Triaged → Fix Committed
Michael Vogt (mvo) on 2008-11-20
Changed in update-manager:
status: In Progress → Fix Committed
Steve Langasek (vorlon) on 2008-11-25
Changed in update-manager:
milestone: jaunty-alpha-1 → jaunty-alpha-2
Changed in fglrx-installer:
status: Fix Released → Triaged
Changed in update-manager:
status: Fix Committed → Fix Released
Michael Rooney (mrooney) on 2008-12-23
description: updated
Michael Rooney (mrooney) on 2008-12-23
description: updated
78 comments hidden view all 158 comments

Yep the preview driver works for me on my 9600 albet the text (font seems smaller) and some colours (the Opera O looks red) are a little odd but thats to be expected for a preview driver.

OK, the open-source-driver works with my ATI Technologies Inc RV350 [Mobility Radeon 9600 M10].
The reaseon, why X was freezing a few seconds after starting was another bug:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/220345

Sorry for posting here and thanks to axel for a hint via e-mail.

Alexander

Marco (0m3g4) wrote :

EDIT POST wrote on 2009-01-24 (fglrx 9.2 + Jaunty)

tried to install with:
--buildpkg Ubuntu/Jaunty (method 1)
catalyst installer (method 2)

(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for 1.4.99.906, module version = 8.58.2
        Module class: X.Org Video Driver
[atiddxSetup] X version mismatch - detected X.org 7.1.-1.901, required X.org 7.4.-1.906
(II) UnloadModule: "fglrx"
(II) Unloading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)

NiksaVel (nikola-leder) wrote :

I've installed the driver and got it running under kubuntu 8.10 however I've noticed a considerable drop in FPS when running videos in fullscreen via VLC (didn't try anything else, cuz I wanna use VLC)... can any1 confirm this? It's running normal in windowed but it's all slow and choppy in fullscreen...

The CPU is at approx. 50% use when running so it's not the CPU limit...

Running it on mobility 9700 on a centrino 1.6 laptop with 1gig ram

Marco (0m3g4) wrote :

catalyst 9.1 out: no R300 support

omega wrote:
> catalyst 9.1 out: no R300 support

I got the same error: (EE) No devices detected...I used the manual
method with 2.6.27-11-generic kernel

I have attached the full xorg log

That's gettin annoying :-(

Noiano

The ATI QA team must be non existant or not testing for the full range of hardware they say they are.

Andrew (arosborough) wrote :

Last weekend I decided to attempt to install the beta driver that Pet linked on 2009-01-23, after seeing that it solved issues for mobility 9700 users.

I was able to successfully install, and after failing to configure dual head correctly, was able to at run startx as root and see a basic grey background and cursor at a fairly high resolution (between 1024x768 and 1400x900). When I decided to go back to runlevel 5 (was previously at run level 3 to test), the gdm login was not able to render correctly and X11 had to be killed w/ ctrl backspace.

At this point I remember seeing some notice that my ext3 file system had been remounted read only due to errors. I ran e2fsck which proceded to move a majority of my filesystem to lost+found, and did not complete successfully several times using the -y or -a flags (it stopped responding for more than an hour on cloning one file w/ multiply claimed inodes). In the end I lost my etc, usr, and sys folders (probably more). Luckily my home directory was left intact, and I backed it up to another partition.

I have attached an error log. As far as I could tell, I was able to load the fglrx beta module and get it to correctly display on my monitor briefly. However, it was not stable and potentially lead to my file system becoming corrupted.

I took this opportunity to install ubuntu 8.04, and I am not upgrading to 8.10 any time soon. Fglrx proprietary drivers work wonderfully in 8.04 LTS, but the xorg 7.4 issue was so frustrating that I was tempted to go out and get an nvidia card (hope you're reading ati). Hopefully new documentation from amd will include specs for the old r300 chipsets, and this will improve 3d and 2d support in the open source drivers significantly.

Some details about my system:

Motherboard: MSI Kt4v-l (ms-6712)
Graphics Card: Tyan 9700Pro
Memory: 3GB pc 2700

Thank you everyone who has been helping out on this issue.

Martin Pitt (pitti) wrote :

Removed from intrepid-proposed as per Mario's request.

Changed in fglrx-installer:
status: Fix Committed → Triaged
Bryce Harrington (bryce) on 2009-02-04
Changed in fglrx-installer:
status: Triaged → Won't Fix
fanou (stephane-vernede) wrote :

I have an IBM thinkpad T40
lspci gives :
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]

I have tested the beta driver that Pet linked on 2009-01-23.
 sudo aticonfig --initial -f
gives
aticonfig: No supported adapters detected

apparently this card is not supported by the beta driver.
Is it possible to add this card on the list of unsuported cards?
Does anybody knows if there is an hope that ATI writes a Linux driver for this card?

Thanks

Pizuz (florian-fahr) wrote :

Sorry to tell you, but support for your card has been dropped aeons ago and I don't think ATI plans to bring back support. Even the Windows driver doesn't support it anymore, as far as I know.

7500 chip has been, and is still supported in the Windows driver. Not sure
what your talking about.

On Mon, Feb 9, 2009 at 3:58 AM, F-3582 <email address hidden> wrote:

> Sorry to tell you, but support for your card has been dropped aeons ago
> and I don't think ATI plans to bring back support. Even the Windows
> driver doesn't support it anymore, as far as I know.
>
> --
> r3xx Hardware does not work with fglrx [EPR#257839]
> https://bugs.launchpad.net/bugs/284408
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in AMD fglrx video driver: Triaged
> Status in Ubuntu Release Notes: Fix Released
> Status in Update Manager: Invalid
> Status in "fglrx-installer" source package in Ubuntu: Triaged
> Status in "update-manager" source package in Ubuntu: Fix Released
> Status in fglrx-installer in Ubuntu Intrepid: Won't Fix
> Status in update-manager in Ubuntu Intrepid: Fix Released
> Status in fglrx-installer in Ubuntu Jaunty: Triaged
> Status in update-manager in Ubuntu Jaunty: Fix Released
>
> Bug description:
> Using fglrx-installer 2:8.543-0ubuntu4, r3xx hardware such as Radeon 9500,
> Mobility Radeon 9700 and similar don't work
>
> They are not explicitly listed in the modaliases, so they will not be
> offered by Jockey. In the past, this hardware did work with the fglrx
> driver. Now the fglrx driver indicates memory errors when trying to load.
>
> Here is a snippet of what the memory error will look like:
> [ 1024.699204] [fglrx] Maximum main memory to use for locked dma buffers:
> 1169 MBytes.
> [ 1024.700616] [fglrx:drm_alloc] *ERROR* [driver] Allocating 0 bytes
> [ 1024.700683] [fglrx:firegl_init_device_list] *ERROR* Out of memory when
> allocating device heads
> [ 1024.700757] [fglrx:firegl_init_module] *ERROR* firegl_init_devices
> failed
>
> WORKAROUND:
> You'll need to completely remove the proprietary driver and [re]install the
> open-source driver. As a plus, many users report improved performance with
> the open-source drivers in Intrepid versus ATI's fglrx in Hardy for 2D
> purposes such as normal desktop use and video playback.
> 1. sudo apt-get remove --purge fglrx*
> 2. sudo apt-get remove --purge xserver-xorg-video-ati
> xserver-xorg-video-radeon
> 3. sudo apt-get install xserver-xorg-video-ati
> 4. Restart.
>
> TEST CASE:
> 1. Install intrepid w/ r3xx hardware.
> 2. attempt to activate fglrx and reboot verifying unable to start X
> 3. Activate intrepid-proposed
> 4. update to new fglrx version, verify that X starts up properly
>

fanou (stephane-vernede) wrote :

Sorry to tell you, but support for your card has been dropped aeons ago and I don't think ATI plans to bring back support. Even the Windows driver doesn't support it anymore, as far as I know.

Thanks F-3582 for your answer.
I didn't have much hope about it.
By the way does somebodoy knows if it is possible to activate the pbuffer on such a card with intrepid
(see post http://ubuntuforums.org/showthread.php?t=1064237)

thanks

Martin Pitt (pitti) wrote :

This isn't really a release blocker for Jaunty. update-manager transitions r3xx users to -ati, which works well enough. This is a target of opportunity at most.

Changed in fglrx-installer:
importance: High → Medium
status: Triaged → Won't Fix
Neal Gompa (ngompa13) wrote :

Nope. Its a target of stupidity at most, and target of problems at least. None of the FOSS drivers support OpenGL 2(.1) or OpenGL 3.0. The ATI FOSS drivers do not support FBOs, which are needed by quite a few OpenGL-based games, especially emulators of game consoles. If you can bring up full OpenGL 2.1 + GLSL support by Jaunty for the FOSS driver, THEN it would be a target of opportunity. Otherwise you are just damning ATI card users. Besides, it seems that the FOSS driver is horribly unoptimized on OpenGL with Wine. fglrx has wonderful OpenGL/WineD3D performance.

Neal Gompa (ngompa13) wrote :

Besides, Catalyst 9.2 finally fixes this issue, however, it will not work without a screen configuration set in xorg.conf. So in a future Ubuntu update, a screen configuration MUST be saved into xorg.conf for it to work...

On Sat, Feb 21, 2009 at 01:09:10AM -0000, Neal Gompa wrote:
> Nope. Its a target of stupidity at most,

This is not an appropriate tone to take in bug reports. Please refrain from
such remarks in the future; they will only serve to get you ignored.

> None of the FOSS drivers support OpenGL 2(.1) or OpenGL 3.0.

And the binary-only driver doesn't support this hardware. This is not under
the control of the Ubuntu team.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Arkhitekton (arkhitekton) wrote :

Following on from the reports that Catalyst 9.2 fixes the problems: Unfortunately it does not fix the problem on my Dell Inspiron 9100. lspci reports the graphics card as:
     01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
The laptop has a fresh installation of Ubuntu 8.10 from the alternative CD. The Proposed packages have been installed, as described earlier in this bug thread. uname -a reports:
Linux tux9100 2.6.27-12-generic #1 SMP Thu Feb 5 09:26:35 UTC 2009 i686 GNU/Linux

The ATI Catalyst 9.2 Linux driver installer, ati-driver-installer-9.2-x86.x86_64.run, was downloaded from the ATI site. The installer was run and the machine rebooted. I open the System -> Administration -> Hardware Drivers window. The ATI drivers were shown to be present but not enabled. At this point compiz.real failed and apport reported a bug which has been filed as Bug #332644. I then tried to enable the ATI driver. Apport then reported that:
     package xorg-driver-fglrx 2:8.543-0ubuntu4.1 failed to install/upgrade: EOF on stdin at conffile prompt
and lead me back here as a likely previously reported bug.

Anyway, I wanted others to know that Catalyst 9.2 might not be the fix they hoped. I realise that the Ubuntu maintainers can't do much about this - but thanks for your efforts so far. Its an ATI problem. Hopefully ATI read the thread and will try and get a fix, or open their API.

stomlin (sethtomlin) wrote :

9.2 fixed the problem for me. I have a Asus z80k with a mobile 9700 pro (rv350)
I installed them manually using the install method here... http://wiki.cchtml.com/index.php/Ubuntu_Intrepid_Installation_Guide
Hooorraaay!

hegemon8 (pantokrata2) wrote :

Thanks. I had major problems with graphics in my Kubuntu Jaunty (alpha4) and Radeon X 700 Pro on PCI Express. No OpenGL apps (ok - games mostlly :) )were working as in Interpid. This Workaround solved my issues :)

stomlin wrote:
> 9.2 fixed the problem for me. I have a Asus z80k with a mobile 9700 pro (rv350)
> I installed them manually using the install method here... http://wiki.cchtml.com/index.php/Ubuntu_Intrepid_Installation_Guide
> Hooorraaay!

Everything is ok also with ati radeon 9500 pro. One little problem: the
intial login screen has a resolution of 1600x1200 which is out of the
range of my lcd screen. How do I set as default resolution 1024x768?

thanks

On Tue, Feb 24, 2009 at 2:10 AM, Noiano <email address hidden> wrote:

> stomlin wrote:
> > 9.2 fixed the problem for me. I have a Asus z80k with a mobile 9700 pro
> (rv350)
> > I installed them manually using the install method here...
> http://wiki.cchtml.com/index.php/Ubuntu_Intrepid_Installation_Guide
> > Hooorraaay!
>
> Everything is ok also with ati radeon 9500 pro. One little problem: the
> intial login screen has a resolution of 1600x1200 which is out of the
> range of my lcd screen. How do I set as default resolution 1024x768?
>
> thanks
>
> --
> r3xx Hardware does not work with fglrx [EPR#257839]
> https://bugs.launchpad.net/bugs/284408
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Make a subsection in the Screen section and insert only modes that you want
it to be able to access, setting it from highest to lowest. Alternatively,
use aticonfig to do it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.600-0ubuntu1

---------------
fglrx-installer (2:8.600-0ubuntu1) jaunty; urgency=low

  * New upstream release. (Closes LP: #313027, #314600)
    - Fixes LP: #253988, #179042, #241176, #284408, #287229, #296497,
      #288620, #289628
  * README.Debian: Update the update procedure a bit

 -- Bryce Harrington <email address hidden> Tue, 17 Mar 2009 15:40:42 -0700

Changed in fglrx-installer:
status: Won't Fix → Fix Released
Bryce Harrington (bryce) wrote :

Actually this one is not closed quite yet.

Changed in fglrx-installer (Ubuntu Jaunty):
status: Fix Released → Triaged
Laurent Bigonville (bigon) wrote :

I think that this bug will never be fixed, AMD/ATI will dropped pre-r500 support next month and as the current version doesn't support Xorg 1.6...

See: http://www.phoronix.com/scan.php?page=article&item=amd_r500_legacy&num=1

Ingomar Wesp (ingomar) wrote :

Since it will be a long time until the OSS ati driver delivers reasonable OpenGL support on r300-based cards, this really is a bummer. People who don't know how to install an older X Server are basically forced to stay with 8.04 if they want fast 3D graphics. And considering all the r300-based notebooks out there, buying a new graphics card is often not an option :(

paulomaia (paulo-maia-di) wrote :

They can actually stay with 8.10.
At least for my mobility radeon 9600 everything is ok with this last
driver (except dual monitor support)...

Ingomar Wesp wrote:
> Since it will be a long time until the OSS ati driver delivers
> reasonable OpenGL support on r300-based cards, this really is a bummer.
> People who don't know how to install an older X Server are basically
> forced to stay with 8.04 if they want fast 3D graphics. And considering
> all the r300-based notebooks out there, buying a new graphics card is
> often not an option :(
>
>

Hanno Meyer-Thurow (h.mth) wrote :

I wonder if it is too hard to do name-version packages like for nvidia packages. :)
See: http://packages.ubuntu.com/search?keywords=nvidia&searchon=names&suite=intrepid&section=all

Neal Gompa (ngompa13) wrote :

I would suggest that if possible we could hold in catalyst 9.3 for r300-r500
support, since those were dropped in 9.4.

On Wed, Mar 18, 2009 at 5:06 PM, Hanno Meyer-Thurow <email address hidden> wrote:

> I wonder if it is too hard to do name-version packages like for nvidia
> packages. :)
> See:
> http://packages.ubuntu.com/search?keywords=nvidia&searchon=names&suite=intrepid&section=all
>
> --
> r3xx Hardware does not work with fglrx [EPR#257839]
> https://bugs.launchpad.net/bugs/284408
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Pizuz (florian-fahr) wrote :

That would be nice, but unfortunately impossible because of the previously mentioned incompatibility with XServer 1.6 which will be introduced in Ubuntu 9.04.

Didn't I read somewhere that AMD had intended to keep a legacy branch that supposedly was to be updated every three months? What happened to those plans?

On Thu, Mar 19, 2009 at 12:34:43AM -0000, F-3582 wrote:
> That would be nice, but unfortunately impossible because of the
> previously mentioned incompatibility with XServer 1.6 which will be
> introduced in Ubuntu 9.04.
>
> Didn't I read somewhere that AMD had intended to keep a legacy branch
> that supposedly was to be updated every three months? What happened to
> those plans?

I've never heard any such plans. nvidia does that though, maybe that's
what you're thinking of?

Bryce

Pizuz (florian-fahr) wrote :

I read that on Heise a month ago, just prior to those announcements that AMD were to drop support for those chips entirely.

On Sun, Mar 22, 2009 at 5:35 AM, F-3582 <email address hidden> wrote:

> I read that on Heise a month ago, just prior to those announcements that
> AMD were to drop support for those chips entirely.

Then it looks like we will be leaving them out cold as far as OpenGL 2.1
support then. None of the existing FOSS drivers support OpenGL 2.1, and as
far as I know, everybody is focused on bringing Gallium3D in to offer that
support, but it seems it won't be ready before April distro release. Really,
that leaves two options, either use Git Mesa code with Gallium3D and hope
for the best, or hold back Xserver to version 1.5, which I doubt will
happen. However, something DOES need to be done about this.

I get the memory error with my Compaq V2402. Radeon Xpress 200M, jaunty devel, xorg-driver-fglrx 2:8.600-0ubuntu1 and kernel 2.6.28-11-generic i686.

root@zing: modprobe fglrx
[ 3951.240066] [fglrx] Maximum main memory to use for locked dma buffers: 1765 MBytes.
[ 3951.240238] [fglrx:drm_alloc] *ERROR* [driver] Allocating 0 bytes
[ 3951.240290] [fglrx:firegl_init_device_list] *ERROR* Out of memory when allocating device heads
[ 3951.240343] [fglrx:firegl_init_module] *ERROR* firegl_init_devices failed

Another possible dup over at #346803

Brett Johnson (linuxturtle) wrote :

I've got the same problem on my HP/Compaq 6910p with a Mobility Radeon X2300 and jaunty,

Note that fglrx worked swimmingly on Intrepid on this laptop.

 [10857.047402] [fglrx] Maximum main memory to use for locked dma buffers: 1856 MBytes.
 [10857.048568] [fglrx:drm_alloc] *ERROR* [driver] Allocating 0 bytes
 [10857.048576] [fglrx:firegl_init_device_list] *ERROR* Out of memory when allocating device heads
 [10857.048584] [fglrx:firegl_init_module] *ERROR* firegl_init_devices failed

> uname -a
Linux nandi 2.6.28-11-generic #38-Ubuntu SMP Fri Mar 27 09:00:52 UTC 2009 i686 GNU/Linux

> dpkg -l | grep fglrx
ii fglrx-amdcccle 2:8.600-0ubuntu2 Catalyst Control Center for the ATI graphics accelerators
ii fglrx-kernel-source 2:8.600-0ubuntu2 Kernel module source for the ATI graphics accelerators
ii fglrx-modaliases 2:8.600-0ubuntu2 Identifiers supported by the ATI graphics driver
ii xorg-driver-fglrx 2:8.600-0ubuntu2 Video driver for the ATI graphics accelerators

> lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc M64-S [Mobility Radeon X2300]

Bryce Harrington (bryce) wrote :

AMD no longer supports pre-r600 hardware on fglrx, so we're closing this bug as wontfix at this time.

Going forward, Ubuntu will be focusing efforts around -ati for this hardware.

Changed in fglrx-installer (Ubuntu Jaunty):
status: Triaged → Won't Fix
Bryce Harrington (bryce) on 2009-04-08
Changed in fglrx-installer (Ubuntu):
status: Triaged → Won't Fix
Changed in fglrx:
status: Triaged → Won't Fix
DougL (dlarue) wrote :

this is tough and problematic and we were very lucky to have 8.04(LTS) 3D accelerated fglrx working. But it means we can't get updated software via Ubuntu and can only run what's already in the repo. It means that if you require 3D acceleration, you/we are stuck on 8.04 forever. The way it seems is the cause is because ATI/AMD stopped supporting some popular graphics chips and that means they not only stopped adding fixes but they stopped bringing the existing driver forward to new X11 server versions. Combine that with Canonical moving quite fast with updates and moving X11 forward and you have orphaned users who have to stay out of date or abandon good hardware and purchase new hardware which is currently supported. Desktop users can just throw out a card, laptop users must throw out the entire computer.

This is not good and with 10s of millions of Linux users and the number growing quickly, this is going to be a much larger problem. Isn't there a way to bring older versions of X forward to help ease the pain or are kernel ties also problematic?

Carey Underwood (cwillu) wrote :

The release notes don't say anything about the drop in support. It's causing confusion.

Changed in ubuntu-release-notes:
status: Fix Released → Confirmed
shell (shell-pcspinnt) wrote :

Does anybody know if there will be a solution. I have a dell inspiron 6400 with an ati x1400 and i have the same error.

When i try to load the the fglrx module i get

FATAL: Error inserting fglrx (/lib/modules/2.6.27-9-generic/updates/dkms/fglrx.ko): Cannot allocate memory

vyncere (vyncere) wrote :

Sorry for the "Nominate for release Karmic". I misunderstood the effect of this action.
I just wanted to report/link this problem to Karmic too.

1) Hardware
01:00.0 VGA compatible controller: ATI Technologies Inc M10 NT [FireGL Mobility T2] (rev 80)

2) Module fglrx: vendor="FireGL - ATI Technologies Inc.", compiled for 1.4.99.906, module version = 8.66.10
Package: xorg-driver-fglrx
New: yes
State: not installed
Version: 2:8.660-0ubuntu4

3) Modprobing error
FATAL: Error inserting fglrx (/lib/modules/2.6.31-14-generic/updates/dkms/fglrx.ko): Cannot allocate memory

mattrenfer (mr-renfer) on 2010-03-08
description: updated
Changed in ubuntu-release-notes:
status: Confirmed → Invalid
assignee: Mario Limonciello (superm1) → nobody
Displaying first 40 and last 40 comments. View all 158 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.